Quantcast

Cannot start Galaxy DistributionNotFound: Paste

classic Classic list List threaded Threaded
2 messages Options
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Cannot start Galaxy DistributionNotFound: Paste

marcelo_t


Guys


I am running CentOS 6.8 in a virtualenv and no matter what, I always get pkg_resources.DistributionNotFound: Paste

These were the commands to install and launch Galaxy


hg clone https://bitbucket.org/galaxy/galaxy-dist
wget http://bitbucket.org/ianb/virtualenv/raw/tip/virtualenv.py

/usr/local/bin/python2.7 virtualenv.py --no-site-packages galaxy_env

. ./galaxy_env/bin/activate

source ~/galaxy_env/bin/activate

sh galaxy-dist/run.sh


and even tried to start with some workarounds found in the web (in no particular order):


cd /home/galaxy/galaxy-dist && ./scripts/common_startup.sh

./scripts/common_startup.sh --skip-venv --dev-wheels

sh galaxy-dist/run.sh --skip-venv --dev-wheels

sh galaxy-dist/run.sh --skip-venv

sh galaxy-dist/run.sh --replace-pip

easy_install paste


Also install or upgrade doesn't solve the problem:


(galaxy_env)bash-4.1$ pip install paste
Requirement already satisfied (use --upgrade to upgrade): paste in ./galaxy_env/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): six in ./galaxy_env/lib/python2.7/site-packages (from paste)


(galaxy_env)bash-4.1$ pip install paste --upgrade
/home/galaxy/galaxy_env/lib/python2.7/site-packages/pip-8.1.2-py2.7.egg/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/galaxy/galaxy_env/lib/python2.7/site-packages/pip-8.1.2-py2.7.egg/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Collecting paste
  Using cached Paste-2.0.3-py2-none-any.whl
Collecting six>=1.4.0 (from paste)
  Using cached six-1.10.0-py2.py3-none-any.whl
Installing collected packages: six, paste
  Found existing installation: six 1.9.0
    Uninstalling six-1.9.0:
      Successfully uninstalled six-1.9.0
  Found existing installation: Paste 2.0.2
    Uninstalling Paste-2.0.2:
      Successfully uninstalled Paste-2.0.2
Successfully installed paste-2.0.3 six-1.10.0


Using common_startup.sh also doesn't solve the problem:


(galaxy_env)bash-4.1$ cd /home/galaxy/galaxy-dist && ./scripts/common_startup.sh
Activating virtualenv at .venv
Ignoring indexes: https://pypi.python.org/simple
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Requirement already up-to-date: pip==8.0.2+gx2 in ./.venv/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): bx-python==0.7.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe==0.23 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 3))
Requirement already satisfied (use --upgrade to upgrade): PyYAML==3.11 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 4))
Requirement already satisfied (use --upgrade to upgrade): SQLAlchemy==1.0.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 5))
Requirement already satisfied (use --upgrade to upgrade): mercurial==3.4.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 7))
Requirement already satisfied (use --upgrade to upgrade): numpy==1.9.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 8))
Requirement already satisfied (use --upgrade to upgrade): pycrypto==2.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 9))
Requirement already satisfied (use --upgrade to upgrade): Paste==2.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 16))
Requirement already satisfied (use --upgrade to upgrade): PasteDeploy==1.5.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 17))
Requirement already satisfied (use --upgrade to upgrade): docutils==0.12 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 18))
Requirement already satisfied (use --upgrade to upgrade): wchartype==0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 19))
Requirement already satisfied (use --upgrade to upgrade): repoze.lru==0.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 20))
Requirement already satisfied (use --upgrade to upgrade): Routes==2.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 21))
Requirement already satisfied (use --upgrade to upgrade): WebOb==1.4.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 22))
Requirement already satisfied (use --upgrade to upgrade): WebHelpers==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 23))
Requirement already satisfied (use --upgrade to upgrade): Mako==1.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 24))
Requirement already satisfied (use --upgrade to upgrade): pytz==2015.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 25))
Requirement already satisfied (use --upgrade to upgrade): Babel==2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 26))
Requirement already satisfied (use --upgrade to upgrade): Beaker==1.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 27))
Requirement already satisfied (use --upgrade to upgrade): Cheetah==2.4.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 30))
Requirement already satisfied (use --upgrade to upgrade): Markdown==2.6.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 31))
Requirement already satisfied (use --upgrade to upgrade): bioblend==0.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 34))
Requirement already satisfied (use --upgrade to upgrade): boto==2.38.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 35))
Requirement already satisfied (use --upgrade to upgrade): requests==2.8.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 36))
Requirement already satisfied (use --upgrade to upgrade): requests-toolbelt==0.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 37))
Requirement already satisfied (use --upgrade to upgrade): kombu==3.0.30 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 40))
Requirement already satisfied (use --upgrade to upgrade): amqp==1.4.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 41))
Requirement already satisfied (use --upgrade to upgrade): anyjson==0.3.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 42))
Requirement already satisfied (use --upgrade to upgrade): sqlalchemy-migrate==0.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 45))
Requirement already satisfied (use --upgrade to upgrade): decorator==4.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 46))
Requirement already satisfied (use --upgrade to upgrade): Tempita==0.5.3dev in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 47))
Requirement already satisfied (use --upgrade to upgrade): sqlparse==0.1.16 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 48))
Requirement already satisfied (use --upgrade to upgrade): pbr==1.8.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 49))
Requirement already satisfied (use --upgrade to upgrade): six==1.9.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 51))
Requirement already satisfied (use --upgrade to upgrade): Parsley==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 52))
Requirement already satisfied (use --upgrade to upgrade): nose==1.3.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 53))
Requirement already satisfied (use --upgrade to upgrade): SVGFig==1.1.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 54))
Requirement already satisfied (use --upgrade to upgrade): Fabric==1.10.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 57))
Requirement already satisfied (use --upgrade to upgrade): paramiko==1.15.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 58))
Requirement already satisfied (use --upgrade to upgrade): ecdsa==0.13 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 59))
Requirement already satisfied (use --upgrade to upgrade): Whoosh==2.4.1+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 66))
Requirement already satisfied (use --upgrade to upgrade): pysam==0.8.4+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 69))
You are using pip version 8.0.2+gx2, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Requirement already satisfied (use --upgrade to upgrade): MySQL-python in ./.venv/lib/python2.7/site-packages (from -r /dev/stdin (line 1))
You are using pip version 8.0.2+gx2, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

(galaxy_env)bash-4.1$ ./galaxy-dist/scripts/common_startup.sh --skip-venv
Could not open requirements file: [Errno 2] No such file or directory: 'requirements.txt'

This is the complete log (with normal startup):


(galaxy_env)bash-4.1$ sh galaxy-dist/run.sh
Activating virtualenv at .venv
Ignoring indexes: https://pypi.python.org/simple
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Requirement already up-to-date: pip==8.0.2+gx2 in ./.venv/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): bx-python==0.7.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe==0.23 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 3))
Requirement already satisfied (use --upgrade to upgrade): PyYAML==3.11 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 4))
Requirement already satisfied (use --upgrade to upgrade): SQLAlchemy==1.0.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 5))
Requirement already satisfied (use --upgrade to upgrade): mercurial==3.4.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 7))
Requirement already satisfied (use --upgrade to upgrade): numpy==1.9.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 8))
Requirement already satisfied (use --upgrade to upgrade): pycrypto==2.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 9))
Requirement already satisfied (use --upgrade to upgrade): Paste==2.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 16))
Requirement already satisfied (use --upgrade to upgrade): PasteDeploy==1.5.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 17))
Requirement already satisfied (use --upgrade to upgrade): docutils==0.12 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 18))
Requirement already satisfied (use --upgrade to upgrade): wchartype==0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 19))
Requirement already satisfied (use --upgrade to upgrade): repoze.lru==0.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 20))
Requirement already satisfied (use --upgrade to upgrade): Routes==2.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 21))
Requirement already satisfied (use --upgrade to upgrade): WebOb==1.4.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 22))
Requirement already satisfied (use --upgrade to upgrade): WebHelpers==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 23))
Requirement already satisfied (use --upgrade to upgrade): Mako==1.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 24))
Requirement already satisfied (use --upgrade to upgrade): pytz==2015.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 25))
Requirement already satisfied (use --upgrade to upgrade): Babel==2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 26))
Requirement already satisfied (use --upgrade to upgrade): Beaker==1.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 27))
Requirement already satisfied (use --upgrade to upgrade): Cheetah==2.4.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 30))
Requirement already satisfied (use --upgrade to upgrade): Markdown==2.6.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 31))
Requirement already satisfied (use --upgrade to upgrade): bioblend==0.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 34))
Requirement already satisfied (use --upgrade to upgrade): boto==2.38.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 35))
Requirement already satisfied (use --upgrade to upgrade): requests==2.8.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 36))
Requirement already satisfied (use --upgrade to upgrade): requests-toolbelt==0.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 37))
Requirement already satisfied (use --upgrade to upgrade): kombu==3.0.30 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 40))
Requirement already satisfied (use --upgrade to upgrade): amqp==1.4.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 41))
Requirement already satisfied (use --upgrade to upgrade): anyjson==0.3.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 42))
Requirement already satisfied (use --upgrade to upgrade): sqlalchemy-migrate==0.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 45))
Requirement already satisfied (use --upgrade to upgrade): decorator==4.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 46))
Requirement already satisfied (use --upgrade to upgrade): Tempita==0.5.3dev in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 47))
Requirement already satisfied (use --upgrade to upgrade): sqlparse==0.1.16 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 48))
Requirement already satisfied (use --upgrade to upgrade): pbr==1.8.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 49))
Requirement already satisfied (use --upgrade to upgrade): six==1.9.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 51))
Requirement already satisfied (use --upgrade to upgrade): Parsley==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 52))
Requirement already satisfied (use --upgrade to upgrade): nose==1.3.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 53))
Requirement already satisfied (use --upgrade to upgrade): SVGFig==1.1.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 54))
Requirement already satisfied (use --upgrade to upgrade): Fabric==1.10.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 57))
Requirement already satisfied (use --upgrade to upgrade): paramiko==1.15.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 58))
Requirement already satisfied (use --upgrade to upgrade): ecdsa==0.13 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 59))
Requirement already satisfied (use --upgrade to upgrade): Whoosh==2.4.1+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 66))
Requirement already satisfied (use --upgrade to upgrade): pysam==0.8.4+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 69))
You are using pip version 8.0.2+gx2, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Requirement already satisfied (use --upgrade to upgrade): MySQL-python in ./.venv/lib/python2.7/site-packages (from -r /dev/stdin (line 1))
You are using pip version 8.0.2+gx2, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Activating virtualenv at .venv
Traceback (most recent call last):
  File "./scripts/paster.py", line 27, in <module>
    serve.run()
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/serve.py", line 1061, in run
    invoke(command, command_name, options, args[1:])
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/serve.py", line 1067, in invoke
    exit_code = runner.run(args)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/serve.py", line 223, in run
    result = self.command()
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/serve.py", line 637, in command
    server = loadserver(server_spec, name=server_name, relative_to=base, global_conf=vars)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 303, in loadserver
    return loadobj(SERVER, uri, name=name, **kw)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 319, in loadobj
    global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 344, in loadcontext
    global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 368, in _loadconfig
    return loader.get_context(object_type, name, global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 502, in get_context
    section)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 524, in _context_from_use
    object_type, name=use, global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 454, in get_context
    global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 344, in loadcontext
    global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 376, in _loadegg
    return loader.get_context(object_type, name, global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 668, in get_context
    object_type, name=name)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 688, in find_egg_entry_point
    pkg_resources.require(self.spec)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 666, in require
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 565, in resolve
pkg_resources.DistributionNotFound: Paste


Any hints?






___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot start Galaxy DistributionNotFound: Paste

Nicola Soranzo-2
Hi Hernán,
the bitbucket repository has been abandoned and so the code you are using is not maintained any more, please get it with git from https://github.com/galaxyproject/galaxy

More information are on the wiki: https://wiki.galaxyproject.org/Admin/GetGalaxy

Cheers,
Nicola

On 27/10/16 18:47, Hernán Piqueras wrote:


Guys


I am running CentOS 6.8 in a virtualenv and no matter what, I always get pkg_resources.DistributionNotFound: Paste

These were the commands to install and launch Galaxy


wget http://bitbucket.org/ianb/virtualenv/raw/tip/virtualenv.py

/usr/local/bin/python2.7 virtualenv.py --no-site-packages galaxy_env

. ./galaxy_env/bin/activate

source ~/galaxy_env/bin/activate

sh galaxy-dist/run.sh


and even tried to start with some workarounds found in the web (in no particular order):


cd /home/galaxy/galaxy-dist && ./scripts/common_startup.sh

./scripts/common_startup.sh --skip-venv --dev-wheels

sh galaxy-dist/run.sh --skip-venv --dev-wheels

sh galaxy-dist/run.sh --skip-venv

sh galaxy-dist/run.sh --replace-pip

easy_install paste


Also install or upgrade doesn't solve the problem:


(galaxy_env)bash-4.1$ pip install paste
Requirement already satisfied (use --upgrade to upgrade): paste in ./galaxy_env/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): six in ./galaxy_env/lib/python2.7/site-packages (from paste)


(galaxy_env)bash-4.1$ pip install paste --upgrade
/home/galaxy/galaxy_env/lib/python2.7/site-packages/pip-8.1.2-py2.7.egg/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/galaxy/galaxy_env/lib/python2.7/site-packages/pip-8.1.2-py2.7.egg/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Collecting paste
  Using cached Paste-2.0.3-py2-none-any.whl
Collecting six>=1.4.0 (from paste)
  Using cached six-1.10.0-py2.py3-none-any.whl
Installing collected packages: six, paste
  Found existing installation: six 1.9.0
    Uninstalling six-1.9.0:
      Successfully uninstalled six-1.9.0
  Found existing installation: Paste 2.0.2
    Uninstalling Paste-2.0.2:
      Successfully uninstalled Paste-2.0.2
Successfully installed paste-2.0.3 six-1.10.0


Using common_startup.sh also doesn't solve the problem:


(galaxy_env)bash-4.1$ cd /home/galaxy/galaxy-dist && ./scripts/common_startup.sh
Activating virtualenv at .venv
Ignoring indexes: https://pypi.python.org/simple
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Requirement already up-to-date: pip==8.0.2+gx2 in ./.venv/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): bx-python==0.7.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe==0.23 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 3))
Requirement already satisfied (use --upgrade to upgrade): PyYAML==3.11 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 4))
Requirement already satisfied (use --upgrade to upgrade): SQLAlchemy==1.0.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 5))
Requirement already satisfied (use --upgrade to upgrade): mercurial==3.4.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 7))
Requirement already satisfied (use --upgrade to upgrade): numpy==1.9.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 8))
Requirement already satisfied (use --upgrade to upgrade): pycrypto==2.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 9))
Requirement already satisfied (use --upgrade to upgrade): Paste==2.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 16))
Requirement already satisfied (use --upgrade to upgrade): PasteDeploy==1.5.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 17))
Requirement already satisfied (use --upgrade to upgrade): docutils==0.12 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 18))
Requirement already satisfied (use --upgrade to upgrade): wchartype==0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 19))
Requirement already satisfied (use --upgrade to upgrade): repoze.lru==0.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 20))
Requirement already satisfied (use --upgrade to upgrade): Routes==2.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 21))
Requirement already satisfied (use --upgrade to upgrade): WebOb==1.4.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 22))
Requirement already satisfied (use --upgrade to upgrade): WebHelpers==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 23))
Requirement already satisfied (use --upgrade to upgrade): Mako==1.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 24))
Requirement already satisfied (use --upgrade to upgrade): pytz==2015.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 25))
Requirement already satisfied (use --upgrade to upgrade): Babel==2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 26))
Requirement already satisfied (use --upgrade to upgrade): Beaker==1.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 27))
Requirement already satisfied (use --upgrade to upgrade): Cheetah==2.4.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 30))
Requirement already satisfied (use --upgrade to upgrade): Markdown==2.6.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 31))
Requirement already satisfied (use --upgrade to upgrade): bioblend==0.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 34))
Requirement already satisfied (use --upgrade to upgrade): boto==2.38.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 35))
Requirement already satisfied (use --upgrade to upgrade): requests==2.8.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 36))
Requirement already satisfied (use --upgrade to upgrade): requests-toolbelt==0.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 37))
Requirement already satisfied (use --upgrade to upgrade): kombu==3.0.30 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 40))
Requirement already satisfied (use --upgrade to upgrade): amqp==1.4.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 41))
Requirement already satisfied (use --upgrade to upgrade): anyjson==0.3.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 42))
Requirement already satisfied (use --upgrade to upgrade): sqlalchemy-migrate==0.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 45))
Requirement already satisfied (use --upgrade to upgrade): decorator==4.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 46))
Requirement already satisfied (use --upgrade to upgrade): Tempita==0.5.3dev in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 47))
Requirement already satisfied (use --upgrade to upgrade): sqlparse==0.1.16 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 48))
Requirement already satisfied (use --upgrade to upgrade): pbr==1.8.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 49))
Requirement already satisfied (use --upgrade to upgrade): six==1.9.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 51))
Requirement already satisfied (use --upgrade to upgrade): Parsley==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 52))
Requirement already satisfied (use --upgrade to upgrade): nose==1.3.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 53))
Requirement already satisfied (use --upgrade to upgrade): SVGFig==1.1.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 54))
Requirement already satisfied (use --upgrade to upgrade): Fabric==1.10.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 57))
Requirement already satisfied (use --upgrade to upgrade): paramiko==1.15.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 58))
Requirement already satisfied (use --upgrade to upgrade): ecdsa==0.13 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 59))
Requirement already satisfied (use --upgrade to upgrade): Whoosh==2.4.1+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 66))
Requirement already satisfied (use --upgrade to upgrade): pysam==0.8.4+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 69))
You are using pip version 8.0.2+gx2, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Requirement already satisfied (use --upgrade to upgrade): MySQL-python in ./.venv/lib/python2.7/site-packages (from -r /dev/stdin (line 1))
You are using pip version 8.0.2+gx2, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

(galaxy_env)bash-4.1$ ./galaxy-dist/scripts/common_startup.sh --skip-venv
Could not open requirements file: [Errno 2] No such file or directory: 'requirements.txt'

This is the complete log (with normal startup):


(galaxy_env)bash-4.1$ sh galaxy-dist/run.sh
Activating virtualenv at .venv
Ignoring indexes: https://pypi.python.org/simple
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Requirement already up-to-date: pip==8.0.2+gx2 in ./.venv/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): bx-python==0.7.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 2))
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe==0.23 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 3))
Requirement already satisfied (use --upgrade to upgrade): PyYAML==3.11 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 4))
Requirement already satisfied (use --upgrade to upgrade): SQLAlchemy==1.0.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 5))
Requirement already satisfied (use --upgrade to upgrade): mercurial==3.4.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 7))
Requirement already satisfied (use --upgrade to upgrade): numpy==1.9.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 8))
Requirement already satisfied (use --upgrade to upgrade): pycrypto==2.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 9))
Requirement already satisfied (use --upgrade to upgrade): Paste==2.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 16))
Requirement already satisfied (use --upgrade to upgrade): PasteDeploy==1.5.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 17))
Requirement already satisfied (use --upgrade to upgrade): docutils==0.12 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 18))
Requirement already satisfied (use --upgrade to upgrade): wchartype==0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 19))
Requirement already satisfied (use --upgrade to upgrade): repoze.lru==0.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 20))
Requirement already satisfied (use --upgrade to upgrade): Routes==2.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 21))
Requirement already satisfied (use --upgrade to upgrade): WebOb==1.4.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 22))
Requirement already satisfied (use --upgrade to upgrade): WebHelpers==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 23))
Requirement already satisfied (use --upgrade to upgrade): Mako==1.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 24))
Requirement already satisfied (use --upgrade to upgrade): pytz==2015.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 25))
Requirement already satisfied (use --upgrade to upgrade): Babel==2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 26))
Requirement already satisfied (use --upgrade to upgrade): Beaker==1.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 27))
Requirement already satisfied (use --upgrade to upgrade): Cheetah==2.4.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 30))
Requirement already satisfied (use --upgrade to upgrade): Markdown==2.6.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 31))
Requirement already satisfied (use --upgrade to upgrade): bioblend==0.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 34))
Requirement already satisfied (use --upgrade to upgrade): boto==2.38.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 35))
Requirement already satisfied (use --upgrade to upgrade): requests==2.8.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 36))
Requirement already satisfied (use --upgrade to upgrade): requests-toolbelt==0.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 37))
Requirement already satisfied (use --upgrade to upgrade): kombu==3.0.30 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 40))
Requirement already satisfied (use --upgrade to upgrade): amqp==1.4.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 41))
Requirement already satisfied (use --upgrade to upgrade): anyjson==0.3.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 42))
Requirement already satisfied (use --upgrade to upgrade): sqlalchemy-migrate==0.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 45))
Requirement already satisfied (use --upgrade to upgrade): decorator==4.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 46))
Requirement already satisfied (use --upgrade to upgrade): Tempita==0.5.3dev in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 47))
Requirement already satisfied (use --upgrade to upgrade): sqlparse==0.1.16 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 48))
Requirement already satisfied (use --upgrade to upgrade): pbr==1.8.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 49))
Requirement already satisfied (use --upgrade to upgrade): six==1.9.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 51))
Requirement already satisfied (use --upgrade to upgrade): Parsley==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 52))
Requirement already satisfied (use --upgrade to upgrade): nose==1.3.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 53))
Requirement already satisfied (use --upgrade to upgrade): SVGFig==1.1.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 54))
Requirement already satisfied (use --upgrade to upgrade): Fabric==1.10.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 57))
Requirement already satisfied (use --upgrade to upgrade): paramiko==1.15.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 58))
Requirement already satisfied (use --upgrade to upgrade): ecdsa==0.13 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 59))
Requirement already satisfied (use --upgrade to upgrade): Whoosh==2.4.1+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 66))
Requirement already satisfied (use --upgrade to upgrade): pysam==0.8.4+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 69))
You are using pip version 8.0.2+gx2, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Requirement already satisfied (use --upgrade to upgrade): MySQL-python in ./.venv/lib/python2.7/site-packages (from -r /dev/stdin (line 1))
You are using pip version 8.0.2+gx2, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Activating virtualenv at .venv
Traceback (most recent call last):
  File "./scripts/paster.py", line 27, in <module>
    serve.run()
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/serve.py", line 1061, in run
    invoke(command, command_name, options, args[1:])
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/serve.py", line 1067, in invoke
    exit_code = runner.run(args)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/serve.py", line 223, in run
    result = self.command()
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/serve.py", line 637, in command
    server = loadserver(server_spec, name=server_name, relative_to=base, global_conf=vars)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 303, in loadserver
    return loadobj(SERVER, uri, name=name, **kw)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 319, in loadobj
    global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 344, in loadcontext
    global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 368, in _loadconfig
    return loader.get_context(object_type, name, global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 502, in get_context
    section)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 524, in _context_from_use
    object_type, name=use, global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 454, in get_context
    global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 344, in loadcontext
    global_conf=global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 376, in _loadegg
    return loader.get_context(object_type, name, global_conf)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 668, in get_context
    object_type, name=name)
  File "/home/galaxy/galaxy-dist/lib/galaxy/util/pastescript/loadwsgi.py", line 688, in find_egg_entry_point
    pkg_resources.require(self.spec)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 666, in require
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 565, in resolve
pkg_resources.DistributionNotFound: Paste


Any hints?







___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Loading...