I'm currently trying to update a tool developed to wrap an in-house scripted pipeline written by a local researcher, so that it gets its dependencies from conda.
The pipeline uses a variety of third-party software packages (many of which are now at "legacy" versions), and I've hit a problem where two of these packages turn out to have conflicting dependencies.
Specifically the issue is with qiime=1.8.0, which it turns out is not compatible with any version of R which is available in the channels used by Galaxy. So when Galaxy builds the conda environment for the tool at execution time, it fails with an error from conda:
UnsatisfiableError: The following specifications were found to be in conflict:
- cairo==1.14.10=0 -> freetype==2.8.1
- cairo==1.14.10=0 -> pixman=0.34
- py2cairo==1.10.0=py27_1 -> cairo==1.12.2 -> freetype=2.4
- py2cairo==1.10.0=py27_1 -> cairo==1.12.2 -> pixman==0.26.2
(The py2cairo requirement comes from an older version of matplotlib that qiime 1.8.0 pulls in.)
It's a long shot, but: does Galaxy offer any options for working around conflicting conda dependencies like these? Or is the only option to try and resolve them at the conda packaging level (which might not be practical, or even possible)?
Thanks in advance for any advice,
Peter Briggs [hidden email] Bioinformatics Core Facility University of Manchester
B.1083 Michael Smith Bldg Tel: (0161) 2751482
Please keep all replies on the list by using "reply all"
in your mail client. To manage your subscriptions to this
and other Galaxy lists, please use the interface at: