Error running workflow via API

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Error running workflow via API

John Eppley-2
The API interface is translating my parameters into python repr strings instead of actual strings.

A command that should look like this:
createPrimerFile.py /minilims/galaxy-data/primerTemplates/nextera.2x.primers.fasta NNNNNN NNNNNN > /slipstream/galaxy/production/data/files/020/dataset_20664.dat

is getting run as this:
createPrimerFile.py /minilims/galaxy-data/primerTemplates/nextera.2x.primers.fasta __lt__galaxy.tools.parameters.basic.RuntimeValue object at 0x792be10__gt__ NNNNNN > /slipstream/galaxy/production/data/files/020/dataset_20728.dat

The input table in the tool info page is:
Input ParameterValueNote for rerun
chemistry type:<galaxy.tools.parameters.basic.RuntimeValue object at 0x7fee4425ca10>
First barcodeNNNNNN
Second (optional) barcodeNNNNNN


I’m running a slightly out of date version of Galaxy (I think it is change set 11080:87b586afb054) because this is BioTeam’s Slipstream appliance. Is there any chance this is a known bug? I didn’t see anything in Trello, but I’m really not sure I’ve got the hang of Trello yet.

Thanks
-john

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Error running workflow via API

John Eppley
The API interface is translating my parameters into python repr strings instead of actual strings.

A command that should look like this:
createPrimerFile.py /minilims/galaxy-data/primerTemplates/nextera.2x.primers.fasta NNNNNN NNNNNN > /slipstream/galaxy/production/data/files/020/dataset_20664.dat

is getting run as this:
createPrimerFile.py /minilims/galaxy-data/primerTemplates/nextera.2x.primers.fasta __lt__galaxy.tools.parameters.basic.RuntimeValue object at 0x792be10__gt__ NNNNNN > /slipstream/galaxy/production/data/files/020/dataset_20728.dat

The input table in the tool info page is:
Input ParameterValueNote for rerun
chemistry type:<galaxy.tools.parameters.basic.RuntimeValue object at 0x7fee4425ca10>
First barcodeNNNNNN
Second (optional) barcodeNNNNNN


I’m running a slightly out of date version of Galaxy (I think it is change set 11080:87b586afb054) because this is BioTeam’s Slipstream appliance. Is there any chance this is a known bug? I didn’t see anything in Trello, but I’m really not sure I’ve got the hang of Trello yet.

Thanks
-john


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

smime.p7s (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error running workflow via API

John Eppley
I’ve figured this one out. The tool id changed one me. Sorry for the spam.
-j

On Apr 9, 2014, at 4:48 PM, John Marmaduke Eppley <[hidden email]> wrote:

The API interface is translating my parameters into python repr strings instead of actual strings.

A command that should look like this:
createPrimerFile.py /minilims/galaxy-data/primerTemplates/nextera.2x.primers.fasta NNNNNN NNNNNN > /slipstream/galaxy/production/data/files/020/dataset_20664.dat

is getting run as this:
createPrimerFile.py /minilims/galaxy-data/primerTemplates/nextera.2x.primers.fasta __lt__galaxy.tools.parameters.basic.RuntimeValue object at 0x792be10__gt__ NNNNNN > /slipstream/galaxy/production/data/files/020/dataset_20728.dat

The input table in the tool info page is:
Input ParameterValueNote for rerun
chemistry type:<galaxy.tools.parameters.basic.RuntimeValue object at 0x7fee4425ca10>
First barcodeNNNNNN
Second (optional) barcodeNNNNNN


I’m running a slightly out of date version of Galaxy (I think it is change set 11080:87b586afb054) because this is BioTeam’s Slipstream appliance. Is there any chance this is a known bug? I didn’t see anything in Trello, but I’m really not sure I’ve got the hang of Trello yet.

Thanks
-john

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

smime.p7s (2K) Download Attachment