GVL/Galaxy ver 18.01 instance error: R_COMM channel basic get exception: [Errno 32] Broken pipe

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

GVL/Galaxy ver 18.01 instance error: R_COMM channel basic get exception: [Errno 32] Broken pipe

Leon Parker
We just stood up our first ever Genomics Virtual Lab appliance and used it to spool up a Galaxy Cluster for doing bioinformatics work.  We’ve worked a bit with the original “Cloudman” application and the ver 17.05 revision of Galaxy and it has worked fine, but we decided it might be a good time to migrate the GVL platform because it uses the latest, greatest version of Galaxy and provides additional tools, and the old “cloud man” approach has been deprecated, giving us further incentive to make the switch.  Unfortunately, we’re encountering an error right out of the gate, when we spool up Galaxy through GVL, before we do anything with it.   

Within two minutes of Galaxy starting, we begin to see the following over and over again in the Cluster Info Log:  

  • 20:55:20 - R_COMM channel basic get exception: [Errno 32] Broken pipe

In addition, we can’t seem to access any Spot worker node instances we activate.  They launch but are never recognized and used.  

Not sure what this mean, as we are biologists, not informaticians nor python experts.  Any help would be most appreciated!  

--Leon

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
Reply | Threaded
Open this post in threaded view
|

Re: GVL/Galaxy ver 18.01 instance error: R_COMM channel basic get exception: [Errno 32] Broken pipe

Martin Čech-2
Hi Leon, list,


Martin

On Mon, Mar 26, 2018 at 5:14 AM Leon Parker <[hidden email]> wrote:
We just stood up our first ever Genomics Virtual Lab appliance and used it to spool up a Galaxy Cluster for doing bioinformatics work.  We’ve worked a bit with the original “Cloudman” application and the ver 17.05 revision of Galaxy and it has worked fine, but we decided it might be a good time to migrate the GVL platform because it uses the latest, greatest version of Galaxy and provides additional tools, and the old “cloud man” approach has been deprecated, giving us further incentive to make the switch.  Unfortunately, we’re encountering an error right out of the gate, when we spool up Galaxy through GVL, before we do anything with it.   

Within two minutes of Galaxy starting, we begin to see the following over and over again in the Cluster Info Log:  

  • 20:55:20 - R_COMM channel basic get exception: [Errno 32] Broken pipe

In addition, we can’t seem to access any Spot worker node instances we activate.  They launch but are never recognized and used.  

Not sure what this mean, as we are biologists, not informaticians nor python experts.  Any help would be most appreciated!  

--Leon
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/