Galaxy Start Up Error - Double Requirements, Tempita

classic Classic list List threaded Threaded
2 messages Options
| Threaded
Open this post in threaded view
|

Galaxy Start Up Error - Double Requirements, Tempita

Yip, Miu ki
Hi all,

When attempting to start up Galaxy, via the run.sh script, we’re getting the following error:

galaxyd@genomics:/galaxy$ sh run.sh
Activating virtualenv at .venv
Requirement already satisfied: pip>=8.1 in ./.venv/lib/python2.7/site-packages
Double requirement given: Tempita==0.5.3.dev0 (from -r requirements.txt (line 155)) (already in Tempita==0.5.3dev (from -r requirements.txt (line 57)), name='Tempita')

This occurs when the start up script is run with the —no-create-venv and without the flag. It looks like there are two “Tempita” items in the requirements.txt, if one of them is removed, it leads to another error about “ethtools”

galaxyd@genomics:/galaxy$ sh run.sh --daemon --no-create-venv
Activating virtualenv at .venv
Requirement already satisfied: pip>=8.1 in ./.venv/lib/python2.7/site-packages
...
Collecting crypto==1.4.1 (from -r requirements.txt (line 81))
  Using cached crypto-1.4.1-py2.py3-none-any.whl
Requirement already satisfied: cycler==0.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 82))
Collecting Cython==0.25.2 (from -r requirements.txt (line 83))
  Using cached Cython-0.25.2-cp27-cp27mu-manylinux1_x86_64.whl
Requirement already satisfied: docopt==0.6.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 86))
Requirement already satisfied: drmaa==0.7.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 88))
Collecting ethtool==0.8 (from -r requirements.txt (line 90))
  Could not find a version that satisfies the requirement ethtool==0.8 (from -r requirements.txt (line 90)) (from versions: )
No matching distribution found for ethtool==0.8 (from -r requirements.txt (line 90))

We’re not sure if both versions of “Tempita” are required and if they are, how can the application be started up? Running both the run.sh and the run_reports.sh scripts lead to this error about “Tempita”. Has anyone encountered this error before?

Thanks!
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
| Threaded
Open this post in threaded view
|

Re: Galaxy Start Up Error - Double Requirements, Tempita

John Chilton-4
I've never seen anything like this - have you modified Galaxy's
requirements.txt file or are you using the one that ships with Galaxy?

On Fri, May 12, 2017 at 11:20 AM, Yip, Miu ki <[hidden email]> wrote:

> Hi all,
>
> When attempting to start up Galaxy, via the run.sh script, we’re getting the following error:
>
> galaxyd@genomics:/galaxy$ sh run.sh
> Activating virtualenv at .venv
> Requirement already satisfied: pip>=8.1 in ./.venv/lib/python2.7/site-packages
> Double requirement given: Tempita==0.5.3.dev0 (from -r requirements.txt (line 155)) (already in Tempita==0.5.3dev (from -r requirements.txt (line 57)), name='Tempita')
>
> This occurs when the start up script is run with the —no-create-venv and without the flag. It looks like there are two “Tempita” items in the requirements.txt, if one of them is removed, it leads to another error about “ethtools”
>
> galaxyd@genomics:/galaxy$ sh run.sh --daemon --no-create-venv
> Activating virtualenv at .venv
> Requirement already satisfied: pip>=8.1 in ./.venv/lib/python2.7/site-packages
> ...
> Collecting crypto==1.4.1 (from -r requirements.txt (line 81))
>   Using cached crypto-1.4.1-py2.py3-none-any.whl
> Requirement already satisfied: cycler==0.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 82))
> Collecting Cython==0.25.2 (from -r requirements.txt (line 83))
>   Using cached Cython-0.25.2-cp27-cp27mu-manylinux1_x86_64.whl
> Requirement already satisfied: docopt==0.6.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 86))
> Requirement already satisfied: drmaa==0.7.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 88))
> Collecting ethtool==0.8 (from -r requirements.txt (line 90))
>   Could not find a version that satisfies the requirement ethtool==0.8 (from -r requirements.txt (line 90)) (from versions: )
> No matching distribution found for ethtool==0.8 (from -r requirements.txt (line 90))
>
> We’re not sure if both versions of “Tempita” are required and if they are, how can the application be started up? Running both the run.sh and the run_reports.sh scripts lead to this error about “Tempita”. Has anyone encountered this error before?
>
> Thanks!
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/