Main tool shed installation issues

classic Classic list List threaded Threaded
4 messages Options
| Threaded
Open this post in threaded view
|

Main tool shed installation issues

Yves Gagnon
Hello fellow Galaxy-Dev users,

We are having an issue trying to install tools from the main tool shed.  Trying to install bowtie2 (or any other tool for that matter) gives us the following error message :

Error Traceback:
URLError: <urlopen error [Errno -2] Name or service not known>

Looking further in the error traceback, the url not found in question is this one (in the case of bowtie2):

https://toolshed.g2.bx.psu.edu/repository/get_repository_information?repository_ids=126c0918b54596%2066&changeset_revisions=a54de7e658f7

Indeed, copy pasting this URL into a browser gives me the Internal server error page.

Anyone knows if this is a widespread issue?

Thanks for your feedback!

Yves

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Main tool shed installation issues

Martin Čech
somehow a space (escaped) got into your id

this is the correct url:

I will look around why it got there.

On Tue, Sep 16, 2014 at 4:41 PM, Yves Gagnon <[hidden email]> wrote:
Hello fellow Galaxy-Dev users,

We are having an issue trying to install tools from the main tool shed.  Trying to install bowtie2 (or any other tool for that matter) gives us the following error message :

Error Traceback:
URLError: <urlopen error [Errno -2] Name or service not known>

Looking further in the error traceback, the url not found in question is this one (in the case of bowtie2):

https://toolshed.g2.bx.psu.edu/repository/get_repository_information?repository_ids=126c0918b54596%2066&changeset_revisions=a54de7e658f7

Indeed, copy pasting this URL into a browser gives me the Internal server error page.

Anyone knows if this is a widespread issue?

Thanks for your feedback!

Yves

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Main tool shed installation issues

Martin Čech
I tried installing this exact repo and changeset on the latest -central galaxy code and encountered no problems.

What version of Galaxy are you using. Did you modify it?

Martin

On Tue, Sep 16, 2014 at 4:44 PM, Martin Čech <[hidden email]> wrote:
somehow a space (escaped) got into your id

this is the correct url:

I will look around why it got there.

On Tue, Sep 16, 2014 at 4:41 PM, Yves Gagnon <[hidden email]> wrote:
Hello fellow Galaxy-Dev users,

We are having an issue trying to install tools from the main tool shed.  Trying to install bowtie2 (or any other tool for that matter) gives us the following error message :

Error Traceback:
URLError: <urlopen error [Errno -2] Name or service not known>

Looking further in the error traceback, the url not found in question is this one (in the case of bowtie2):

https://toolshed.g2.bx.psu.edu/repository/get_repository_information?repository_ids=126c0918b54596%2066&changeset_revisions=a54de7e658f7

Indeed, copy pasting this URL into a browser gives me the Internal server error page.

Anyone knows if this is a widespread issue?

Thanks for your feedback!

Yves

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Main tool shed installation issues

Yves Gagnon
Hi Martin,

I think that the escaped space was added because of the Interactive traceback display, I had to click a link to display the full URL.

The original URL does not contain a space in the repository_id (URL: admin_toolshed/prepare_for_install?tool_shed_url=https://toolshed.g2.bx.psu.edu/&repository_ids=126c0918b5459666&changeset_revisions=a54de7e658f7)

I think I pinpointed the issue now.  It seems to be a proxy misconfiguration.  When I enter the URL on my machine, I do not have any errors.  When I do wget on the galaxy server machine, it is there that I have the Name or service not known error.

Well, thank you for your quick answer!

Yves



From:        Martin Čech <[hidden email]>
To:        Yves Gagnon <[hidden email]>
Cc:        galaxy-dev <[hidden email]>
Date:        16/09/2014 04:50 PM
Subject:        Re: [galaxy-dev] Main tool shed installation issues
Sent by:        [hidden email]




I tried installing this exact repo and changeset on the latest -central galaxy code and encountered no problems.

What version of Galaxy are you using. Did you modify it?

Martin

On Tue, Sep 16, 2014 at 4:44 PM, Martin Čech <marten@...> wrote:
somehow a space (escaped) got into your id

this is the correct url:
https://toolshed.g2.bx.psu.edu/repository/get_repository_information?repository_ids=126c0918b5459666&changeset_revisions=a54de7e658f7

I will look around why it got there.

On Tue, Sep 16, 2014 at 4:41 PM, Yves Gagnon <yves.gagnon@...> wrote:
Hello fellow Galaxy-Dev users,

We are having an issue trying to install tools from the main tool shed.  Trying to install bowtie2 (or any other tool for that matter) gives us the following error message :


Error Traceback:

URLError: <urlopen error [Errno -2] Name or service not known>

Looking further in the error traceback, the url not found in question is this one (in the case of bowtie2):


https://toolshed.g2.bx.psu.edu/repository/get_repository_information?repository_ids=126c0918b54596%2066&changeset_revisions=a54de7e658f7

Indeed, copy pasting this URL into a browser gives me the Internal server error page.


Anyone knows if this is a widespread issue?


Thanks for your feedback!


Yves


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 
http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/