Multiple select input error after update

classic Classic list List threaded Threaded
4 messages Options
| Threaded
Open this post in threaded view
|

Multiple select input error after update

Alexandre
Hi all,

I've updated a Galaxy server with the latest stable distribution "latest_2015.01.13" and now a I got an error:
cannot open galaxy.tools.wrappers.DatasetFilenameWrapper: No such file
The tool has a multiple select field:
<param name="input_pdbs" type="data" multiple="true" format="pdb" label="PDB Files" />

On the job details, the select files on the multiple select (there are on my history already), are showed at the Job command line as follow:
python /home/alexandre/mestrado/protpred-galaxy/galaxy-dist/tools/analysis/dominance_ranking.py -i [<galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a653290>, <galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a653bd0>, <galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a653d90>, <galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a61de10>] 

The command on XML is:
<command interpreter="python">
       dominance_ranking.py -i $input_pdbs
</command>

This tool was working fine before the update.

Any ideas what Is going wrong?

Thanks a lot,
Alexandre

--
Alexandre Defelicibus
Mestrando em Bioengenharia
Programa de Pós-Graduação em Bioengenharia
Universidade de São Paulo - USP

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Multiple select input error after update

Daniel Blankenberg
Hi Alexandre,

Thanks for reporting this issue. We have committed a fix here https://bitbucket.org/galaxy/galaxy-central/commits/7fd6061e43d5/ and it will be applied to additional releases soon. Please let know if you encounter additional issues.


Thanks for using Galaxy,

Dan


On Jan 14, 2015, at 1:40 PM, Alexandre Defelicibus <[hidden email]> wrote:

Hi all,

I've updated a Galaxy server with the latest stable distribution "latest_2015.01.13" and now a I got an error:
cannot open galaxy.tools.wrappers.DatasetFilenameWrapper: No such file
The tool has a multiple select field:
<param name="input_pdbs" type="data" multiple="true" format="pdb" label="PDB Files" />

On the job details, the select files on the multiple select (there are on my history already), are showed at the Job command line as follow:
python /home/alexandre/mestrado/protpred-galaxy/galaxy-dist/tools/analysis/dominance_ranking.py -i [<galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a653290>, <galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a653bd0>, <galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a653d90>, <galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a61de10>] 

The command on XML is:
<command interpreter="python">
       dominance_ranking.py -i $input_pdbs
</command>

This tool was working fine before the update.

Any ideas what Is going wrong?

Thanks a lot,
Alexandre

--
Alexandre Defelicibus
Mestrando em Bioengenharia
Programa de Pós-Graduação em Bioengenharia
Universidade de São Paulo - USP
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Multiple select input error after update

Alexandre
Hi Daniel,

Thanks for the answer.
How can I update my Galaxy instance with this fix? The fix is on galaxy-central repository and I've cloned the galaxy-dist repository.

Thanks a lot,

Alexandre

2015-01-14 18:29 GMT-02:00 Daniel Blankenberg <[hidden email]>:
Hi Alexandre,

Thanks for reporting this issue. We have committed a fix here https://bitbucket.org/galaxy/galaxy-central/commits/7fd6061e43d5/ and it will be applied to additional releases soon. Please let know if you encounter additional issues.


Thanks for using Galaxy,

Dan


On Jan 14, 2015, at 1:40 PM, Alexandre Defelicibus <[hidden email]> wrote:

Hi all,

I've updated a Galaxy server with the latest stable distribution "latest_2015.01.13" and now a I got an error:
cannot open galaxy.tools.wrappers.DatasetFilenameWrapper: No such file
The tool has a multiple select field:
<param name="input_pdbs" type="data" multiple="true" format="pdb" label="PDB Files" />

On the job details, the select files on the multiple select (there are on my history already), are showed at the Job command line as follow:
python /home/alexandre/mestrado/protpred-galaxy/galaxy-dist/tools/analysis/dominance_ranking.py -i [<galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a653290>, <galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a653bd0>, <galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a653d90>, <galaxy.tools.wrappers.DatasetFilenameWrapper object at 0x7f4e1a61de10>] 

The command on XML is:
<command interpreter="python">
       dominance_ranking.py -i $input_pdbs
</command>

This tool was working fine before the update.

Any ideas what Is going wrong?

Thanks a lot,
Alexandre

--
Alexandre Defelicibus
Mestrando em Bioengenharia
Programa de Pós-Graduação em Bioengenharia
Universidade de São Paulo - USP
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/




--
Alexandre Defelicibus
Mestrando em Bioengenharia
Programa de Pós-Graduação em Bioengenharia
Universidade de São Paulo - USP

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Multiple select input error after update

Nicola Soranzo-2
Hi Alexandre,
the commit seems to be also in galaxy-dist now. Anyway, this command should do the trick:

hg pull -b stable https://bitbucket.org/galaxy/galaxy-central

I'd suggest you to use directly the stable branch of galaxy-central, which usually gets the hotfixes much faster than galaxy-dist. But that's just my personal opinion.

Best,
Nicola

Il 15.01.2015 17:32 Alexandre Defelicibus ha scritto:

Hi Daniel,
Thanks for the answer.
How can I update my Galaxy instance with this fix? The fix is on galaxy-central repository and I've cloned the galaxy-dist repository.
Thanks a lot,
Alexandre

2015-01-14 18:29 GMT-02:00 Daniel Blankenberg <[hidden email]>:
Hi Alexandre,
Thanks for reporting this issue. We have committed a fix here https://bitbucket.org/galaxy/galaxy-central/commits/7fd6061e43d5/ and it will be applied to additional releases soon. Please let know if you encounter additional issues.
Thanks for using Galaxy,
Dan

On Jan 14, 2015, at 1:40 PM, Alexandre Defelicibus <[hidden email]> wrote:
Hi all,
I've updated a Galaxy server with the latest stable distribution "latest_2015.01.13" and now a I got an error:
cannot open galaxy.tools.wrappers.DatasetFilenameWrapper: No such file
The tool has a multiple select field:
On the job details, the select files on the multiple select (there are on my history already), are showed at the Job command line as follow:
python /home/alexandre/mestrado/protpred-galaxy/galaxy-dist/tools/analysis/dominance_ranking.py -i [, , , ] 

The command on XML is:
       dominance_ranking.py -i $input_pdbs
This tool was working fine before the update.
Any ideas what Is going wrong?
Thanks a lot,
Alexandre
--
Alexandre Defelicibus
Mestrando em Bioengenharia
Programa de Pós-Graduação em Bioengenharia
Universidade de São Paulo - USP
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


--
Alexandre Defelicibus
Mestrando em Bioengenharia
Programa de Pós-Graduação em Bioengenharia
Universidade de São Paulo - USP
-- 
Nicola Soranzo
http://nsoranzo.altervista.org

La mia chiave PGP:
http://nsoranzo.altervista.org/key.asc



Connetti gratis il mondo con la nuova indoona: hai la chat, le chiamate, le video chiamate e persino le chiamate di gruppo.
E chiami gratis anche i numeri fissi e mobili nel mondo!
Scarica subito l’app Vai su https://www.indoona.com/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/