Package/Module RPY

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Package/Module RPY

Hayes, Curt

Hi there all,

 

I have searched previous posts, nothing since 2010. I have a local install (production config – postgres, etc – on CENTOS 6.5).
Does anyone have RPY working? I install via toolshed and the folder is empty, and shows missing dependencies.

 

From Galaxy User:

Dataset generation errors

Dataset 81: Build base quality distribution on data 9

 

Tool execution generated the following error message:

Traceback (most recent call last):

  File "/apps/galaxy/galaxy-dist/tools/metag_tools/short_reads_figure_score.py", line 12, in <module>

    from rpy import *

ImportError: No module named rpy

 

I have attempted to download/install the scripts but they fail with multiple errors (most posts out there have a bad URL) - http://getgalaxyp.org/install.html says use: curl http://rpy.svn.sourceforge.net/viewvc/rpy/trunk/rpy/?view=tar > rpy.tar.gz

if you view that it redirects you to another URL.  

 

Via shell: R is installed: R version 2.13.0 (2011-04-13)

 

Can someone provide me some help please to get it working via Galaxy? I understand it works in Central.

 

From Toolshed:

Name

Version

Type

Installation status

rpy

1.0.3

package

Error

 

Toolshed Error:

In file included from src/rpymodule2110.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2110.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. <truncated>


Thanks,
Curt

 

CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

rpy_error.txt (43K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Package/Module RPY

Hayes, Curt

Hi there all,

Does anyone have RPY working? I install via toolshed and the folder is empty, and shows missing dependencies.

I have searched previous posts, nothing since 2010. I have a local install (production config – postgres, etc – on CENTOS 6.5). I posted last week and it fell off the list.

From Galaxy User interface:

Dataset generation errors

Dataset 81: Build base quality distribution on data 9

 

Tool execution generated the following error message:

Traceback (most recent call last):

  File "/apps/galaxy/galaxy-dist/tools/metag_tools/short_reads_figure_score.py", line 12, in <module>

    from rpy import *

ImportError: No module named rpy

 

I have attempted to download/install the scripts but they fail with multiple errors (most posts out there have a bad URL) - http://getgalaxyp.org/install.html says use: curl http://rpy.svn.sourceforge.net/viewvc/rpy/trunk/rpy/?view=tar > rpy.tar.gz

if you view that it redirects you to another URL.  

 

Via shell: R is installed: R version 2.13.0 (2011-04-13)

 

Can someone provide me some help please to get it working via Galaxy? I understand it works in Central.

 

From Toolshed:

Name

Version

Type

Installation status

rpy

1.0.3

package

Error

 

Toolshed Error:

In file included from src/rpymodule2110.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2110.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. <truncated>


Thanks,
Curt

 

CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Package/Module RPY

Greg Von Kuster
<base href="x-msg://687/">Hello Curt,

I believe that version 1.0.3 of the rpy package should be installing successfully from the main tool shed if you have a repository that contains a tool that defines a dependency to the rpy repository owned by devteam at http://toolshed.g2.bx.psu.edu/view/devteam/package_rpy_1_0_3
 
Here is the last test run for the tool shed's install and test framework for that repository.  I believe tis should install correctly using the dist repository, but if you're seeing problems, let us know.  Also, the next release is coming soon ( tentatively a week or so from now )..

Tool shedNameOwnerChangeset revision
toolshed.g2.bx.psu.edu package_r_2_11_0 devteam 5824d2b3bc8b
TypeNameVersion
R package 2.11.0
Installation directory
/ToolDepsMain/R/2.11.0/devteam/package_rpy_1_0_3/82170c94ca7c
TypeNameVersion
rpy package 1.0.3
Installation directory
/ToolDepsMain/rpy/1.0.3/devteam/package_rpy_1_0_3/82170c94ca7c



On Apr 8, 2014, at 3:28 PM, "Hayes, Curt" <[hidden email]> wrote:

Hi there all,
Does anyone have RPY working? I install via toolshed and the folder is empty, and shows missing dependencies.
I have searched previous posts, nothing since 2010. I have a local install (production config – postgres, etc – on CENTOS 6.5). I posted last week and it fell off the list. 

From Galaxy User interface:
Dataset generation errors
Dataset 81: Build base quality distribution on data 9
 
Tool execution generated the following error message:
Traceback (most recent call last):
  File "/apps/galaxy/galaxy-dist/tools/metag_tools/short_reads_figure_score.py", line 12, in <module>
    from rpy import *
ImportError: No module named rpy
 
I have attempted to download/install the scripts but they fail with multiple errors (most posts out there have a bad URL) - http://getgalaxyp.org/install.html says use: curlhttp://rpy.svn.sourceforge.net/viewvc/rpy/trunk/rpy/?view=tar > rpy.tar.gz
if you view that it redirects you to another URL.  
 
Via shell: R is installed: R version 2.13.0 (2011-04-13)
 
Can someone provide me some help please to get it working via Galaxy? I understand it works in Central.
 
From Toolshed:
Name
Version
Type
Installation status
1.0.3
package
Error
 
Toolshed Error:
In file included from src/rpymodule2110.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2110.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. <truncated>

Thanks,
Curt
 
CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message. 
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Package/Module RPY

Hayes, Curt
<base href="x-msg://687/">

Name

Description

Owner

Revision

Installation Status

package_rpy_1_0_3

Contains a tool dependency definition that downloads and installs version 1.0.3 of the python R interface.

devteam

82170c94ca7c

Installed, missing both tool and repository dependencies

package_r_2_11_0

Contains a tool dependency definition that downloads and compiles version 2.11.0 of the R interpreter.

devteam

5824d2b3bc8b

Installed

 

stalled tool shed repository 'package_rpy_1_0_3'

Top of Form

Tool shed:toolshed.g2.bx.psu.edu

Name:package_rpy_1_0_3

Description:

Revision:82170c94ca7c

Owner:devteam

Location:/apps/galaxy/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/package_rpy_1_0_3/82170c94ca7c/package_rpy_1_0_3

Deleted:False

Bottom of Form

Dependencies of this repository

<a href="javascript:void(0);">Missing repository dependencies - installation of these additional repositories is required

 

<a href="javascript:void(0);">Installed repository dependencies

Name

Revision

Owner

Installation status

package_r_2_11_0

5824d2b3bc8b

devteam

Installed

 

<a href="javascript:void(0);">Installed tool dependencies - click the name to browse the dependency installation directory

Name

Version

Type

Installation status

R

2.11.0

package

Installed

 

<a href="javascript:void(0);">Missing tool dependencies - click the name to install the missing dependency

Name

Version

Type

Installation status

rpy

1.0.3

package

Error

 

 

Tool shed repository 'package_rpy_1_0_3' tool dependencies



Name

Version

Type

Status

Error

R

2.11.0

package

Installed

rpy

1.0.3

package

Error

In file included from src/rpymodule2130.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:227: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:228: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_uintp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:330: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:331: error: expected ‘)’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:334: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:347: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:349: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:359: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:361: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:364: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:368: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:370: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:371: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:372: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:378: error: expected specifier-qualifier-list before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:391: error: expected specifier-qualifier-list before ‘PyArray_GetItemFunc’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:492: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:526: error: expected specifier-qualifier-list before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:536: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:561: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:569: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:578: error: expected declaration specifiers or ‘...’ before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:728: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:731: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:883: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:937: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:980: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1036, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: (Each undeclared identifier is reported only once /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: for each function it appears in.) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord2D’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: expected ‘;’ before ‘wb’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Next’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Reset’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h: At top level: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1223: error: expected specifier-qualifier-list before ‘npy_intp’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1238, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h: In function ‘_import_array’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘PyObject’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘numpy’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: warning: implicit declaration of function ‘PyImport_ImportModule’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1191: error: ‘c_api’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1193: warning: implicit declaration of function ‘PyObject_GetAttrString’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1194: warning: implicit declaration of function ‘Py_DECREF’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1195: warning: implicit declaration of function ‘PyCObject_Check’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1196: warning: implicit declaration of function ‘PyCObject_AsVoidPtr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: warning: implicit declaration of function ‘PyErr_Format’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: error: ‘PyExc_RuntimeError’ undeclared (first use in this function) In file included from src/rpymodule2130.c:51: src/RPy.h: At top level: src/RPy.h:91: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘n_intp’ In file included from src/RPy.h:105, from src/rpymodule2130.c:51: src/robjobject.h:46: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ src/robjobject.h:57: warning: return type defaults to ‘int’ src/robjobject.h: In function ‘DL_IMPORT’: src/robjobject.h:57: error: expected declaration specifiers before ‘Robj_Type’ In file included from src/rpymodule2130.c:51: src/RPy.h:112: error: expected ‘)’ before ‘*’ token src/RPy.h:113: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:114: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:115: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:132: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:133: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:138: error: storage class specified for parameter ‘Rf_initEmbeddedR’ src/RPy.h:139: error: storage class specified for parameter ‘init_io_routines’ src/RPy.h:145: error: storage class specified for parameter ‘R_Outputfile’ src/RPy.h:153: error: storage class specified for parameter ‘ptr_R_WriteConsole’ src/RPy.h:154: error: storage class specified for parameter ‘ptr_R_ReadConsole’ src/RPy.h:155: error: storage class specified for parameter ‘ptr_R_ShowFiles’ src/RPy.h:172: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:173: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:174: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:175: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:176: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:177: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:183: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘python_sigint’ src/RPy.h:186: error: storage class specified for parameter ‘jump_now’ src/RPy.h:189: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:192: error: storage class specified for parameter ‘R_interact’ src/RPy.h:195: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:197: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:205: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:205: error: storage class specified for parameter ‘to_Pyobj_proc’ src/RPy.h:206: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:206: error: storage class specified for parameter ‘to_Pyobj_class’ src/RPy.h:207: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:207: error: storage class specified for parameter ‘to_Pyobj_basic’ src/RPy.h:208: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:208: error: storage class specified for parameter ‘to_Pyobj_vector’ src/rpymodule2130.c:63: error: storage class specified for parameter ‘use_numeric’ src/rpymodule2130.c:63: error: parameter ‘use_numeric’ is initialized src/rpymodule2130.c:67: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:68: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:70: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:77: error: storage class specified for parameter ‘get_item’ src/rpymodule2130.c:78: error: storage class specified for parameter ‘set_item’ src/rpymodule2130.c:79: error: storage class specified for parameter ‘length’ src/rpymodule2130.c:80: error: storage class specified for parameter ‘aperm’ src/rpymodule2130.c:81: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:82: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:83: error: storage class specified for parameter ‘default_mode’ src/rpymodule2130.c:84: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:85: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:86: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:87: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:89: error: storage class specified for parameter ‘RHOME’ src/rpymodule2130.c:90: error: storage class specified for parameter ‘RVERSION’ src/rpymodule2130.c:91: error: storage class specified for parameter ‘RVER’ src/rpymodule2130.c:92: error: storage class specified for parameter ‘RUSER’ src/rpymodule2130.c:93: error: parameter ‘defaultargv’ is initialized src/rpymodule2130.c:93: warning: initialization from incompatible pointer type src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:94: error: parameter ‘defaultargc’ is initialized src/rpymodule2130.c:97: error: expected declaration specifiers before ‘PyInterpreterState’ src/rpymodule2130.c:100: error: redefinition of parameter ‘R_interact’ src/RPy.h:192: note: previous definition of ‘R_interact’ was here src/rpymodule2130.c:103: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:104: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:108: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:113: error: storage class specified for parameter ‘R_References’ src/rpymodule2130.c:117: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:141: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:160: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:183: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:207: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:292: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:330: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:510: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:626: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:652: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:686: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:710: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:751: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:752: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:774: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:775: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:900: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:939: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:940: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:977: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:978: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:999: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1000: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1015: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:1048: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1049: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1067: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1092: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1093: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1139: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1191: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1192: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1276: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1342: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1369: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1392: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_methods’ src/rpymodule2130.c:1398: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1404: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1423: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1449: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1490: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1564: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_as_sequence’ src/rpymodule2130.c:1575: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1589: error: expected declaration specifiers before ‘PyTypeObject’ src/rpymodule2130.c:1656: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1663: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1682: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1700: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1709: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1739: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1754: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1774: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1807: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1818: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1834: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1863: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rpy_methods’ src/rpymodule2130.c:1877: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1972: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:113: error: declaration for parameter ‘R_References’ but no such parameter src/rpymodule2130.c:100: error: declaration for parameter ‘R_interact’ but no such parameter src/rpymodule2130.c:94: error: declaration for parameter ‘defaultargc’ but no such parameter src/rpymodule2130.c:93: error: declaration for parameter ‘defaultargv’ but no such parameter src/rpymodule2130.c:92: error: declaration for parameter ‘RUSER’ but no such parameter src/rpymodule2130.c:91: error: declaration for parameter ‘RVER’ but no such parameter src/rpymodule2130.c:90: error: declaration for parameter ‘RVERSION’ but no such parameter src/rpymodule2130.c:89: error: declaration for parameter ‘RHOME’ but no such parameter src/rpymodule2130.c:83: error: declaration for parameter ‘default_mode’ but no such parameter src/rpymodule2130.c:80: error: declaration for parameter ‘aperm’ but no such parameter src/rpymodule2130.c:79: error: declaration for parameter ‘length’ but no such parameter src/rpymodule2130.c:78: error: declaration for parameter ‘set_item’ but no such parameter src/rpymodule2130.c:77: error: declaration for parameter ‘get_item’ but no such parameter src/rpymodule2130.c:63: error: declaration for parameter ‘use_numeric’ but no such parameter src/RPy.h:208: error: declaration for parameter ‘to_Pyobj_vector’ but no such parameter src/RPy.h:207: error: declaration for parameter ‘to_Pyobj_basic’ but no such parameter src/RPy.h:206: error: declaration for parameter ‘to_Pyobj_class’ but no such parameter src/RPy.h:205: error: declaration for parameter ‘to_Pyobj_proc’ but no such parameter src/RPy.h:201: error: declaration for parameter ‘start_events’ but no such parameter src/RPy.h:200: error: declaration for parameter ‘stop_events’ but no such parameter src/RPy.h:192: error: declaration for parameter ‘R_interact’ but no such parameter src/RPy.h:186: error: declaration for parameter ‘jump_now’ but no such parameter src/RPy.h:180: error: declaration for parameter ‘interrupt_R’ but no such parameter src/RPy.h:155: error: declaration for parameter ‘ptr_R_ShowFiles’ but no such parameter src/RPy.h:154: error: declaration for parameter ‘ptr_R_ReadConsole’ but no such parameter src/RPy.h:153: error: declaration for parameter ‘ptr_R_WriteConsole’ but no such parameter src/RPy.h:145: error: declaration for parameter ‘R_Outputfile’ but no such parameter src/RPy.h:139: error: declaration for parameter ‘init_io_routines’ but no such parameter src/RPy.h:138: error: declaration for parameter ‘Rf_initEmbeddedR’ but no such parameter src/RPy.h:135: error: declaration for parameter ‘get_last_error_msg’ but no such parameter src/RPy.h:128: error: declaration for parameter ‘get_fun_from_name’ but no such parameter src/RPy.h:127: error: declaration for parameter ‘do_eval_fun’ but no such parameter src/RPy.h:126: error: declaration for parameter ‘do_eval_expr’ but no such parameter src/setenv.h:46: error: declaration for parameter ‘setenv’ but no such parameter src/robjobject.h:62: error: declaration for parameter ‘Robj_new’ but no such parameter src/rpymodule2130.c:2104: error: expected ‘{’ at end of input error: command 'gcc' failed with exit status 1



Top of Form

Check each tool dependency that you want to uninstall and click Uninstall.

Select/unselect all tool dependencies

R version 2.11.0

rpy version 1.0.3

Bottom of Form

 

 

From: Greg Von Kuster [mailto:[hidden email]]
Sent: Tuesday, April 08, 2014 1:27 PM
To: Hayes, Curt
Cc: '[hidden email]'
Subject: Re: [galaxy-dev] Package/Module RPY

 

Hello Curt,

 

I believe that version 1.0.3 of the rpy package should be installing successfully from the main tool shed if you have a repository that contains a tool that defines a dependency to the rpy repository owned by devteam at http://toolshed.g2.bx.psu.edu/view/devteam/package_rpy_1_0_3

 

Here is the last test run for the tool shed's install and test framework for that repository.  I believe tis should install correctly using the dist repository, but if you're seeing problems, let us know.  Also, the next release is coming soon ( tentatively a week or so from now )..

 

Test runs

2014-04-07 17:25:49

Automated test environment

Successful installations

Repository dependencies - installation of these additional repositories is required

Tool shed

Name

Owner

Changeset revision

toolshed.g2.bx.psu.edu

package_r_2_11_0

devteam

5824d2b3bc8b

Tool dependencies

Type

Name

Version

R

package

2.11.0

Installation directory

/ToolDepsMain/R/2.11.0/devteam/package_rpy_1_0_3/82170c94ca7c

Type

Name

Version

rpy

package

1.0.3

Installation directory

/ToolDepsMain/rpy/1.0.3/devteam/package_rpy_1_0_3/82170c94ca7c

 

 

 

On Apr 8, 2014, at 3:28 PM, "Hayes, Curt" <[hidden email]> wrote:



Hi there all,

Does anyone have RPY working? I install via toolshed and the folder is empty, and shows missing dependencies.

I have searched previous posts, nothing since 2010. I have a local install (production config – postgres, etc – on CENTOS 6.5). I posted last week and it fell off the list. 


From Galaxy User interface:

Dataset generation errors

Dataset 81: Build base quality distribution on data 9

 

Tool execution generated the following error message:

Traceback (most recent call last):

  File "/apps/galaxy/galaxy-dist/tools/metag_tools/short_reads_figure_score.py", line 12, in <module>

    from rpy import *

ImportError: No module named rpy

 

I have attempted to download/install the scripts but they fail with multiple errors (most posts out there have a bad URL) - http://getgalaxyp.org/install.html says use: curlhttp://rpy.svn.sourceforge.net/viewvc/rpy/trunk/rpy/?view=tar > rpy.tar.gz

if you view that it redirects you to another URL.  

 

Via shell: R is installed: R version 2.13.0 (2011-04-13)

 

Can someone provide me some help please to get it working via Galaxy? I understand it works in Central.

 

From Toolshed:

Name

Version

Type

Installation status

rpy

1.0.3

package

Error

 

Toolshed Error:

In file included from src/rpymodule2110.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2110.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. <truncated>


Thanks,
Curt

 

CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message. 
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

 

CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Package/Module RPY

Greg Von Kuster
<base href="x-msg://687/">Hi Curt,

Let's hope someone else can provide some insight into resolving this issue now that the error log from installing into your environment is available.  I'm not expert enough with system level things like this to provide much help here.  Sorry I'm not much help.

Greg Von Kuster

On Apr 8, 2014, at 4:49 PM, "Hayes, Curt" <[hidden email]> wrote:

Name
Description
Owner
Revision
Installation Status
Contains a tool dependency definition that downloads and installs version 1.0.3 of the python R interface.
devteam
82170c94ca7c
Installed, missing both tool and repository dependencies
Contains a tool dependency definition that downloads and compiles version 2.11.0 of the R interpreter.
devteam
5824d2b3bc8b
Installed
 
stalled tool shed repository 'package_rpy_1_0_3'

Tool shed:toolshed.g2.bx.psu.edu
Name:package_rpy_1_0_3
Description:
Revision:82170c94ca7c
Owner:devteam
Deleted:False

Dependencies of this repository
<a href="javascript:void(0);" style="color: purple; text-decoration: underline; ">Missing repository dependencies - installation of these additional repositories is required

<a href="javascript:void(0);" style="color: purple; text-decoration: underline; ">Installed repository dependencies
Name
Revision
Owner
Installation status
5824d2b3bc8b
devteam
Installed

<a href="javascript:void(0);" style="color: purple; text-decoration: underline; ">Installed tool dependencies - click the name to browse the dependency installation directory
Name
Version
Type
Installation status
2.11.0
package
Installed

<a href="javascript:void(0);" style="color: purple; text-decoration: underline; ">Missing tool dependencies - click the name to install the missing dependency
Name
Version
Type
Installation status
1.0.3
package
Error
 
 
Tool shed repository 'package_rpy_1_0_3' tool dependencies


Name
Version
Type
Status
Error
2.11.0
package
Installed
1.0.3
package
Error
In file included from src/rpymodule2130.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:227: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:228: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_uintp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:330: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:331: error: expected ‘)’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:334: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:347: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:349: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:359: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:361: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:364: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:368: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:370: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:371: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:372: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:378: error: expected specifier-qualifier-list before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:391: error: expected specifier-qualifier-list before ‘PyArray_GetItemFunc’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:492: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:526: error: expected specifier-qualifier-list before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:536: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:561: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:569: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:578: error: expected declaration specifiers or ‘...’ before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:728: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:731: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:883: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:937: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:980: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1036, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: (Each undeclared identifier is reported only once /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: for each function it appears in.) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord2D’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: expected ‘;’ before ‘wb’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Next’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Reset’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h: At top level: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1223: error: expected specifier-qualifier-list before ‘npy_intp’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1238, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h: In function ‘_import_array’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘PyObject’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘numpy’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: warning: implicit declaration of function ‘PyImport_ImportModule’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1191: error: ‘c_api’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1193: warning: implicit declaration of function ‘PyObject_GetAttrString’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1194: warning: implicit declaration of function ‘Py_DECREF’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1195: warning: implicit declaration of function ‘PyCObject_Check’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1196: warning: implicit declaration of function ‘PyCObject_AsVoidPtr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: warning: implicit declaration of function ‘PyErr_Format’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: error: ‘PyExc_RuntimeError’ undeclared (first use in this function) In file included from src/rpymodule2130.c:51: src/RPy.h: At top level: src/RPy.h:91: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘n_intp’ In file included from src/RPy.h:105, from src/rpymodule2130.c:51: src/robjobject.h:46: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ src/robjobject.h:57: warning: return type defaults to ‘int’ src/robjobject.h: In function ‘DL_IMPORT’: src/robjobject.h:57: error: expected declaration specifiers before ‘Robj_Type’ In file included from src/rpymodule2130.c:51: src/RPy.h:112: error: expected ‘)’ before ‘*’ token src/RPy.h:113: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:114: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:115: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:132: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:133: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:138: error: storage class specified for parameter ‘Rf_initEmbeddedR’ src/RPy.h:139: error: storage class specified for parameter ‘init_io_routines’ src/RPy.h:145: error: storage class specified for parameter ‘R_Outputfile’ src/RPy.h:153: error: storage class specified for parameter ‘ptr_R_WriteConsole’ src/RPy.h:154: error: storage class specified for parameter ‘ptr_R_ReadConsole’ src/RPy.h:155: error: storage class specified for parameter ‘ptr_R_ShowFiles’ src/RPy.h:172: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:173: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:174: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:175: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:176: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:177: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:183: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘python_sigint’ src/RPy.h:186: error: storage class specified for parameter ‘jump_now’ src/RPy.h:189: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:192: error: storage class specified for parameter ‘R_interact’ src/RPy.h:195: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:197: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:205: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:205: error: storage class specified for parameter ‘to_Pyobj_proc’ src/RPy.h:206: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:206: error: storage class specified for parameter ‘to_Pyobj_class’ src/RPy.h:207: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:207: error: storage class specified for parameter ‘to_Pyobj_basic’ src/RPy.h:208: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:208: error: storage class specified for parameter ‘to_Pyobj_vector’ src/rpymodule2130.c:63: error: storage class specified for parameter ‘use_numeric’ src/rpymodule2130.c:63: error: parameter ‘use_numeric’ is initialized src/rpymodule2130.c:67: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:68: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:70: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:77: error: storage class specified for parameter ‘get_item’ src/rpymodule2130.c:78: error: storage class specified for parameter ‘set_item’ src/rpymodule2130.c:79: error: storage class specified for parameter ‘length’ src/rpymodule2130.c:80: error: storage class specified for parameter ‘aperm’ src/rpymodule2130.c:81: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:82: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:83: error: storage class specified for parameter ‘default_mode’ src/rpymodule2130.c:84: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:85: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:86: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:87: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:89: error: storage class specified for parameter ‘RHOME’ src/rpymodule2130.c:90: error: storage class specified for parameter ‘RVERSION’ src/rpymodule2130.c:91: error: storage class specified for parameter ‘RVER’ src/rpymodule2130.c:92: error: storage class specified for parameter ‘RUSER’ src/rpymodule2130.c:93: error: parameter ‘defaultargv’ is initialized src/rpymodule2130.c:93: warning: initialization from incompatible pointer type src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:94: error: parameter ‘defaultargc’ is initialized src/rpymodule2130.c:97: error: expected declaration specifiers before ‘PyInterpreterState’ src/rpymodule2130.c:100: error: redefinition of parameter ‘R_interact’ src/RPy.h:192: note: previous definition of ‘R_interact’ was here src/rpymodule2130.c:103: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:104: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:108: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:113: error: storage class specified for parameter ‘R_References’ src/rpymodule2130.c:117: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:141: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:160: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:183: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:207: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:292: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:330: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:510: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:626: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:652: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:686: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:710: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:751: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:752: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:774: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:775: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:900: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:939: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:940: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:977: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:978: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:999: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1000: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1015: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:1048: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1049: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1067: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1092: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1093: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1139: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1191: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1192: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1276: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1342: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1369: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1392: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_methods’ src/rpymodule2130.c:1398: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1404: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1423: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1449: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1490: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1564: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_as_sequence’ src/rpymodule2130.c:1575: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1589: error: expected declaration specifiers before ‘PyTypeObject’ src/rpymodule2130.c:1656: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1663: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1682: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1700: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1709: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1739: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1754: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1774: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1807: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1818: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1834: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1863: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rpy_methods’ src/rpymodule2130.c:1877: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1972: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:113: error: declaration for parameter ‘R_References’ but no such parameter src/rpymodule2130.c:100: error: declaration for parameter ‘R_interact’ but no such parameter src/rpymodule2130.c:94: error: declaration for parameter ‘defaultargc’ but no such parameter src/rpymodule2130.c:93: error: declaration for parameter ‘defaultargv’ but no such parameter src/rpymodule2130.c:92: error: declaration for parameter ‘RUSER’ but no such parameter src/rpymodule2130.c:91: error: declaration for parameter ‘RVER’ but no such parameter src/rpymodule2130.c:90: error: declaration for parameter ‘RVERSION’ but no such parameter src/rpymodule2130.c:89: error: declaration for parameter ‘RHOME’ but no such parameter src/rpymodule2130.c:83: error: declaration for parameter ‘default_mode’ but no such parameter src/rpymodule2130.c:80: error: declaration for parameter ‘aperm’ but no such parameter src/rpymodule2130.c:79: error: declaration for parameter ‘length’ but no such parameter src/rpymodule2130.c:78: error: declaration for parameter ‘set_item’ but no such parameter src/rpymodule2130.c:77: error: declaration for parameter ‘get_item’ but no such parameter src/rpymodule2130.c:63: error: declaration for parameter ‘use_numeric’ but no such parameter src/RPy.h:208: error: declaration for parameter ‘to_Pyobj_vector’ but no such parameter src/RPy.h:207: error: declaration for parameter ‘to_Pyobj_basic’ but no such parameter src/RPy.h:206: error: declaration for parameter ‘to_Pyobj_class’ but no such parameter src/RPy.h:205: error: declaration for parameter ‘to_Pyobj_proc’ but no such parameter src/RPy.h:201: error: declaration for parameter ‘start_events’ but no such parameter src/RPy.h:200: error: declaration for parameter ‘stop_events’ but no such parameter src/RPy.h:192: error: declaration for parameter ‘R_interact’ but no such parameter src/RPy.h:186: error: declaration for parameter ‘jump_now’ but no such parameter src/RPy.h:180: error: declaration for parameter ‘interrupt_R’ but no such parameter src/RPy.h:155: error: declaration for parameter ‘ptr_R_ShowFiles’ but no such parameter src/RPy.h:154: error: declaration for parameter ‘ptr_R_ReadConsole’ but no such parameter src/RPy.h:153: error: declaration for parameter ‘ptr_R_WriteConsole’ but no such parameter src/RPy.h:145: error: declaration for parameter ‘R_Outputfile’ but no such parameter src/RPy.h:139: error: declaration for parameter ‘init_io_routines’ but no such parameter src/RPy.h:138: error: declaration for parameter ‘Rf_initEmbeddedR’ but no such parameter src/RPy.h:135: error: declaration for parameter ‘get_last_error_msg’ but no such parameter src/RPy.h:128: error: declaration for parameter ‘get_fun_from_name’ but no such parameter src/RPy.h:127: error: declaration for parameter ‘do_eval_fun’ but no such parameter src/RPy.h:126: error: declaration for parameter ‘do_eval_expr’ but no such parameter src/setenv.h:46: error: declaration for parameter ‘setenv’ but no such parameter src/robjobject.h:62: error: declaration for parameter ‘Robj_new’ but no such parameter src/rpymodule2130.c:2104: error: expected ‘{’ at end of input error: command 'gcc' failed with exit status 1


Check each tool dependency that you want to uninstall and click Uninstall.
Select/unselect all tool dependencies
R version 2.11.0
rpy version 1.0.3

 
 
From: Greg Von Kuster [mailto:greg@bx.psu.edu] 
Sent: Tuesday, April 08, 2014 1:27 PM
To: Hayes, Curt
Cc: '[hidden email]'
Subject: Re: [galaxy-dev] Package/Module RPY
 
Hello Curt,
 
I believe that version 1.0.3 of the rpy package should be installing successfully from the main tool shed if you have a repository that contains a tool that defines a dependency to the rpy repository owned by devteam at http://toolshed.g2.bx.psu.edu/view/devteam/package_rpy_1_0_3
 
Here is the last test run for the tool shed's install and test framework for that repository.  I believe tis should install correctly using the dist repository, but if you're seeing problems, let us know.  Also, the next release is coming soon ( tentatively a week or so from now )..
 
Test runs
2014-04-07 17:25:49
Automated test environment
Successful installations
Repository dependencies - installation of these additional repositories is required
Tool shed
Name
Owner
Changeset revision
toolshed.g2.bx.psu.edu
package_r_2_11_0
devteam
5824d2b3bc8b
Tool dependencies
Type
Name
Version
R
package
2.11.0
Installation directory
/ToolDepsMain/R/2.11.0/devteam/package_rpy_1_0_3/82170c94ca7c
Type
Name
Version
rpy
package
1.0.3
Installation directory
/ToolDepsMain/rpy/1.0.3/devteam/package_rpy_1_0_3/82170c94ca7c
 
 
 
On Apr 8, 2014, at 3:28 PM, "Hayes, Curt" <[hidden email]> wrote:


Hi there all,
Does anyone have RPY working? I install via toolshed and the folder is empty, and shows missing dependencies.
I have searched previous posts, nothing since 2010. I have a local install (production config – postgres, etc – on CENTOS 6.5). I posted last week and it fell off the list. 


From Galaxy User interface:
Dataset generation errors
Dataset 81: Build base quality distribution on data 9
 
Tool execution generated the following error message:
Traceback (most recent call last):
  File "/apps/galaxy/galaxy-dist/tools/metag_tools/short_reads_figure_score.py", line 12, in <module>
    from rpy import *
ImportError: No module named rpy
 
I have attempted to download/install the scripts but they fail with multiple errors (most posts out there have a bad URL) - http://getgalaxyp.org/install.html says use: curlhttp://rpy.svn.sourceforge.net/viewvc/rpy/trunk/rpy/?view=tar > rpy.tar.gz
if you view that it redirects you to another URL.  
 
Via shell: R is installed: R version 2.13.0 (2011-04-13)
 
Can someone provide me some help please to get it working via Galaxy? I understand it works in Central.
 
From Toolshed:
Name
Version
Type
Installation status
1.0.3
package
Error
 
Toolshed Error:
In file included from src/rpymodule2110.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2110.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. <truncated>

Thanks,
Curt
 
CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message. 
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/
 
CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Package/Module RPY

Dannon Baker-2
On the face of it, looks like your system needs python-dev or some similar package with the appropriate header files.


On Tue, Apr 8, 2014 at 5:02 PM, Greg Von Kuster <[hidden email]> wrote:
Hi Curt,

Let's hope someone else can provide some insight into resolving this issue now that the error log from installing into your environment is available.  I'm not expert enough with system level things like this to provide much help here.  Sorry I'm not much help.

Greg Von Kuster

On Apr 8, 2014, at 4:49 PM, "Hayes, Curt" <[hidden email]> wrote:

Name
Description
Owner
Revision
Installation Status
Contains a tool dependency definition that downloads and installs version 1.0.3 of the python R interface.
devteam
82170c94ca7c
Installed, missing both tool and repository dependencies
Contains a tool dependency definition that downloads and compiles version 2.11.0 of the R interpreter.
devteam
5824d2b3bc8b
Installed
 
stalled tool shed repository 'package_rpy_1_0_3'

Tool shed:toolshed.g2.bx.psu.edu
Name:package_rpy_1_0_3
Description:
Revision:82170c94ca7c
Owner:devteam
Deleted:False

Dependencies of this repository

Name
Revision
Owner
Installation status
5824d2b3bc8b
devteam
Installed

Name
Version
Type
Installation status
2.11.0
package
Installed

Name
Version
Type
Installation status
1.0.3
package
Error
 
 
Tool shed repository 'package_rpy_1_0_3' tool dependencies


Name
Version
Type
Status
Error
2.11.0
package
Installed
1.0.3
package
Error
In file included from src/rpymodule2130.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:227: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:228: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_uintp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:330: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:331: error: expected ‘)’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:334: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:347: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:349: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:359: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:361: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:364: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:368: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:370: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:371: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:372: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:378: error: expected specifier-qualifier-list before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:391: error: expected specifier-qualifier-list before ‘PyArray_GetItemFunc’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:492: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:526: error: expected specifier-qualifier-list before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:536: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:561: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:569: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:578: error: expected declaration specifiers or ‘...’ before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:728: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:731: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:883: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:937: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:980: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1036, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: (Each undeclared identifier is reported only once /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: for each function it appears in.) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord2D’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: expected ‘;’ before ‘wb’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Next’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Reset’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h: At top level: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1223: error: expected specifier-qualifier-list before ‘npy_intp’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1238, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h: In function ‘_import_array’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘PyObject’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘numpy’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: warning: implicit declaration of function ‘PyImport_ImportModule’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1191: error: ‘c_api’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1193: warning: implicit declaration of function ‘PyObject_GetAttrString’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1194: warning: implicit declaration of function ‘Py_DECREF’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1195: warning: implicit declaration of function ‘PyCObject_Check’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1196: warning: implicit declaration of function ‘PyCObject_AsVoidPtr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: warning: implicit declaration of function ‘PyErr_Format’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: error: ‘PyExc_RuntimeError’ undeclared (first use in this function) In file included from src/rpymodule2130.c:51: src/RPy.h: At top level: src/RPy.h:91: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘n_intp’ In file included from src/RPy.h:105, from src/rpymodule2130.c:51: src/robjobject.h:46: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ src/robjobject.h:57: warning: return type defaults to ‘int’ src/robjobject.h: In function ‘DL_IMPORT’: src/robjobject.h:57: error: expected declaration specifiers before ‘Robj_Type’ In file included from src/rpymodule2130.c:51: src/RPy.h:112: error: expected ‘)’ before ‘*’ token src/RPy.h:113: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:114: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:115: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:132: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:133: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:138: error: storage class specified for parameter ‘Rf_initEmbeddedR’ src/RPy.h:139: error: storage class specified for parameter ‘init_io_routines’ src/RPy.h:145: error: storage class specified for parameter ‘R_Outputfile’ src/RPy.h:153: error: storage class specified for parameter ‘ptr_R_WriteConsole’ src/RPy.h:154: error: storage class specified for parameter ‘ptr_R_ReadConsole’ src/RPy.h:155: error: storage class specified for parameter ‘ptr_R_ShowFiles’ src/RPy.h:172: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:173: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:174: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:175: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:176: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:177: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:183: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘python_sigint’ src/RPy.h:186: error: storage class specified for parameter ‘jump_now’ src/RPy.h:189: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:192: error: storage class specified for parameter ‘R_interact’ src/RPy.h:195: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:197: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:205: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:205: error: storage class specified for parameter ‘to_Pyobj_proc’ src/RPy.h:206: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:206: error: storage class specified for parameter ‘to_Pyobj_class’ src/RPy.h:207: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:207: error: storage class specified for parameter ‘to_Pyobj_basic’ src/RPy.h:208: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:208: error: storage class specified for parameter ‘to_Pyobj_vector’ src/rpymodule2130.c:63: error: storage class specified for parameter ‘use_numeric’ src/rpymodule2130.c:63: error: parameter ‘use_numeric’ is initialized src/rpymodule2130.c:67: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:68: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:70: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:77: error: storage class specified for parameter ‘get_item’ src/rpymodule2130.c:78: error: storage class specified for parameter ‘set_item’ src/rpymodule2130.c:79: error: storage class specified for parameter ‘length’ src/rpymodule2130.c:80: error: storage class specified for parameter ‘aperm’ src/rpymodule2130.c:81: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:82: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:83: error: storage class specified for parameter ‘default_mode’ src/rpymodule2130.c:84: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:85: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:86: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:87: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:89: error: storage class specified for parameter ‘RHOME’ src/rpymodule2130.c:90: error: storage class specified for parameter ‘RVERSION’ src/rpymodule2130.c:91: error: storage class specified for parameter ‘RVER’ src/rpymodule2130.c:92: error: storage class specified for parameter ‘RUSER’ src/rpymodule2130.c:93: error: parameter ‘defaultargv’ is initialized src/rpymodule2130.c:93: warning: initialization from incompatible pointer type src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:94: error: parameter ‘defaultargc’ is initialized src/rpymodule2130.c:97: error: expected declaration specifiers before ‘PyInterpreterState’ src/rpymodule2130.c:100: error: redefinition of parameter ‘R_interact’ src/RPy.h:192: note: previous definition of ‘R_interact’ was here src/rpymodule2130.c:103: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:104: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:108: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:113: error: storage class specified for parameter ‘R_References’ src/rpymodule2130.c:117: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:141: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:160: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:183: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:207: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:292: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:330: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:510: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:626: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:652: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:686: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:710: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:751: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:752: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:774: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:775: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:900: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:939: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:940: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:977: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:978: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:999: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1000: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1015: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:1048: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1049: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1067: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1092: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1093: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1139: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1191: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1192: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1276: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1342: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1369: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1392: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_methods’ src/rpymodule2130.c:1398: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1404: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1423: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1449: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1490: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1564: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_as_sequence’ src/rpymodule2130.c:1575: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1589: error: expected declaration specifiers before ‘PyTypeObject’ src/rpymodule2130.c:1656: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1663: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1682: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1700: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1709: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1739: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1754: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1774: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1807: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1818: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1834: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1863: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rpy_methods’ src/rpymodule2130.c:1877: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1972: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:113: error: declaration for parameter ‘R_References’ but no such parameter src/rpymodule2130.c:100: error: declaration for parameter ‘R_interact’ but no such parameter src/rpymodule2130.c:94: error: declaration for parameter ‘defaultargc’ but no such parameter src/rpymodule2130.c:93: error: declaration for parameter ‘defaultargv’ but no such parameter src/rpymodule2130.c:92: error: declaration for parameter ‘RUSER’ but no such parameter src/rpymodule2130.c:91: error: declaration for parameter ‘RVER’ but no such parameter src/rpymodule2130.c:90: error: declaration for parameter ‘RVERSION’ but no such parameter src/rpymodule2130.c:89: error: declaration for parameter ‘RHOME’ but no such parameter src/rpymodule2130.c:83: error: declaration for parameter ‘default_mode’ but no such parameter src/rpymodule2130.c:80: error: declaration for parameter ‘aperm’ but no such parameter src/rpymodule2130.c:79: error: declaration for parameter ‘length’ but no such parameter src/rpymodule2130.c:78: error: declaration for parameter ‘set_item’ but no such parameter src/rpymodule2130.c:77: error: declaration for parameter ‘get_item’ but no such parameter src/rpymodule2130.c:63: error: declaration for parameter ‘use_numeric’ but no such parameter src/RPy.h:208: error: declaration for parameter ‘to_Pyobj_vector’ but no such parameter src/RPy.h:207: error: declaration for parameter ‘to_Pyobj_basic’ but no such parameter src/RPy.h:206: error: declaration for parameter ‘to_Pyobj_class’ but no such parameter src/RPy.h:205: error: declaration for parameter ‘to_Pyobj_proc’ but no such parameter src/RPy.h:201: error: declaration for parameter ‘start_events’ but no such parameter src/RPy.h:200: error: declaration for parameter ‘stop_events’ but no such parameter src/RPy.h:192: error: declaration for parameter ‘R_interact’ but no such parameter src/RPy.h:186: error: declaration for parameter ‘jump_now’ but no such parameter src/RPy.h:180: error: declaration for parameter ‘interrupt_R’ but no such parameter src/RPy.h:155: error: declaration for parameter ‘ptr_R_ShowFiles’ but no such parameter src/RPy.h:154: error: declaration for parameter ‘ptr_R_ReadConsole’ but no such parameter src/RPy.h:153: error: declaration for parameter ‘ptr_R_WriteConsole’ but no such parameter src/RPy.h:145: error: declaration for parameter ‘R_Outputfile’ but no such parameter src/RPy.h:139: error: declaration for parameter ‘init_io_routines’ but no such parameter src/RPy.h:138: error: declaration for parameter ‘Rf_initEmbeddedR’ but no such parameter src/RPy.h:135: error: declaration for parameter ‘get_last_error_msg’ but no such parameter src/RPy.h:128: error: declaration for parameter ‘get_fun_from_name’ but no such parameter src/RPy.h:127: error: declaration for parameter ‘do_eval_fun’ but no such parameter src/RPy.h:126: error: declaration for parameter ‘do_eval_expr’ but no such parameter src/setenv.h:46: error: declaration for parameter ‘setenv’ but no such parameter src/robjobject.h:62: error: declaration for parameter ‘Robj_new’ but no such parameter src/rpymodule2130.c:2104: error: expected ‘{’ at end of input error: command 'gcc' failed with exit status 1


Check each tool dependency that you want to uninstall and click Uninstall.
Select/unselect all tool dependencies
R version 2.11.0
rpy version 1.0.3

 
 
From: Greg Von Kuster [mailto:[hidden email]bx.psu.edu] 
Sent: Tuesday, April 08, 2014 1:27 PM
To: Hayes, Curt
Cc: '[hidden email]'
Subject: Re: [galaxy-dev] Package/Module RPY
 
Hello Curt,
 
I believe that version 1.0.3 of the rpy package should be installing successfully from the main tool shed if you have a repository that contains a tool that defines a dependency to the rpy repository owned by devteam at http://toolshed.g2.bx.psu.edu/view/devteam/package_rpy_1_0_3
 
Here is the last test run for the tool shed's install and test framework for that repository.  I believe tis should install correctly using the dist repository, but if you're seeing problems, let us know.  Also, the next release is coming soon ( tentatively a week or so from now )..
 
Test runs
2014-04-07 17:25:49
Automated test environment
Successful installations
Repository dependencies - installation of these additional repositories is required
Tool shed
Name
Owner
Changeset revision
toolshed.g2.bx.psu.edu
package_r_2_11_0
devteam
5824d2b3bc8b
Tool dependencies
Type
Name
Version
R
package
2.11.0
Installation directory
/ToolDepsMain/R/2.11.0/devteam/package_rpy_1_0_3/82170c94ca7c
Type
Name
Version
rpy
package
1.0.3
Installation directory
/ToolDepsMain/rpy/1.0.3/devteam/package_rpy_1_0_3/82170c94ca7c
 
 
 
On Apr 8, 2014, at 3:28 PM, "Hayes, Curt" <[hidden email]> wrote:


Hi there all,
Does anyone have RPY working? I install via toolshed and the folder is empty, and shows missing dependencies.
I have searched previous posts, nothing since 2010. I have a local install (production config – postgres, etc – on CENTOS 6.5). I posted last week and it fell off the list. 


From Galaxy User interface:
Dataset generation errors
Dataset 81: Build base quality distribution on data 9
 
Tool execution generated the following error message:
Traceback (most recent call last):
  File "/apps/galaxy/galaxy-dist/tools/metag_tools/short_reads_figure_score.py", line 12, in <module>
    from rpy import *
ImportError: No module named rpy
 
I have attempted to download/install the scripts but they fail with multiple errors (most posts out there have a bad URL) - http://getgalaxyp.org/install.html says use: curlhttp://rpy.svn.sourceforge.net/viewvc/rpy/trunk/rpy/?view=tar > rpy.tar.gz
if you view that it redirects you to another URL.  
 
Via shell: R is installed: R version 2.13.0 (2011-04-13)
 
Can someone provide me some help please to get it working via Galaxy? I understand it works in Central.
 
From Toolshed:
Name
Version
Type
Installation status
1.0.3
package
Error
 
Toolshed Error:
In file included from src/rpymodule2110.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2110.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. <truncated>

Thanks,
Curt
 
CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message. 
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/
 
CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Package/Module RPY

Hayes, Curt

OK thank you. So I installed python-devel (I thought it was already installed), now different error:

I do have gcc etc. installed / in the path.

Tool shed repository 'package_rpy_1_0_3' tool dependencies



Name

Version

Type

Status

Error

R

2.11.0

package

Installed

rpy

1.0.3

package

Error

In file included from /usr/include/python2.6/pyconfig.h:6, from /usr/include/python2.6/Python.h:8, from src/RPy.h:56, from src/rpymodule2130.c:51: /usr/include/python2.6/pyconfig-64.h:1043:1: warning: "_XOPEN_SOURCE" redefined In file included from /usr/include/stdlib.h:25, from /usr/lib64/R/include/R.h:28, from src/RPy.h:51, from src/rpymodule2130.c:51: /usr/include/features.h:164:1: warning: this is the location of the previous definition src/rpymodule2130.c:1565: warning: initialization from incompatible pointer type src/rpymodule2130.c:1568: warning: ‘intargfunc’ is deprecated src/rpymodule2130.c:1568: warning: initialization from incompatible pointer type src/rpymodule2130.c:1569: warning: ‘intintargfunc’ is deprecated src/rpymodule2130.c:1569: warning: initialization from incompatible pointer type src/rpymodule2130.c:1570: warning: initialization from incompatible pointer type src/rpymodule2130.c: In function ‘r_finalize’: src/rpymodule2130.c:1782: warning: implicit declaration of function ‘Rf_KillAllDevices’ src/rpymodule2130.c:1788: warning: implicit declaration of function ‘R_CleanTempDir’ src/rpymodule2130.c:1776: warning: unused variable ‘tmpdir’ src/rpymodule2130.c:1775: warning: unused variable ‘buf’ In file included from /usr/include/python2.6/pyconfig.h:6, from /usr/include/python2.6/Python.h:8, from src/RPy.h:56, from src/R_eval2130.c:63: /usr/include/python2.6/pyconfig-64.h:1043:1: warning: "_XOPEN_SOURCE" redefined In file included from /usr/include/stdlib.h:25, from /usr/lib64/R/include/R.h:28, from src/RPy.h:51, from src/R_eval2130.c:63: /usr/include/features.h:164:1: warning: this is the location of the previous definition /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1187: warning: ‘_import_array’ defined but not used In file included from /usr/include/python2.6/pyconfig.h:6, from /usr/include/python2.6/Python.h:8, from src/RPy.h:56, from src/io2130.c:43: /usr/include/python2.6/pyconfig-64.h:1043:1: warning: "_XOPEN_SOURCE" redefined In file included from /usr/include/stdlib.h:25, from /usr/lib64/R/include/R.h:28, from src/RPy.h:51, from src/io2130.c:43: /usr/include/features.h:164:1: warning: this is the location of the previous definition src/io2130.c: In function ‘RPy_ReadConsole’: src/io2130.c:133: warning: pointer targets in passing argument 1 of ‘snprintf’ differ in signedness /usr/include/bits/stdio2.h:62: note: expected ‘char * __restrict__’ but argument is of type ‘unsigned char *’ src/io2130.c: At top level: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1187: warning: ‘_import_array’ defined but not used /usr/bin/ld: cannot find -lRlapack collect2: ld returned 1 exit status error: command 'gcc' failed with exit status 1

 

 

From: Dannon Baker [mailto:[hidden email]]
Sent: Tuesday, April 08, 2014 2:13 PM
To: Greg Von Kuster
Cc: Hayes, Curt; [hidden email]
Subject: Re: [galaxy-dev] Package/Module RPY

 

On the face of it, looks like your system needs python-dev or some similar package with the appropriate header files.

 

On Tue, Apr 8, 2014 at 5:02 PM, Greg Von Kuster <[hidden email]> wrote:

Hi Curt,

 

Let's hope someone else can provide some insight into resolving this issue now that the error log from installing into your environment is available.  I'm not expert enough with system level things like this to provide much help here.  Sorry I'm not much help.

 

Greg Von Kuster

 

On Apr 8, 2014, at 4:49 PM, "Hayes, Curt" <[hidden email]> wrote:

 

Name

Description

Owner

Revision

Installation Status

Contains a tool dependency definition that downloads and installs version 1.0.3 of the python R interface.

devteam

82170c94ca7c

Installed, missing both tool and repository dependencies

Contains a tool dependency definition that downloads and compiles version 2.11.0 of the R interpreter.

devteam

5824d2b3bc8b

Installed

 

stalled tool shed repository 'package_rpy_1_0_3'

Tool shed:toolshed.g2.bx.psu.edu

Name:package_rpy_1_0_3

Description:

Revision:82170c94ca7c

Owner:devteam

Deleted:False

Dependencies of this repository

Missing repository dependencies - installation of these additional repositories is required

 

Installed repository dependencies

Name

Revision

Owner

Installation status

5824d2b3bc8b

devteam

Installed

 

Installed tool dependencies - click the name to browse the dependency installation directory

Name

Version

Type

Installation status

R

2.11.0

package

Installed

 

Missing tool dependencies - click the name to install the missing dependency

Name

Version

Type

Installation status

rpy

1.0.3

package

Error

 

 

Tool shed repository 'package_rpy_1_0_3' tool dependencies

 

Name

Version

Type

Status

Error

R

2.11.0

package

Installed

rpy

1.0.3

package

Error

In file included from src/rpymodule2130.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:227: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:228: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_uintp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:330: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:331: error: expected ‘)’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:334: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:347: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:349: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:359: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:361: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:364: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:368: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:370: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:371: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:372: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:378: error: expected specifier-qualifier-list before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:391: error: expected specifier-qualifier-list before ‘PyArray_GetItemFunc’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:492: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:526: error: expected specifier-qualifier-list before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:536: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:561: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:569: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:578: error: expected declaration specifiers or ‘...’ before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:728: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:731: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:883: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:937: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:980: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1036, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: (Each undeclared identifier is reported only once /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: for each function it appears in.) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord2D’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: expected ‘;’ before ‘wb’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Next’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Reset’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h: At top level: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1223: error: expected specifier-qualifier-list before ‘npy_intp’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1238, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h: In function ‘_import_array’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘PyObject’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘numpy’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: warning: implicit declaration of function ‘PyImport_ImportModule’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1191: error: ‘c_api’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1193: warning: implicit declaration of function ‘PyObject_GetAttrString’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1194: warning: implicit declaration of function ‘Py_DECREF’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1195: warning: implicit declaration of function ‘PyCObject_Check’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1196: warning: implicit declaration of function ‘PyCObject_AsVoidPtr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: warning: implicit declaration of function ‘PyErr_Format’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: error: ‘PyExc_RuntimeError’ undeclared (first use in this function) In file included from src/rpymodule2130.c:51: src/RPy.h: At top level: src/RPy.h:91: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘n_intp’ In file included from src/RPy.h:105, from src/rpymodule2130.c:51: src/robjobject.h:46: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ src/robjobject.h:57: warning: return type defaults to ‘int’ src/robjobject.h: In function ‘DL_IMPORT’: src/robjobject.h:57: error: expected declaration specifiers before ‘Robj_Type’ In file included from src/rpymodule2130.c:51: src/RPy.h:112: error: expected ‘)’ before ‘*’ token src/RPy.h:113: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:114: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:115: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:132: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:133: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:138: error: storage class specified for parameter ‘Rf_initEmbeddedR’ src/RPy.h:139: error: storage class specified for parameter ‘init_io_routines’ src/RPy.h:145: error: storage class specified for parameter ‘R_Outputfile’ src/RPy.h:153: error: storage class specified for parameter ‘ptr_R_WriteConsole’ src/RPy.h:154: error: storage class specified for parameter ‘ptr_R_ReadConsole’ src/RPy.h:155: error: storage class specified for parameter ‘ptr_R_ShowFiles’ src/RPy.h:172: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:173: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:174: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:175: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:176: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:177: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:183: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘python_sigint’ src/RPy.h:186: error: storage class specified for parameter ‘jump_now’ src/RPy.h:189: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:192: error: storage class specified for parameter ‘R_interact’ src/RPy.h:195: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:197: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:205: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:205: error: storage class specified for parameter ‘to_Pyobj_proc’ src/RPy.h:206: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:206: error: storage class specified for parameter ‘to_Pyobj_class’ src/RPy.h:207: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:207: error: storage class specified for parameter ‘to_Pyobj_basic’ src/RPy.h:208: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:208: error: storage class specified for parameter ‘to_Pyobj_vector’ src/rpymodule2130.c:63: error: storage class specified for parameter ‘use_numeric’ src/rpymodule2130.c:63: error: parameter ‘use_numeric’ is initialized src/rpymodule2130.c:67: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:68: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:70: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:77: error: storage class specified for parameter ‘get_item’ src/rpymodule2130.c:78: error: storage class specified for parameter ‘set_item’ src/rpymodule2130.c:79: error: storage class specified for parameter ‘length’ src/rpymodule2130.c:80: error: storage class specified for parameter ‘aperm’ src/rpymodule2130.c:81: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:82: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:83: error: storage class specified for parameter ‘default_mode’ src/rpymodule2130.c:84: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:85: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:86: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:87: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:89: error: storage class specified for parameter ‘RHOME’ src/rpymodule2130.c:90: error: storage class specified for parameter ‘RVERSION’ src/rpymodule2130.c:91: error: storage class specified for parameter ‘RVER’ src/rpymodule2130.c:92: error: storage class specified for parameter ‘RUSER’ src/rpymodule2130.c:93: error: parameter ‘defaultargv’ is initialized src/rpymodule2130.c:93: warning: initialization from incompatible pointer type src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:94: error: parameter ‘defaultargc’ is initialized src/rpymodule2130.c:97: error: expected declaration specifiers before ‘PyInterpreterState’ src/rpymodule2130.c:100: error: redefinition of parameter ‘R_interact’ src/RPy.h:192: note: previous definition of ‘R_interact’ was here src/rpymodule2130.c:103: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:104: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:108: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:113: error: storage class specified for parameter ‘R_References’ src/rpymodule2130.c:117: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:141: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:160: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:183: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:207: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:292: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:330: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:510: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:626: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:652: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:686: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:710: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:751: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:752: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:774: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:775: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:900: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:939: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:940: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:977: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:978: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:999: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1000: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1015: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:1048: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1049: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1067: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1092: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1093: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1139: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1191: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1192: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1276: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1342: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1369: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1392: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_methods’ src/rpymodule2130.c:1398: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1404: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1423: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1449: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1490: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1564: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_as_sequence’ src/rpymodule2130.c:1575: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1589: error: expected declaration specifiers before ‘PyTypeObject’ src/rpymodule2130.c:1656: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1663: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1682: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1700: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1709: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1739: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1754: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1774: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1807: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1818: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1834: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1863: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rpy_methods’ src/rpymodule2130.c:1877: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1972: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:113: error: declaration for parameter ‘R_References’ but no such parameter src/rpymodule2130.c:100: error: declaration for parameter ‘R_interact’ but no such parameter src/rpymodule2130.c:94: error: declaration for parameter ‘defaultargc’ but no such parameter src/rpymodule2130.c:93: error: declaration for parameter ‘defaultargv’ but no such parameter src/rpymodule2130.c:92: error: declaration for parameter ‘RUSER’ but no such parameter src/rpymodule2130.c:91: error: declaration for parameter ‘RVER’ but no such parameter src/rpymodule2130.c:90: error: declaration for parameter ‘RVERSION’ but no such parameter src/rpymodule2130.c:89: error: declaration for parameter ‘RHOME’ but no such parameter src/rpymodule2130.c:83: error: declaration for parameter ‘default_mode’ but no such parameter src/rpymodule2130.c:80: error: declaration for parameter ‘aperm’ but no such parameter src/rpymodule2130.c:79: error: declaration for parameter ‘length’ but no such parameter src/rpymodule2130.c:78: error: declaration for parameter ‘set_item’ but no such parameter src/rpymodule2130.c:77: error: declaration for parameter ‘get_item’ but no such parameter src/rpymodule2130.c:63: error: declaration for parameter ‘use_numeric’ but no such parameter src/RPy.h:208: error: declaration for parameter ‘to_Pyobj_vector’ but no such parameter src/RPy.h:207: error: declaration for parameter ‘to_Pyobj_basic’ but no such parameter src/RPy.h:206: error: declaration for parameter ‘to_Pyobj_class’ but no such parameter src/RPy.h:205: error: declaration for parameter ‘to_Pyobj_proc’ but no such parameter src/RPy.h:201: error: declaration for parameter ‘start_events’ but no such parameter src/RPy.h:200: error: declaration for parameter ‘stop_events’ but no such parameter src/RPy.h:192: error: declaration for parameter ‘R_interact’ but no such parameter src/RPy.h:186: error: declaration for parameter ‘jump_now’ but no such parameter src/RPy.h:180: error: declaration for parameter ‘interrupt_R’ but no such parameter src/RPy.h:155: error: declaration for parameter ‘ptr_R_ShowFiles’ but no such parameter src/RPy.h:154: error: declaration for parameter ‘ptr_R_ReadConsole’ but no such parameter src/RPy.h:153: error: declaration for parameter ‘ptr_R_WriteConsole’ but no such parameter src/RPy.h:145: error: declaration for parameter ‘R_Outputfile’ but no such parameter src/RPy.h:139: error: declaration for parameter ‘init_io_routines’ but no such parameter src/RPy.h:138: error: declaration for parameter ‘Rf_initEmbeddedR’ but no such parameter src/RPy.h:135: error: declaration for parameter ‘get_last_error_msg’ but no such parameter src/RPy.h:128: error: declaration for parameter ‘get_fun_from_name’ but no such parameter src/RPy.h:127: error: declaration for parameter ‘do_eval_fun’ but no such parameter src/RPy.h:126: error: declaration for parameter ‘do_eval_expr’ but no such parameter src/setenv.h:46: error: declaration for parameter ‘setenv’ but no such parameter src/robjobject.h:62: error: declaration for parameter ‘Robj_new’ but no such parameter src/rpymodule2130.c:2104: error: expected ‘{’ at end of input error: command 'gcc' failed with exit status 1

 

Check each tool dependency that you want to uninstall and click Uninstall.

Select/unselect all tool dependencies

R version 2.11.0

rpy version 1.0.3

 

 

From: Greg Von Kuster [mailto:[hidden email]bx.psu.edu
Sent: Tuesday, April 08, 2014 1:27 PM
To: Hayes, Curt
Cc: '[hidden email]'
Subject: Re: [galaxy-dev] Package/Module RPY

 

Hello Curt,

 

I believe that version 1.0.3 of the rpy package should be installing successfully from the main tool shed if you have a repository that contains a tool that defines a dependency to the rpy repository owned by devteam at http://toolshed.g2.bx.psu.edu/view/devteam/package_rpy_1_0_3

 

Here is the last test run for the tool shed's install and test framework for that repository.  I believe tis should install correctly using the dist repository, but if you're seeing problems, let us know.  Also, the next release is coming soon ( tentatively a week or so from now )..

 

Test runs

2014-04-07 17:25:49

Automated test environment

Successful installations

Repository dependencies - installation of these additional repositories is required

Tool shed

Name

Owner

Changeset revision

toolshed.g2.bx.psu.edu

package_r_2_11_0

devteam

5824d2b3bc8b

Tool dependencies

Type

Name

Version

R

package

2.11.0

Installation directory

/ToolDepsMain/R/2.11.0/devteam/package_rpy_1_0_3/82170c94ca7c

Type

Name

Version

rpy

package

1.0.3

Installation directory

/ToolDepsMain/rpy/1.0.3/devteam/package_rpy_1_0_3/82170c94ca7c

 

 

 

On Apr 8, 2014, at 3:28 PM, "Hayes, Curt" <[hidden email]> wrote:

 

Hi there all,

Does anyone have RPY working? I install via toolshed and the folder is empty, and shows missing dependencies.

I have searched previous posts, nothing since 2010. I have a local install (production config – postgres, etc – on CENTOS 6.5). I posted last week and it fell off the list. 

From Galaxy User interface:

Dataset generation errors

Dataset 81: Build base quality distribution on data 9

 

Tool execution generated the following error message:

Traceback (most recent call last):

  File "/apps/galaxy/galaxy-dist/tools/metag_tools/short_reads_figure_score.py", line 12, in <module>

    from rpy import *

ImportError: No module named rpy

 

I have attempted to download/install the scripts but they fail with multiple errors (most posts out there have a bad URL) - http://getgalaxyp.org/install.html says use: curlhttp://rpy.svn.sourceforge.net/viewvc/rpy/trunk/rpy/?view=tar > rpy.tar.gz

if you view that it redirects you to another URL.  

 

Via shell: R is installed: R version 2.13.0 (2011-04-13)

 

Can someone provide me some help please to get it working via Galaxy? I understand it works in Central.

 

From Toolshed:

Name

Version

Type

Installation status

rpy

1.0.3

package

Error

 

Toolshed Error:

In file included from src/rpymodule2110.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2110.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. <truncated>


Thanks,
Curt

 

CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message. 
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

 

CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

 

CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Package/Module RPY

Greg Von Kuster
<base href="x-msg://876/">Hi Curt,

Tool dependency recipe authors can assume all of the following packages are available in the environment into which their recipes will install packages.  See https://wiki.galaxyproject.org/InstallAndTestCertification

Perhaps your environment is missing one or more of these as well.

  • autoconf
  • automake
  • autotools-dev
  • build-essential
  • cmake
  • git-core
  • libatlas-base-dev
  • libblas-dev
  • liblapack-dev
  • libc6-dev
  • mercurial
  • python2.6
  • python2.6-dev
  • pkg-config
  • subversion
  • python-dev
  • python-pip

On Apr 8, 2014, at 7:00 PM, "Hayes, Curt" <[hidden email]> wrote:

OK thank you. So I installed python-devel (I thought it was already installed), now different error:
I do have gcc etc. installed / in the path.
Tool shed repository 'package_rpy_1_0_3' tool dependencies


Name
Version
Type
Status
Error
2.11.0
package
Installed
1.0.3
package
Error
In file included from /usr/include/python2.6/pyconfig.h:6, from /usr/include/python2.6/Python.h:8, from src/RPy.h:56, from src/rpymodule2130.c:51: /usr/include/python2.6/pyconfig-64.h:1043:1: warning: "_XOPEN_SOURCE" redefined In file included from /usr/include/stdlib.h:25, from /usr/lib64/R/include/R.h:28, from src/RPy.h:51, from src/rpymodule2130.c:51: /usr/include/features.h:164:1: warning: this is the location of the previous definition src/rpymodule2130.c:1565: warning: initialization from incompatible pointer type src/rpymodule2130.c:1568: warning: ‘intargfunc’ is deprecated src/rpymodule2130.c:1568: warning: initialization from incompatible pointer type src/rpymodule2130.c:1569: warning: ‘intintargfunc’ is deprecated src/rpymodule2130.c:1569: warning: initialization from incompatible pointer type src/rpymodule2130.c:1570: warning: initialization from incompatible pointer type src/rpymodule2130.c: In function ‘r_finalize’: src/rpymodule2130.c:1782: warning: implicit declaration of function ‘Rf_KillAllDevices’ src/rpymodule2130.c:1788: warning: implicit declaration of function ‘R_CleanTempDir’ src/rpymodule2130.c:1776: warning: unused variable ‘tmpdir’ src/rpymodule2130.c:1775: warning: unused variable ‘buf’ In file included from /usr/include/python2.6/pyconfig.h:6, from /usr/include/python2.6/Python.h:8, from src/RPy.h:56, from src/R_eval2130.c:63: /usr/include/python2.6/pyconfig-64.h:1043:1: warning: "_XOPEN_SOURCE" redefined In file included from /usr/include/stdlib.h:25, from /usr/lib64/R/include/R.h:28, from src/RPy.h:51, from src/R_eval2130.c:63: /usr/include/features.h:164:1: warning: this is the location of the previous definition /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1187: warning: ‘_import_array’ defined but not used In file included from /usr/include/python2.6/pyconfig.h:6, from /usr/include/python2.6/Python.h:8, from src/RPy.h:56, from src/io2130.c:43: /usr/include/python2.6/pyconfig-64.h:1043:1: warning: "_XOPEN_SOURCE" redefined In file included from /usr/include/stdlib.h:25, from /usr/lib64/R/include/R.h:28, from src/RPy.h:51, from src/io2130.c:43: /usr/include/features.h:164:1: warning: this is the location of the previous definition src/io2130.c: In function ‘RPy_ReadConsole’: src/io2130.c:133: warning: pointer targets in passing argument 1 of ‘snprintf’ differ in signedness /usr/include/bits/stdio2.h:62: note: expected ‘char * __restrict__’ but argument is of type ‘unsigned char *’ src/io2130.c: At top level: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1187: warning: ‘_import_array’ defined but not used /usr/bin/ld: cannot find -lRlapack collect2: ld returned 1 exit status error: command 'gcc' failed with exit status 1
 
 
From: Dannon Baker [mailto:dannon.baker@gmail.com] 
Sent: Tuesday, April 08, 2014 2:13 PM
To: Greg Von Kuster
Cc: Hayes, Curt; [hidden email]
Subject: Re: [galaxy-dev] Package/Module RPY
 
On the face of it, looks like your system needs python-dev or some similar package with the appropriate header files.

 

On Tue, Apr 8, 2014 at 5:02 PM, Greg Von Kuster <[hidden email]> wrote:
Hi Curt,
 
Let's hope someone else can provide some insight into resolving this issue now that the error log from installing into your environment is available.  I'm not expert enough with system level things like this to provide much help here.  Sorry I'm not much help.
 
Greg Von Kuster
 
On Apr 8, 2014, at 4:49 PM, "Hayes, Curt" <[hidden email]> wrote:
 
Name
Description
Owner
Revision
Installation Status
Contains a tool dependency definition that downloads and installs version 1.0.3 of the python R interface.
devteam
82170c94ca7c
Installed, missing both tool and repository dependencies
Contains a tool dependency definition that downloads and compiles version 2.11.0 of the R interpreter.
devteam
5824d2b3bc8b
Installed
 
stalled tool shed repository 'package_rpy_1_0_3'
Tool shed:toolshed.g2.bx.psu.edu
Name:package_rpy_1_0_3
Description:
Revision:82170c94ca7c
Owner:devteam
Deleted:False
Dependencies of this repository
Missing repository dependencies - installation of these additional repositories is required

Installed repository dependencies
Name
Revision
Owner
Installation status
5824d2b3bc8b
devteam
Installed

Installed tool dependencies - click the name to browse the dependency installation directory
Name
Version
Type
Installation status
2.11.0
package
Installed

Missing tool dependencies - click the name to install the missing dependency
Name
Version
Type
Installation status
1.0.3
package
Error
 
 
Tool shed repository 'package_rpy_1_0_3' tool dependencies

 

Name
Version
Type
Status
Error
2.11.0
package
Installed
1.0.3
package
Error
In file included from src/rpymodule2130.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:227: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:228: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘npy_uintp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:330: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:331: error: expected ‘)’ before ‘*’ token /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:333: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:334: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:344: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:346: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:347: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:349: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:359: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:361: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:362: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:364: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:368: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:370: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:371: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:372: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:373: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:374: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:378: error: expected specifier-qualifier-list before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:391: error: expected specifier-qualifier-list before ‘PyArray_GetItemFunc’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:492: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:526: error: expected specifier-qualifier-list before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:536: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:561: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:569: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:578: error: expected declaration specifiers or ‘...’ before ‘PyObject’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:728: error: expected declaration specifiers or ‘...’ before ‘npy_intp’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:731: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:883: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:937: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:980: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1036, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: (Each undeclared identifier is reported only once /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: for each function it appears in.) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:40: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:42: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:43: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘_PyArrayNeighborhoodIter_IncrCoord2D’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:55: error: expected ‘;’ before ‘wb’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘wb’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:57: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:58: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Next’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:71: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h: In function ‘PyArrayNeighborhoodIter_Reset’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: ‘npy_intp’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:82: error: expected ‘;’ before ‘i’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘i’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:84: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘nd’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:85: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘bounds’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘dataptr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘translate’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/_neighborhood_iterator_imp.h:87: error: ‘PyArrayNeighborhoodIterObject’ has no member named ‘coordinates’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h: At top level: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1223: error: expected specifier-qualifier-list before ‘npy_intp’ In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:1238, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2130.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h: In function ‘_import_array’: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘PyObject’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: error: ‘numpy’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1190: warning: implicit declaration of function ‘PyImport_ImportModule’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1191: error: ‘c_api’ undeclared (first use in this function) /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1193: warning: implicit declaration of function ‘PyObject_GetAttrString’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1194: warning: implicit declaration of function ‘Py_DECREF’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1195: warning: implicit declaration of function ‘PyCObject_Check’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1196: warning: implicit declaration of function ‘PyCObject_AsVoidPtr’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: warning: implicit declaration of function ‘PyErr_Format’ /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/__multiarray_api.h:1203: error: ‘PyExc_RuntimeError’ undeclared (first use in this function) In file included from src/rpymodule2130.c:51: src/RPy.h: At top level: src/RPy.h:91: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘n_intp’ In file included from src/RPy.h:105, from src/rpymodule2130.c:51: src/robjobject.h:46: error: expected specifier-qualifier-list before ‘PyObject_HEAD’ src/robjobject.h:57: warning: return type defaults to ‘int’ src/robjobject.h: In function ‘DL_IMPORT’: src/robjobject.h:57: error: expected declaration specifiers before ‘Robj_Type’ In file included from src/rpymodule2130.c:51: src/RPy.h:112: error: expected ‘)’ before ‘*’ token src/RPy.h:113: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:114: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:115: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:132: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:133: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:138: error: storage class specified for parameter ‘Rf_initEmbeddedR’ src/RPy.h:139: error: storage class specified for parameter ‘init_io_routines’ src/RPy.h:145: error: storage class specified for parameter ‘R_Outputfile’ src/RPy.h:153: error: storage class specified for parameter ‘ptr_R_WriteConsole’ src/RPy.h:154: error: storage class specified for parameter ‘ptr_R_ReadConsole’ src/RPy.h:155: error: storage class specified for parameter ‘ptr_R_ShowFiles’ src/RPy.h:172: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:173: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:174: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:175: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:176: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:177: error: expected declaration specifiers before ‘PyObject’ src/RPy.h:183: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘python_sigint’ src/RPy.h:186: error: storage class specified for parameter ‘jump_now’ src/RPy.h:189: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:192: error: storage class specified for parameter ‘R_interact’ src/RPy.h:195: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:197: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/RPy.h:205: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:205: error: storage class specified for parameter ‘to_Pyobj_proc’ src/RPy.h:206: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:206: error: storage class specified for parameter ‘to_Pyobj_class’ src/RPy.h:207: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:207: error: storage class specified for parameter ‘to_Pyobj_basic’ src/RPy.h:208: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/RPy.h:208: error: storage class specified for parameter ‘to_Pyobj_vector’ src/rpymodule2130.c:63: error: storage class specified for parameter ‘use_numeric’ src/rpymodule2130.c:63: error: parameter ‘use_numeric’ is initialized src/rpymodule2130.c:67: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:68: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:70: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:77: error: storage class specified for parameter ‘get_item’ src/rpymodule2130.c:78: error: storage class specified for parameter ‘set_item’ src/rpymodule2130.c:79: error: storage class specified for parameter ‘length’ src/rpymodule2130.c:80: error: storage class specified for parameter ‘aperm’ src/rpymodule2130.c:81: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:82: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:83: error: storage class specified for parameter ‘default_mode’ src/rpymodule2130.c:84: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:85: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:86: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:87: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:89: error: storage class specified for parameter ‘RHOME’ src/rpymodule2130.c:90: error: storage class specified for parameter ‘RVERSION’ src/rpymodule2130.c:91: error: storage class specified for parameter ‘RVER’ src/rpymodule2130.c:92: error: storage class specified for parameter ‘RUSER’ src/rpymodule2130.c:93: error: parameter ‘defaultargv’ is initialized src/rpymodule2130.c:93: warning: initialization from incompatible pointer type src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:93: warning: excess elements in scalar initializer src/rpymodule2130.c:93: warning: (near initialization for ‘defaultargv’) src/rpymodule2130.c:94: error: parameter ‘defaultargc’ is initialized src/rpymodule2130.c:97: error: expected declaration specifiers before ‘PyInterpreterState’ src/rpymodule2130.c:100: error: redefinition of parameter ‘R_interact’ src/RPy.h:192: note: previous definition of ‘R_interact’ was here src/rpymodule2130.c:103: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:104: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:108: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:113: error: storage class specified for parameter ‘R_References’ src/rpymodule2130.c:117: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:141: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:160: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:183: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:207: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:292: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:330: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:510: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:626: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:652: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:686: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:710: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:751: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:752: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:774: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:775: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:900: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:939: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:940: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:977: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:978: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:999: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1000: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1015: error: expected declaration specifiers before ‘PyObject’ src/rpymodule2130.c:1048: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1049: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1067: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1092: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1093: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1139: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1191: error: expected declaration specifiers or ‘...’ before ‘PyObject’ src/rpymodule2130.c:1192: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1276: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1342: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1369: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1392: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_methods’ src/rpymodule2130.c:1398: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1404: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1423: error: expected ‘)’ before ‘*’ token src/rpymodule2130.c:1449: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1490: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1564: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Robj_as_sequence’ src/rpymodule2130.c:1575: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1589: error: expected declaration specifiers before ‘PyTypeObject’ src/rpymodule2130.c:1656: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1663: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1682: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1700: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1709: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1739: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1754: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1774: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1807: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1818: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token src/rpymodule2130.c:1834: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token src/rpymodule2130.c:1863: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rpy_methods’ src/rpymodule2130.c:1877: error: expected declaration specifiers before ‘;’ token src/rpymodule2130.c:1972: error: expected declaration specifiers before ‘DL_EXPORT’ src/rpymodule2130.c:113: error: declaration for parameter ‘R_References’ but no such parameter src/rpymodule2130.c:100: error: declaration for parameter ‘R_interact’ but no such parameter src/rpymodule2130.c:94: error: declaration for parameter ‘defaultargc’ but no such parameter src/rpymodule2130.c:93: error: declaration for parameter ‘defaultargv’ but no such parameter src/rpymodule2130.c:92: error: declaration for parameter ‘RUSER’ but no such parameter src/rpymodule2130.c:91: error: declaration for parameter ‘RVER’ but no such parameter src/rpymodule2130.c:90: error: declaration for parameter ‘RVERSION’ but no such parameter src/rpymodule2130.c:89: error: declaration for parameter ‘RHOME’ but no such parameter src/rpymodule2130.c:83: error: declaration for parameter ‘default_mode’ but no such parameter src/rpymodule2130.c:80: error: declaration for parameter ‘aperm’ but no such parameter src/rpymodule2130.c:79: error: declaration for parameter ‘length’ but no such parameter src/rpymodule2130.c:78: error: declaration for parameter ‘set_item’ but no such parameter src/rpymodule2130.c:77: error: declaration for parameter ‘get_item’ but no such parameter src/rpymodule2130.c:63: error: declaration for parameter ‘use_numeric’ but no such parameter src/RPy.h:208: error: declaration for parameter ‘to_Pyobj_vector’ but no such parameter src/RPy.h:207: error: declaration for parameter ‘to_Pyobj_basic’ but no such parameter src/RPy.h:206: error: declaration for parameter ‘to_Pyobj_class’ but no such parameter src/RPy.h:205: error: declaration for parameter ‘to_Pyobj_proc’ but no such parameter src/RPy.h:201: error: declaration for parameter ‘start_events’ but no such parameter src/RPy.h:200: error: declaration for parameter ‘stop_events’ but no such parameter src/RPy.h:192: error: declaration for parameter ‘R_interact’ but no such parameter src/RPy.h:186: error: declaration for parameter ‘jump_now’ but no such parameter src/RPy.h:180: error: declaration for parameter ‘interrupt_R’ but no such parameter src/RPy.h:155: error: declaration for parameter ‘ptr_R_ShowFiles’ but no such parameter src/RPy.h:154: error: declaration for parameter ‘ptr_R_ReadConsole’ but no such parameter src/RPy.h:153: error: declaration for parameter ‘ptr_R_WriteConsole’ but no such parameter src/RPy.h:145: error: declaration for parameter ‘R_Outputfile’ but no such parameter src/RPy.h:139: error: declaration for parameter ‘init_io_routines’ but no such parameter src/RPy.h:138: error: declaration for parameter ‘Rf_initEmbeddedR’ but no such parameter src/RPy.h:135: error: declaration for parameter ‘get_last_error_msg’ but no such parameter src/RPy.h:128: error: declaration for parameter ‘get_fun_from_name’ but no such parameter src/RPy.h:127: error: declaration for parameter ‘do_eval_fun’ but no such parameter src/RPy.h:126: error: declaration for parameter ‘do_eval_expr’ but no such parameter src/setenv.h:46: error: declaration for parameter ‘setenv’ but no such parameter src/robjobject.h:62: error: declaration for parameter ‘Robj_new’ but no such parameter src/rpymodule2130.c:2104: error: expected ‘{’ at end of input error: command 'gcc' failed with exit status 1

 

Check each tool dependency that you want to uninstall and click Uninstall.
Select/unselect all tool dependencies
R version 2.11.0
rpy version 1.0.3
 
 
From: Greg Von Kuster [mailto:[hidden email]bx.psu.edu
Sent: Tuesday, April 08, 2014 1:27 PM
To: Hayes, Curt
Cc: '[hidden email]'
Subject: Re: [galaxy-dev] Package/Module RPY
 
Hello Curt,
 
I believe that version 1.0.3 of the rpy package should be installing successfully from the main tool shed if you have a repository that contains a tool that defines a dependency to the rpy repository owned by devteam at http://toolshed.g2.bx.psu.edu/view/devteam/package_rpy_1_0_3
 
Here is the last test run for the tool shed's install and test framework for that repository.  I believe tis should install correctly using the dist repository, but if you're seeing problems, let us know.  Also, the next release is coming soon ( tentatively a week or so from now )..
 
Test runs
2014-04-07 17:25:49
Automated test environment
Successful installations
Repository dependencies - installation of these additional repositories is required
Tool shed
Name
Owner
Changeset revision
toolshed.g2.bx.psu.edu
package_r_2_11_0
devteam
5824d2b3bc8b
Tool dependencies
Type
Name
Version
R
package
2.11.0
Installation directory
/ToolDepsMain/R/2.11.0/devteam/package_rpy_1_0_3/82170c94ca7c
Type
Name
Version
rpy
package
1.0.3
Installation directory
/ToolDepsMain/rpy/1.0.3/devteam/package_rpy_1_0_3/82170c94ca7c
 
 
 
On Apr 8, 2014, at 3:28 PM, "Hayes, Curt" <[hidden email]> wrote:

 

Hi there all,
Does anyone have RPY working? I install via toolshed and the folder is empty, and shows missing dependencies.

I have searched previous posts, nothing since 2010. I have a local install (production config – postgres, etc – on CENTOS 6.5). I posted last week and it fell off the list. 

From Galaxy User interface:
Dataset generation errors
Dataset 81: Build base quality distribution on data 9
 
Tool execution generated the following error message:
Traceback (most recent call last):
  File "/apps/galaxy/galaxy-dist/tools/metag_tools/short_reads_figure_score.py", line 12, in <module>
    from rpy import *
ImportError: No module named rpy
 
I have attempted to download/install the scripts but they fail with multiple errors (most posts out there have a bad URL) - http://getgalaxyp.org/install.html says use: curlhttp://rpy.svn.sourceforge.net/viewvc/rpy/trunk/rpy/?view=tar > rpy.tar.gz
if you view that it redirects you to another URL.  
 
Via shell: R is installed: R version 2.13.0 (2011-04-13)
 
Can someone provide me some help please to get it working via Galaxy? I understand it works in Central.
 
From Toolshed:
Name
Version
Type
Installation status
1.0.3
package
Error
 
Toolshed Error:
In file included from src/rpymodule2110.c:51: src/RPy.h:56:20: error: Python.h: No such file or directory In file included from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/ndarrayobject.h:68, from /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/arrayobject.h:14, from src/RPy.h:89, from src/rpymodule2110.c:51: /usr/lib64/python2.6/site-packages/numpy/core/include/numpy/npy_common.h:79:2: error: #error Must use Python with unicode enabled. <truncated>

Thanks,
Curt
 
CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message. 
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/
 
CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.
 

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
 
CONFIDENTIALITY NOTICE: This e-mail message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information protected by law. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/