Problem Running TopHat2

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem Running TopHat2

changk16
Hello All,


I am running a Galaxy instance on Linux and have installed tools from the Galaxy Main Tool Shed. However, whenever I run TopHat2, the program is unable to complete the job before I get the following error message:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found


So far, I have made sure that the samtools do appear to be installed since they can be found listed under "Managed Installed Tool Shed Repositories". Is it possible that they were installed incorrectly?
Any help is much appreciated.


Thanks for taking the time to read this,
Kevin Chang



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Problem Running TopHat2

nephantes
Hey Kevin, 
You need to install samtools and bowtie(2) into your system. I assume, the package you installed to galaxy is just a wrapper to call samtools. It doesn’t come with samtools binary.
Best,
Alper Kucukural, PhD
Bioinformatics Core,
University of Massachusetts Medical School
368 Plantation St.Room AS4.2067
Worcester, MA 01605-2324
Phone: 774-312-4493
E-mail: [hidden email]



On Aug 26, 2014, at 11:36 AM, Kevin <[hidden email]> wrote:

Hello All,


I am running a Galaxy instance on Linux and have installed tools from the Galaxy Main Tool Shed. However, whenever I run TopHat2, the program is unable to complete the job before I get the following error message:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found

So far, I have made sure that the samtools do appear to be installed since they can be found listed under "Managed Installed Tool Shed Repositories". Is it possible that they were installed incorrectly?
Any help is much appreciated.


Thanks for taking the time to read this,
Kevin Chang


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Problem Running TopHat2

changk16
Hi Alper,

Thank you for the advice. After you suggested that I install the samtools and not just the samtools binary, I went to the Galaxy Main Tool Shed and installed the “package_samtools_0_1_18”. After running TopHat2 again for around 36 hours, the same error message came up again. It appears that installing the samtools themselves did not fix the problem.

Are there any other ways to try and fix this problem?

Thanks for taking the time to help me out,
Kevin Chang


Sent from Windows Mail

From: [hidden email]
Sent: ‎Tuesday‎, ‎August‎ ‎26‎, ‎2014 ‎1‎:‎21‎ ‎PM
To: [hidden email]
Cc: [hidden email]

Hey Kevin, 
You need to install samtools and bowtie(2) into your system. I assume, the package you installed to galaxy is just a wrapper to call samtools. It doesn’t come with samtools binary.
Best,
Alper Kucukural, PhD
Bioinformatics Core,
University of Massachusetts Medical School
368 Plantation St.Room AS4.2067
Worcester, MA 01605-2324
Phone: 774-312-4493
E-mail: [hidden email]



On Aug 26, 2014, at 11:36 AM, Kevin <[hidden email]> wrote:

Hello All,


I am running a Galaxy instance on Linux and have installed tools from the Galaxy Main Tool Shed. However, whenever I run TopHat2, the program is unable to complete the job before I get the following error message:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found

So far, I have made sure that the samtools do appear to be installed since they can be found listed under "Managed Installed Tool Shed Repositories". Is it possible that they were installed incorrectly?
Any help is much appreciated.


Thanks for taking the time to read this,
Kevin Chang


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Problem Running TopHat2

nephantes
What was the error?

From: Kevin <[hidden email]>
Date: Thursday, August 28, 2014 at 11:17 PM
To: Alper Kucukural <[hidden email]>
Cc: "[hidden email]" <[hidden email]>
Subject: Re: [galaxy-dev] Problem Running TopHat2

Hi Alper,

Thank you for the advice. After you suggested that I install the samtools and not just the samtools binary, I went to the Galaxy Main Tool Shed and installed the “package_samtools_0_1_18”. After running TopHat2 again for around 36 hours, the same error message came up again. It appears that installing the samtools themselves did not fix the problem.

Are there any other ways to try and fix this problem?

Thanks for taking the time to help me out,
Kevin Chang


Sent from Windows Mail

From: [hidden email]
Sent: Tuesday, August 26, 2014 1:21 PM
To: [hidden email]
Cc: [hidden email]

Hey Kevin, 
You need to install samtools and bowtie(2) into your system. I assume, the package you installed to galaxy is just a wrapper to call samtools. It doesn’t come with samtools binary.
Best,
Alper Kucukural, PhD
Bioinformatics Core,
University of Massachusetts Medical School
368 Plantation St.Room AS4.2067
Worcester, MA 01605-2324
Phone: 774-312-4493
E-mail: [hidden email]



On Aug 26, 2014, at 11:36 AM, Kevin <[hidden email]> wrote:

Hello All,


I am running a Galaxy instance on Linux and have installed tools from the Galaxy Main Tool Shed. However, whenever I run TopHat2, the program is unable to complete the job before I get the following error message:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found

So far, I have made sure that the samtools do appear to be installed since they can be found listed under "Managed Installed Tool Shed Repositories". Is it possible that they were installed incorrectly?
Any help is much appreciated.


Thanks for taking the time to read this,
Kevin Chang


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Problem Running TopHat2

changk16
The error message was the same thing as before:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found

Thanks,
Kevin Chang

From: [hidden email]
Sent: ‎Friday‎, ‎August‎ ‎29‎, ‎2014 ‎10‎:‎16‎ ‎AM
To: [hidden email]
Cc: [hidden email]

What was the error?

From: Kevin <[hidden email]>
Date: Thursday, August 28, 2014 at 11:17 PM
To: Alper Kucukural <[hidden email]>
Cc: "[hidden email]" <[hidden email]>
Subject: Re: [galaxy-dev] Problem Running TopHat2

Hi Alper,

Thank you for the advice. After you suggested that I install the samtools and not just the samtools binary, I went to the Galaxy Main Tool Shed and installed the “package_samtools_0_1_18”. After running TopHat2 again for around 36 hours, the same error message came up again. It appears that installing the samtools themselves did not fix the problem.

Are there any other ways to try and fix this problem?

Thanks for taking the time to help me out,
Kevin Chang


Sent from Windows Mail

From: [hidden email]
Sent: Tuesday, August 26, 2014 1:21 PM
To: [hidden email]
Cc: [hidden email]

Hey Kevin, 
You need to install samtools and bowtie(2) into your system. I assume, the package you installed to galaxy is just a wrapper to call samtools. It doesn’t come with samtools binary.
Best,
Alper Kucukural, PhD
Bioinformatics Core,
University of Massachusetts Medical School
368 Plantation St.Room AS4.2067
Worcester, MA 01605-2324
Phone: 774-312-4493
E-mail: [hidden email]



On Aug 26, 2014, at 11:36 AM, Kevin <[hidden email]> wrote:

Hello All,


I am running a Galaxy instance on Linux and have installed tools from the Galaxy Main Tool Shed. However, whenever I run TopHat2, the program is unable to complete the job before I get the following error message:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found

So far, I have made sure that the samtools do appear to be installed since they can be found listed under "Managed Installed Tool Shed Repositories". Is it possible that they were installed incorrectly?
Any help is much appreciated.


Thanks for taking the time to read this,
Kevin Chang


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/






___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Problem Running TopHat2

nephantes
Kevin,
You should install samtools to your operating system and put the executable file to your /usr/local/bin or somewhere in a path that galaxy user can call. 
Best,
Alper

From: Kevin <[hidden email]>
Date: Friday, August 29, 2014 at 10:44 AM
To: Alper Kucukural <[hidden email]>
Cc: "[hidden email]" <[hidden email]>
Subject: Re: [galaxy-dev] Problem Running TopHat2

The error message was the same thing as before:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found

Thanks,
Kevin Chang

From: [hidden email]
Sent: Friday, August 29, 2014 10:16 AM
To: [hidden email]
Cc: [hidden email]

What was the error?

From: Kevin <[hidden email]>
Date: Thursday, August 28, 2014 at 11:17 PM
To: Alper Kucukural <[hidden email]>
Cc: "[hidden email]" <[hidden email]>
Subject: Re: [galaxy-dev] Problem Running TopHat2

Hi Alper,

Thank you for the advice. After you suggested that I install the samtools and not just the samtools binary, I went to the Galaxy Main Tool Shed and installed the “package_samtools_0_1_18”. After running TopHat2 again for around 36 hours, the same error message came up again. It appears that installing the samtools themselves did not fix the problem.

Are there any other ways to try and fix this problem?

Thanks for taking the time to help me out,
Kevin Chang


Sent from Windows Mail

From: [hidden email]
Sent: Tuesday, August 26, 2014 1:21 PM
To: [hidden email]
Cc: [hidden email]

Hey Kevin, 
You need to install samtools and bowtie(2) into your system. I assume, the package you installed to galaxy is just a wrapper to call samtools. It doesn’t come with samtools binary.
Best,
Alper Kucukural, PhD
Bioinformatics Core,
University of Massachusetts Medical School
368 Plantation St.Room AS4.2067
Worcester, MA 01605-2324
Phone: 774-312-4493
E-mail: [hidden email]



On Aug 26, 2014, at 11:36 AM, Kevin <[hidden email]> wrote:

Hello All,


I am running a Galaxy instance on Linux and have installed tools from the Galaxy Main Tool Shed. However, whenever I run TopHat2, the program is unable to complete the job before I get the following error message:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found

So far, I have made sure that the samtools do appear to be installed since they can be found listed under "Managed Installed Tool Shed Repositories". Is it possible that they were installed incorrectly?
Any help is much appreciated.


Thanks for taking the time to read this,
Kevin Chang


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/






___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Problem Running TopHat2

changk16
Hi Alper,

I think that the problem is somewhat fixed now. After I moved the samtools executable into the TopHat2 /bin, I also went into the “universe_wsgi.ini” and uncommented+changed the line “retry_metadata_internally=true” to “retry_metadata_internally=false”.

Then, when I ran the TopHat2 alignment again, the job was able to be completed. However, now the only problem is a small notification under the accepted hits file saying that “An error occurred setting the metadata for this dataset. You may be able to set it manually or retry auto-detection”

Is the metadata something I should be concerned about? Or is it okay to proceed without the metadata being completely done? I intend to use this accepted hits file for Cufflinks and Cuffdiff later on.

Thanks for all your help,
Kevin Chang



Sent: ‎Friday‎, ‎August‎ ‎29‎, ‎2014 ‎10‎:‎52‎ ‎AM
To: [hidden email]
Cc: [hidden email]

Kevin,
You should install samtools to your operating system and put the executable file to your /usr/local/bin or somewhere in a path that galaxy user can call. 
Best,
Alper

From: Kevin <[hidden email]>
Date: Friday, August 29, 2014 at 10:44 AM
To: Alper Kucukural <[hidden email]>
Cc: "[hidden email]" <[hidden email]>
Subject: Re: [galaxy-dev] Problem Running TopHat2

The error message was the same thing as before:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found

Thanks,
Kevin Chang

From: [hidden email]
Sent: Friday, August 29, 2014 10:16 AM
To: [hidden email]
Cc: [hidden email]

What was the error?

From: Kevin <[hidden email]>
Date: Thursday, August 28, 2014 at 11:17 PM
To: Alper Kucukural <[hidden email]>
Cc: "[hidden email]" <[hidden email]>
Subject: Re: [galaxy-dev] Problem Running TopHat2

Hi Alper,

Thank you for the advice. After you suggested that I install the samtools and not just the samtools binary, I went to the Galaxy Main Tool Shed and installed the “package_samtools_0_1_18”. After running TopHat2 again for around 36 hours, the same error message came up again. It appears that installing the samtools themselves did not fix the problem.

Are there any other ways to try and fix this problem?

Thanks for taking the time to help me out,
Kevin Chang


Sent from Windows Mail

From: [hidden email]
Sent: Tuesday, August 26, 2014 1:21 PM
To: [hidden email]
Cc: [hidden email]

Hey Kevin, 
You need to install samtools and bowtie(2) into your system. I assume, the package you installed to galaxy is just a wrapper to call samtools. It doesn’t come with samtools binary.
Best,
Alper Kucukural, PhD
Bioinformatics Core,
University of Massachusetts Medical School
368 Plantation St.Room AS4.2067
Worcester, MA 01605-2324
Phone: 774-312-4493
E-mail: [hidden email]



On Aug 26, 2014, at 11:36 AM, Kevin <[hidden email]> wrote:

Hello All,


I am running a Galaxy instance on Linux and have installed tools from the Galaxy Main Tool Shed. However, whenever I run TopHat2, the program is unable to complete the job before I get the following error message:

Traceback (most recent call last):
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, in queue_job
   job_wrapper.finish( stdout, stderr, exit_code )
 File "/home/ubuntu/galaxy-dist/lib/galaxy/jobs/__init__.py", line 998, in finish
   dataset.datatype.set_meta( dataset, overwrite=False )  # call datatype.set_meta directly for the initial set_meta call during dataset creation
 File "/home/ubuntu/galaxy-dist/lib/galaxy/datatypes/binary.py", line 251, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found

So far, I have made sure that the samtools do appear to be installed since they can be found listed under "Managed Installed Tool Shed Repositories". Is it possible that they were installed incorrectly?
Any help is much appreciated.


Thanks for taking the time to read this,
Kevin Chang


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/








___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/