Quantcast

Problem with 'galaxy_packages' dependency resolver in versionless mode

classic Classic list List threaded Threaded
4 messages Options
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem with 'galaxy_packages' dependency resolver in versionless mode

Peter Briggs
Dear developers

I'm having problems trying to use the 'galaxy_packages' dependency resolver in versionless mode, as described in the docs at:

https://docs.galaxyproject.org/en/latest/admin/dependency_resolvers.html#galaxy-packages-dependency-resolver

As I understand this: if I manually create a directory structure of the form e.g. /path/to/local_tool_dependencies/my_package/default/ which contains an env.sh file, and if my dependency_resolvers_conf.xml file includes the line:

<galaxy_packages base_path="/path/to/local_tool_dependencies" versionless="true" />

then at run time Galaxy should be able to resolve the following requirement in a tool XML file:

<requirement type="package">my_package</requirement>

Unfortunately although the "versioned" galaxy_packages resolver works as expected (when placed ahead of the "versionless" resolver), I don't seem able to get this working with Galaxy v16.10.

Can anyone point out what I'm doing wrong?

Thanks!

Best wishes

Peter

--
Peter Briggs [hidden email]
Bioinformatics Core Facility University of Manchester
B.1083 Michael Smith Bldg Tel: (0161) 2751482

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with 'galaxy_packages' dependency resolver in versionless mode

Björn Grüning-3
Hi Peter,

can you try to make  /path/to/local_tool_dependencies/my_package/default
a symlink?

Ciao,
Bjoern

Am 20.01.2017 um 16:41 schrieb Peter Briggs:

> Dear developers
>
> I'm having problems trying to use the 'galaxy_packages' dependency resolver in versionless mode, as described in the docs at:
>
> https://docs.galaxyproject.org/en/latest/admin/dependency_resolvers.html#galaxy-packages-dependency-resolver
>
> As I understand this: if I manually create a directory structure of the form e.g. /path/to/local_tool_dependencies/my_package/default/ which contains an env.sh file, and if my dependency_resolvers_conf.xml file includes the line:
>
> <galaxy_packages base_path="/path/to/local_tool_dependencies" versionless="true" />
>
> then at run time Galaxy should be able to resolve the following requirement in a tool XML file:
>
> <requirement type="package">my_package</requirement>
>
> Unfortunately although the "versioned" galaxy_packages resolver works as expected (when placed ahead of the "versionless" resolver), I don't seem able to get this working with Galaxy v16.10.
>
> Can anyone point out what I'm doing wrong?
>
> Thanks!
>
> Best wishes
>
> Peter
>
> --
> Peter Briggs [hidden email]
> Bioinformatics Core Facility University of Manchester
> B.1083 Michael Smith Bldg Tel: (0161) 2751482
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with 'galaxy_packages' dependency resolver in versionless mode

Peter Briggs
Hello Bjoern

Yes it looks like making the 'default' directory into a symlink makes
this work.

Thanks for your help and sorry not to get back to you sooner!

Best wishes

Peter

On 20/01/17 16:56, Björn Grüning wrote:

> Hi Peter,
>
> can you try to make  /path/to/local_tool_dependencies/my_package/default
> a symlink?
>
> Ciao,
> Bjoern
>
> Am 20.01.2017 um 16:41 schrieb Peter Briggs:
>> Dear developers
>>
>> I'm having problems trying to use the 'galaxy_packages' dependency resolver in versionless mode, as described in the docs at:
>>
>> https://docs.galaxyproject.org/en/latest/admin/dependency_resolvers.html#galaxy-packages-dependency-resolver
>>
>> As I understand this: if I manually create a directory structure of the form e.g. /path/to/local_tool_dependencies/my_package/default/ which contains an env.sh file, and if my dependency_resolvers_conf.xml file includes the line:
>>
>> <galaxy_packages base_path="/path/to/local_tool_dependencies" versionless="true" />
>>
>> then at run time Galaxy should be able to resolve the following requirement in a tool XML file:
>>
>> <requirement type="package">my_package</requirement>
>>
>> Unfortunately although the "versioned" galaxy_packages resolver works as expected (when placed ahead of the "versionless" resolver), I don't seem able to get this working with Galaxy v16.10.
>>
>> Can anyone point out what I'm doing wrong?
>>
>> Thanks!
>>
>> Best wishes
>>
>> Peter
>>
>> --
>> Peter Briggs [hidden email]
>> Bioinformatics Core Facility University of Manchester
>> B.1083 Michael Smith Bldg Tel: (0161) 2751482
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>   https://lists.galaxyproject.org/
>>
>> To search Galaxy mailing lists use the unified search at:
>>   http://galaxyproject.org/search/mailinglists/
>>

--
Peter Briggs [hidden email]
Bioinformatics Core Facility University of Manchester
B.1083 Michael Smith Bldg Tel: (0161) 2751482
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with 'galaxy_packages' dependency resolver in versionless mode

John Chilton-4
I recently reworked the dependency resolver documentation and made
this explicit. I don't think the previous revision of that document
mentioned this important caveat at all. Thanks for Galaxy-ing!

Thanks,
-John

On Tue, Jan 24, 2017 at 7:01 AM, Peter Briggs
<[hidden email]> wrote:

> Hello Bjoern
>
> Yes it looks like making the 'default' directory into a symlink makes this
> work.
>
> Thanks for your help and sorry not to get back to you sooner!
>
> Best wishes
>
> Peter
>
>
> On 20/01/17 16:56, Björn Grüning wrote:
>>
>> Hi Peter,
>>
>> can you try to make  /path/to/local_tool_dependencies/my_package/default
>> a symlink?
>>
>> Ciao,
>> Bjoern
>>
>> Am 20.01.2017 um 16:41 schrieb Peter Briggs:
>>>
>>> Dear developers
>>>
>>> I'm having problems trying to use the 'galaxy_packages' dependency
>>> resolver in versionless mode, as described in the docs at:
>>>
>>>
>>> https://docs.galaxyproject.org/en/latest/admin/dependency_resolvers.html#galaxy-packages-dependency-resolver
>>>
>>> As I understand this: if I manually create a directory structure of the
>>> form e.g. /path/to/local_tool_dependencies/my_package/default/ which
>>> contains an env.sh file, and if my dependency_resolvers_conf.xml file
>>> includes the line:
>>>
>>> <galaxy_packages base_path="/path/to/local_tool_dependencies"
>>> versionless="true" />
>>>
>>> then at run time Galaxy should be able to resolve the following
>>> requirement in a tool XML file:
>>>
>>> <requirement type="package">my_package</requirement>
>>>
>>> Unfortunately although the "versioned" galaxy_packages resolver works as
>>> expected (when placed ahead of the "versionless" resolver), I don't seem
>>> able to get this working with Galaxy v16.10.
>>>
>>> Can anyone point out what I'm doing wrong?
>>>
>>> Thanks!
>>>
>>> Best wishes
>>>
>>> Peter
>>>
>>> --
>>> Peter Briggs [hidden email]
>>> Bioinformatics Core Facility University of Manchester
>>> B.1083 Michael Smith Bldg Tel: (0161) 2751482
>>>
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>>   https://lists.galaxyproject.org/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>>   http://galaxyproject.org/search/mailinglists/
>>>
>
> --
> Peter Briggs [hidden email]
> Bioinformatics Core Facility University of Manchester
> B.1083 Michael Smith Bldg Tel: (0161) 2751482
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>  https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>  http://galaxyproject.org/search/mailinglists/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Loading...