Protocol for changing the section of an installed tool shed repo

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Protocol for changing the section of an installed tool shed repo

Joachim Jacob
Hi all,


Stupidly enough, I installed a tool shed repo under 'root' of the
toolbox. Yes, it was EMBOSS5.0 (btw, installation went flawless!).

1. From the admin menu, I choose to unactivate the repo (manage tool
shed repo's)
2. From the admin menu, I reinstalled the tool shed from Main Tool Shed,
and chose to put it under a section 'EMBOSS'. This to no avail: all
tools still under root.
3. I manually edited the shed_tool_conf.xml and added the section tags
4. The section is now displayed, containing the EMBOSS tools. BUT the
tools under the root of the toolbox are still there.

Any assistance here?


Cheers,
Joachim

--
Joachim Jacob

Rijvisschestraat 120, 9052 Zwijnaarde
Tel: +32 9 244.66.34
Bioinformatics Training and Services (BITS)
http://www.bits.vib.be
@bitsatvib

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Protocol for changing the section of an installed tool shed repo

Dave Bouvier
Joachim,

As you discovered, deactivating a repository does not give you the
option to select a new tool panel section. However, if you select the
option to remove the repository from disk, and then reinstall it, you
will be presented with the tool panel section page, where you can
uncheck the 'no changes' box and either select or create a tool panel
section for the tools contained in the repository.

    --Dave B.

On 5/8/13 09:44:57.000, Joachim Jacob | VIB | wrote:

> Hi all,
>
>
> Stupidly enough, I installed a tool shed repo under 'root' of the
> toolbox. Yes, it was EMBOSS5.0 (btw, installation went flawless!).
>
> 1. From the admin menu, I choose to unactivate the repo (manage tool
> shed repo's)
> 2. From the admin menu, I reinstalled the tool shed from Main Tool Shed,
> and chose to put it under a section 'EMBOSS'. This to no avail: all
> tools still under root.
> 3. I manually edited the shed_tool_conf.xml and added the section tags
> 4. The section is now displayed, containing the EMBOSS tools. BUT the
> tools under the root of the toolbox are still there.
>
> Any assistance here?
>
>
> Cheers,
> Joachim
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Protocol for changing the section of an installed tool shed repo

Björn Grüning
In reply to this post by Joachim Jacob
Hi Joachim,

can you try to delete/rename integrated_tool_panel.xml, it is generated
during start-up.

Hope that helps,
Björn

> Hi all,
>
>
> Stupidly enough, I installed a tool shed repo under 'root' of the
> toolbox. Yes, it was EMBOSS5.0 (btw, installation went flawless!).
>
> 1. From the admin menu, I choose to unactivate the repo (manage tool
> shed repo's)
> 2. From the admin menu, I reinstalled the tool shed from Main Tool Shed,
> and chose to put it under a section 'EMBOSS'. This to no avail: all
> tools still under root.
> 3. I manually edited the shed_tool_conf.xml and added the section tags
> 4. The section is now displayed, containing the EMBOSS tools. BUT the
> tools under the root of the toolbox are still there.
>
> Any assistance here?
>
>
> Cheers,
> Joachim
>



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Protocol for changing the section of an installed tool shed repo

Joachim Jacob
Deleting the integrated tool panel config and retarting solved the
issue. Thanks!

Joachim

Joachim Jacob

Rijvisschestraat 120, 9052 Zwijnaarde
Tel: +32 9 244.66.34
Bioinformatics Training and Services (BITS)
http://www.bits.vib.be
@bitsatvib

On 05/08/2013 04:02 PM, Björn Grüning wrote:

> Hi Joachim,
>
> can you try to delete/rename integrated_tool_panel.xml, it is generated
> during start-up.
>
> Hope that helps,
> Björn
>
>> Hi all,
>>
>>
>> Stupidly enough, I installed a tool shed repo under 'root' of the
>> toolbox. Yes, it was EMBOSS5.0 (btw, installation went flawless!).
>>
>> 1. From the admin menu, I choose to unactivate the repo (manage tool
>> shed repo's)
>> 2. From the admin menu, I reinstalled the tool shed from Main Tool Shed,
>> and chose to put it under a section 'EMBOSS'. This to no avail: all
>> tools still under root.
>> 3. I manually edited the shed_tool_conf.xml and added the section tags
>> 4. The section is now displayed, containing the EMBOSS tools. BUT the
>> tools under the root of the toolbox are still there.
>>
>> Any assistance here?
>>
>>
>> Cheers,
>> Joachim
>>
>
>
>
>

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/