Speedup Galaxy

classic Classic list List threaded Threaded
6 messages Options
| Threaded
Open this post in threaded view
|

Speedup Galaxy

Jochen
We are running a Galaxy instance at our institute (version 15.10). Since
some month the speed/reaction time of the interface drastically
decrease. Sometimes there is a lack of more than a minute loading a
single tool. I restarted galaxy without any improvements. We are working
with up to 3 people on this instance that should not be the problem.
Does anyone have any idea?
Disk-space?
uptime of our server?
big full database?
??

Cheers Jochen
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Speedup Galaxy

Curtis Hendrickeduson
Jochen

We once had a similar, sudden performance problem, and found that the setting

        Galaxy.ini: debug = False

Had accidentally been re-set to "True". Having "debug" turned on really, really slows down the galaxy app process....

So, check that debug = False.

Regards
Curtis



-----Original Message-----
From: galaxy-dev [mailto:[hidden email]] On Behalf Of Jochen Bick
Sent: Friday, December 9, 2016 6:05 AM
To: [hidden email]
Subject: [galaxy-dev] Speedup Galaxy

We are running a Galaxy instance at our institute (version 15.10). Since some month the speed/reaction time of the interface drastically decrease. Sometimes there is a lack of more than a minute loading a single tool. I restarted galaxy without any improvements. We are working with up to 3 people on this instance that should not be the problem.
Does anyone have any idea?
Disk-space?
uptime of our server?
big full database?
??

Cheers Jochen
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Speedup Galaxy

Jochen
Thanks for your reply but in my case it did not solve the problem...
has anyone else good ideas to speed up galaxy?

Cheers Jochen

On 09.12.2016 17:07, Hendrickson, Curtis (Campus) wrote:

> Jochen
>
> We once had a similar, sudden performance problem, and found that the setting
>
> Galaxy.ini: debug = False
>
> Had accidentally been re-set to "True". Having "debug" turned on really, really slows down the galaxy app process....
>
> So, check that debug = False.
>
> Regards
> Curtis
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Speedup Galaxy

Nate Coraor (nate@bx.psu.edu)
Hi Jochen,

You might want to enable the heartbeat (see the relevant options in galaxy.ini), so you can see what the threads are actually doing during that period. This should give you some insight on the culprit.

--nate

On Mon, Dec 12, 2016 at 9:40 AM, Jochen Bick <[hidden email]> wrote:
Thanks for your reply but in my case it did not solve the problem...
has anyone else good ideas to speed up galaxy?

Cheers Jochen

On 09.12.2016 17:07, Hendrickson, Curtis (Campus) wrote:
> Jochen
>
> We once had a similar, sudden performance problem, and found that the setting
>
>       Galaxy.ini: debug = False
>
> Had accidentally been re-set to "True". Having "debug" turned on really, really slows down the galaxy app process....
>
> So, check that debug = False.
>
> Regards
> Curtis
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Speedup Galaxy

Jochen
Thanks Nate,

So since today the speed is much better ... I changed to debug = False
and activated the heartbeat. But I have no idea what the actual problem
was...

I hope I can deactivate it soon, because it said that it will eat up
disk space rapidly...

Cheers Jochen


On 12.12.2016 18:37, Nate Coraor wrote:

> Hi Jochen,
>
> You might want to enable the heartbeat (see the relevant options in
> galaxy.ini), so you can see what the threads are actually doing during that
> period. This should give you some insight on the culprit.
>
> --nate
>
> On Mon, Dec 12, 2016 at 9:40 AM, Jochen Bick <[hidden email]>
> wrote:
>
>> Thanks for your reply but in my case it did not solve the problem...
>> has anyone else good ideas to speed up galaxy?
>>
>> Cheers Jochen
>>
>> On 09.12.2016 17:07, Hendrickson, Curtis (Campus) wrote:
>>> Jochen
>>>
>>> We once had a similar, sudden performance problem, and found that the
>> setting
>>>
>>>       Galaxy.ini: debug = False
>>>
>>> Had accidentally been re-set to "True". Having "debug" turned on really,
>> really slows down the galaxy app process....
>>>
>>> So, check that debug = False.
>>>
>>> Regards
>>> Curtis
>>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>   https://lists.galaxyproject.org/
>>
>> To search Galaxy mailing lists use the unified search at:
>>   http://galaxyproject.org/search/mailinglists/
>>
>

--
ETH Zurich
*Jochen Bick*
Animal Physiology
Institute of Agricultural Sciences
Postal address: Universitätstrasse 2 / LFW B 58.1
Office: Tannenstrasse 1 / TAN D 6.2
8092 Zurich, Switzerland

Phone +41 44 632 28 25
[hidden email] <mailto:[hidden email]>
www.ap.ethz.ch
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Speedup Galaxy

Nate Coraor (nate@bx.psu.edu)
It actually won't eat up that much, but keep an eye on it. If it's growing too quickly you can decrease the frequency.

On Wed, Dec 14, 2016 at 9:48 AM, Jochen Bick <[hidden email]> wrote:
Thanks Nate,

So since today the speed is much better ... I changed to debug = False
and activated the heartbeat. But I have no idea what the actual problem
was...

I hope I can deactivate it soon, because it said that it will eat up
disk space rapidly...

Cheers Jochen


On 12.12.2016 18:37, Nate Coraor wrote:
> Hi Jochen,
>
> You might want to enable the heartbeat (see the relevant options in
> galaxy.ini), so you can see what the threads are actually doing during that
> period. This should give you some insight on the culprit.
>
> --nate
>
> On Mon, Dec 12, 2016 at 9:40 AM, Jochen Bick <[hidden email]>
> wrote:
>
>> Thanks for your reply but in my case it did not solve the problem...
>> has anyone else good ideas to speed up galaxy?
>>
>> Cheers Jochen
>>
>> On 09.12.2016 17:07, Hendrickson, Curtis (Campus) wrote:
>>> Jochen
>>>
>>> We once had a similar, sudden performance problem, and found that the
>> setting
>>>
>>>       Galaxy.ini: debug = False
>>>
>>> Had accidentally been re-set to "True". Having "debug" turned on really,
>> really slows down the galaxy app process....
>>>
>>> So, check that debug = False.
>>>
>>> Regards
>>> Curtis
>>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>   https://lists.galaxyproject.org/
>>
>> To search Galaxy mailing lists use the unified search at:
>>   http://galaxyproject.org/search/mailinglists/
>>
>

--
ETH Zurich
*Jochen Bick*
Animal Physiology
Institute of Agricultural Sciences
Postal address: Universitätstrasse 2 / LFW B 58.1
Office: Tannenstrasse 1 / TAN D 6.2
8092 Zurich, Switzerland

Phone <a href="tel:%2B41%2044%20632%2028%2025" value="+41446322825">+41 44 632 28 25
[hidden email] <mailto:[hidden email]>
www.ap.ethz.ch


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/