Workflow editor stuck on loading workflow

classic Classic list List threaded Threaded
7 messages Options
| Threaded
Open this post in threaded view
|

Workflow editor stuck on loading workflow

ryang
It looks like a recent commit since 6/26 to 15.05 is break the workflow editor.  I have a pipeline I'm trying to edit.  I updated my instance of Galaxy and now when I try to edit a workflow, the editor is stuck at "Loading workflow editor". 



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Workflow editor stuck on loading workflow

ryang
Hmmm this only happens on a specific workflow.  How can I debug this?

On Tue, Jul 14, 2015 at 3:37 PM, Ryan G <[hidden email]> wrote:
It looks like a recent commit since 6/26 to 15.05 is break the workflow editor.  I have a pipeline I'm trying to edit.  I updated my instance of Galaxy and now when I try to edit a workflow, the editor is stuck at "Loading workflow editor". 




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Workflow editor stuck on loading workflow

Björn Grüning-3
Hi Ryan,

try to look at the JS console. I suspect some problem with one of the
tools in your workflow.

Cheers,
Bjoern

Am 14.07.2015 um 22:02 schrieb Ryan G:

> Hmmm this only happens on a specific workflow.  How can I debug this?
>
> On Tue, Jul 14, 2015 at 3:37 PM, Ryan G <[hidden email]> wrote:
>
>> It looks like a recent commit since 6/26 to 15.05 is break the workflow
>> editor.  I have a pipeline I'm trying to edit.  I updated my instance of
>> Galaxy and now when I try to edit a workflow, the editor is stuck at
>> "Loading workflow editor".
>>
>>
>>
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Workflow editor stuck on loading workflow

ryang
The error I see is "TypeError: c.effectiveMapOver is not a function" in static/scripts/galaxy.workflow_editor.canvas.js?v=1436897004

On Tue, Jul 14, 2015 at 4:50 PM, Björn Grüning <[hidden email]> wrote:
Hi Ryan,

try to look at the JS console. I suspect some problem with one of the
tools in your workflow.

Cheers,
Bjoern

Am 14.07.2015 um 22:02 schrieb Ryan G:
> Hmmm this only happens on a specific workflow.  How can I debug this?
>
> On Tue, Jul 14, 2015 at 3:37 PM, Ryan G <[hidden email]> wrote:
>
>> It looks like a recent commit since 6/26 to 15.05 is break the workflow
>> editor.  I have a pipeline I'm trying to edit.  I updated my instance of
>> Galaxy and now when I try to edit a workflow, the editor is stuck at
>> "Loading workflow editor".
>>
>>
>>
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Workflow editor stuck on loading workflow

Daniel Blankenberg
Just a quick general suggestion: have you tried clearing your browser cache?


Thanks for using Galaxy,

Dan



On Jul 15, 2015, at 11:18 AM, Ryan G <[hidden email]> wrote:

The error I see is "TypeError: c.effectiveMapOver is not a function" in static/scripts/galaxy.workflow_editor.canvas.js?v=1436897004

On Tue, Jul 14, 2015 at 4:50 PM, Björn Grüning <[hidden email]> wrote:
Hi Ryan,

try to look at the JS console. I suspect some problem with one of the
tools in your workflow.

Cheers,
Bjoern

Am 14.07.2015 um 22:02 schrieb Ryan G:
> Hmmm this only happens on a specific workflow.  How can I debug this?
>
> On Tue, Jul 14, 2015 at 3:37 PM, Ryan G <[hidden email]> wrote:
>
>> It looks like a recent commit since 6/26 to 15.05 is break the workflow
>> editor.  I have a pipeline I'm trying to edit.  I updated my instance of
>> Galaxy and now when I try to edit a workflow, the editor is stuck at
>> "Loading workflow editor".
>>
>>
>>
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
>

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Workflow editor stuck on loading workflow

John Chilton-4
In reply to this post by ryang
Ryan - is this still a problem? I assume there is some use of dataset
collections in this workflow? What would be ideal is to determine a
minimum combination of data flow (connections) and tools that exhibit
this - and then share that workflow and tool with me. If you don't
have time for that - maybe just attempting to export the workflow and
sending it to me. I cannot make any promises but I can try to look it
over.

Thanks for the bug report - we are doing a lot of work on workflows
and the workflow editor and if I encounter this bug and find a fix I
will let you know,
-John

On Wed, Jul 15, 2015 at 4:18 PM, Ryan G <[hidden email]> wrote:

> The error I see is "TypeError: c.effectiveMapOver is not a function" in
> static/scripts/galaxy.workflow_editor.canvas.js?v=1436897004
>
> On Tue, Jul 14, 2015 at 4:50 PM, Björn Grüning <[hidden email]>
> wrote:
>>
>> Hi Ryan,
>>
>> try to look at the JS console. I suspect some problem with one of the
>> tools in your workflow.
>>
>> Cheers,
>> Bjoern
>>
>> Am 14.07.2015 um 22:02 schrieb Ryan G:
>> > Hmmm this only happens on a specific workflow.  How can I debug this?
>> >
>> > On Tue, Jul 14, 2015 at 3:37 PM, Ryan G <[hidden email]>
>> > wrote:
>> >
>> >> It looks like a recent commit since 6/26 to 15.05 is break the workflow
>> >> editor.  I have a pipeline I'm trying to edit.  I updated my instance
>> >> of
>> >> Galaxy and now when I try to edit a workflow, the editor is stuck at
>> >> "Loading workflow editor".
>> >>
>> >>
>> >>
>> >
>> >
>> >
>> > ___________________________________________________________
>> > Please keep all replies on the list by using "reply all"
>> > in your mail client.  To manage your subscriptions to this
>> > and other Galaxy lists, please use the interface at:
>> >   https://lists.galaxyproject.org/
>> >
>> > To search Galaxy mailing lists use the unified search at:
>> >   http://galaxyproject.org/search/mailinglists/
>> >
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: Workflow editor stuck on loading workflow

ryang
Hi  - Yes, this is still happening.  Clearing my browser's cache didn't help.  I suspect this is related to a tool being removed/renamed that is used in the workflow, but not completely sure.  Attached is the exported workflow.

Let me know if you need anything else to help debug this.  Thanks,

Ryan



On Mon, Jul 27, 2015 at 9:44 AM, John Chilton <[hidden email]> wrote:
Ryan - is this still a problem? I assume there is some use of dataset
collections in this workflow? What would be ideal is to determine a
minimum combination of data flow (connections) and tools that exhibit
this - and then share that workflow and tool with me. If you don't
have time for that - maybe just attempting to export the workflow and
sending it to me. I cannot make any promises but I can try to look it
over.

Thanks for the bug report - we are doing a lot of work on workflows
and the workflow editor and if I encounter this bug and find a fix I
will let you know,
-John

On Wed, Jul 15, 2015 at 4:18 PM, Ryan G <[hidden email]> wrote:
> The error I see is "TypeError: c.effectiveMapOver is not a function" in
> static/scripts/galaxy.workflow_editor.canvas.js?v=1436897004
>
> On Tue, Jul 14, 2015 at 4:50 PM, Björn Grüning <[hidden email]>
> wrote:
>>
>> Hi Ryan,
>>
>> try to look at the JS console. I suspect some problem with one of the
>> tools in your workflow.
>>
>> Cheers,
>> Bjoern
>>
>> Am 14.07.2015 um 22:02 schrieb Ryan G:
>> > Hmmm this only happens on a specific workflow.  How can I debug this?
>> >
>> > On Tue, Jul 14, 2015 at 3:37 PM, Ryan G <[hidden email]>
>> > wrote:
>> >
>> >> It looks like a recent commit since 6/26 to 15.05 is break the workflow
>> >> editor.  I have a pipeline I'm trying to edit.  I updated my instance
>> >> of
>> >> Galaxy and now when I try to edit a workflow, the editor is stuck at
>> >> "Loading workflow editor".
>> >>
>> >>
>> >>
>> >
>> >
>> >
>> > ___________________________________________________________
>> > Please keep all replies on the list by using "reply all"
>> > in your mail client.  To manage your subscriptions to this
>> > and other Galaxy lists, please use the interface at:
>> >   https://lists.galaxyproject.org/
>> >
>> > To search Galaxy mailing lists use the unified search at:
>> >   http://galaxyproject.org/search/mailinglists/
>> >
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Galaxy-Workflow-RNA-Seq_QC_(hg19)_Pipeline_v0.1.ga (23K) Download Attachment