Workflow with many inputs

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Workflow with many inputs

Alexandre
Hi all,

I have a tool that receives multiple inputs, and it is working fine if I run it stand alone. However, I want to create a workflow where this tool receive as an input the output of other tools.

I can connect the output from the other tools in the input of this tool, but the tool receives only one input.

Is there a way to set multiple inputs to a tool in a workflow? I've found several similar questions like mine, but I haven't found an answer.

I appreciate your help.

Best regards, 

--
Alexandre Defelicibus
Mestrando em Bioengenharia
Programa de Pós-Graduação em Bioengenharia
Universidade de São Paulo - USP

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Workflow with many inputs

John Chilton-4
I just want to clarify - do you have a tool with a multiple input data
parameter (e.g. <param type="data" multiple="true" ... ) as some
intermediate step in a workflow? Or are you using a repeat or
something?

And are you saying the workflow editor shows multiple inputs going
into the tool but at runtime the tool is only actually receiving one
of these?

If yes and yes, I fixed at least a couple different errors related
workflows and multiple input data parameters with the latest release.
Are you on the latest release or something older?

If you are on the latest stable release - can you send me the simplest
workflow you can construct to reproduce the error? That would help
greatly. Also - a link to the tool or a simplification of the tool
with the multiple input data parameter?

If these are not your problems - can you let me know what I misinterpreted?

-John


On Tue, Jul 15, 2014 at 6:06 PM, Alexandre Defelicibus
<[hidden email]> wrote:

> Hi all,
>
> I have a tool that receives multiple inputs, and it is working fine if I run
> it stand alone. However, I want to create a workflow where this tool receive
> as an input the output of other tools.
>
> I can connect the output from the other tools in the input of this tool, but
> the tool receives only one input.
>
> Is there a way to set multiple inputs to a tool in a workflow? I've found
> several similar questions like mine, but I haven't found an answer.
>
> I appreciate your help.
>
> Best regards,
>
> --
> Alexandre Defelicibus
> Mestrando em Bioengenharia
> Programa de Pós-Graduação em Bioengenharia
> Universidade de São Paulo - USP
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: Workflow with many inputs

Alexandre
Hi John,

Thank you very much for your reply.

# I just want to clarify - do you have a tool with a multiple input data
# parameter (e.g. <param type="data" multiple="true" ... ) as some
# intermediate step in a workflow? Or are you using a repeat or
# something?

I have a tool with a multiple input data parameter at the end of the workflow. So, it receives the output of others. The types of output and input are the same. Here is the code of the tool:

<inputs>         
        <param name="input_pdbs" type="data" multiple="true" format="pdb" label="PDB Files" />
        <param name="Fitness_Energy" type="select" display="checkboxes" multiple="true" label="Objective">
            <option value="Potential">Potential</option>
            <option value="Gyrate">Gyrate</option>
            <option value="Hydrophobic">Hydrophobic</option>
            <option value="Hydrophilic">Hydrophilic</option>
            <option value="Area_Total">Total Area</option>
            <option value="H_Bond_Main">H Bond Main</option>
            <option value="Electrostatic">Stride Helix</option>
            <option value="GBSA_Solvatation">GBSA_Solvatation</option>
            <option value="Van_der_Waals">Van der Waals</option>
        </param> 
    </inputs>
    <outputs>
        <data name="output" format="zip" label="Analysis.zip"/>
    </outputs>

# And are you saying the workflow editor shows multiple inputs going
# into the tool but at runtime the tool is only actually receiving one
# of these?

No, the workflow editor doesn't show me multiple input. I was saying that I connect more than one tool to the input of this tool above. I think if I do this, Galaxy would set multiple input with the several outputs I connected, and it does. I was confused because when I ran the workflow, on the tool that should receive two output was showing just one. It would be better if Galaxy listed all the input. 

I checked my instance I wasn't with the latest stable release. I updated and now it is working.

Thanks for your help John.


2014-07-16 17:38 GMT-03:00 John Chilton <[hidden email]>:
I just want to clarify - do you have a tool with a multiple input data
parameter (e.g. <param type="data" multiple="true" ... ) as some
intermediate step in a workflow? Or are you using a repeat or
something?

And are you saying the workflow editor shows multiple inputs going
into the tool but at runtime the tool is only actually receiving one
of these?

If yes and yes, I fixed at least a couple different errors related
workflows and multiple input data parameters with the latest release.
Are you on the latest release or something older?

If you are on the latest stable release - can you send me the simplest
workflow you can construct to reproduce the error? That would help
greatly. Also - a link to the tool or a simplification of the tool
with the multiple input data parameter?

If these are not your problems - can you let me know what I misinterpreted?

-John


On Tue, Jul 15, 2014 at 6:06 PM, Alexandre Defelicibus
<[hidden email]> wrote:
> Hi all,
>
> I have a tool that receives multiple inputs, and it is working fine if I run
> it stand alone. However, I want to create a workflow where this tool receive
> as an input the output of other tools.
>
> I can connect the output from the other tools in the input of this tool, but
> the tool receives only one input.
>
> Is there a way to set multiple inputs to a tool in a workflow? I've found
> several similar questions like mine, but I haven't found an answer.
>
> I appreciate your help.
>
> Best regards,
>
> --
> Alexandre Defelicibus
> Mestrando em Bioengenharia
> Programa de Pós-Graduação em Bioengenharia
> Universidade de São Paulo - USP
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/



--
Alexandre Defelicibus
Mestrando em Bioengenharia
Programa de Pós-Graduação em Bioengenharia
Universidade de São Paulo - USP

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/