bowtie2 toolshed installation

classic Classic list List threaded Threaded
6 messages Options
| Threaded
Open this post in threaded view
|

bowtie2 toolshed installation

Alexander Kurze
Hi there,

I have a local copy of galaxy and I am trying to install bowtie2 2.1.0 onto the system via the toolshed. However it just doesn't work. I always get a Server Error message. I have checked if the dependencies are installed and they are all installed in the toolshed depenencies folders. However, the actual repos only contains the tool_dependency.xml. (eg galaxy/shed_tools/testtoolshed.g2.bx.psu.edu/repos/jjohnson/package_bowtie_2_1_0/38652b57e057/package_bowtie_2_1_0/tool_dependencies.xml)

I thought that there should be a bowtie2.xml file in the repos of package_bowtie_2_1_0 but there isn't...

Also, looking at the shed_tool_config.xml I cannot see any entry for bowtie2.

Is there a way to add bowtie2 manually?

Best wishes,

Alex





___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: bowtie2 toolshed installation

Björn Grüning-3
The package_* is installing the binary for you and can be used by other programs as well. bowtie_wrappers contains the actual wrappers and is depending on package_*. To make it short. You need to install http://toolshed.g2.bx.psu.edu/view/devteam/bowtie_wrappers and both packages will be installed and you should see your wrapper.

Ciao,
Bjoern


2014-01-31 Alexander Kurze <[hidden email]>:
Hi there,

I have a local copy of galaxy and I am trying to install bowtie2 2.1.0 onto the system via the toolshed. However it just doesn't work. I always get a Server Error message. I have checked if the dependencies are installed and they are all installed in the toolshed depenencies folders. However, the actual repos only contains the tool_dependency.xml. (eg galaxy/shed_tools/testtoolshed.g2.bx.psu.edu/repos/jjohnson/package_bowtie_2_1_0/38652b57e057/package_bowtie_2_1_0/tool_dependencies.xml)

I thought that there should be a bowtie2.xml file in the repos of package_bowtie_2_1_0 but there isn't...

Also, looking at the shed_tool_config.xml I cannot see any entry for bowtie2.

Is there a way to add bowtie2 manually?

Best wishes,

Alex





___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: bowtie2 toolshed installation

Alexander Kurze
Thanks for your quick answers.

I actually have installed the dependencies first and then I have tried to add bowtie2 http://toolshed.g2.bx.psu.edu/view/devteam/bowtie2.

But this is where the problem lies: I get following error message:

"Server Error

An error occurred. See the error logs for more information. (Turn debug on to display exception reports here)"


Meanwhile, I have downloaded the bowtie2.xml and added it to the ./tools/sr_mapping/ folder and added it to the tool_config.xml and it now works.

Any clue why I get the error message? Is there something wrong with my server or do is it the repository?

Cheers,

Alex


On Fri, Jan 31, 2014 at 1:18 PM, [hidden email] <[hidden email]> wrote:
The package_* is installing the binary for you and can be used by other programs as well. bowtie_wrappers contains the actual wrappers and is depending on package_*. To make it short. You need to install http://toolshed.g2.bx.psu.edu/view/devteam/bowtie_wrappers and both packages will be installed and you should see your wrapper.

Ciao,
Bjoern


2014-01-31 Alexander Kurze <[hidden email]>:
Hi there,

I have a local copy of galaxy and I am trying to install bowtie2 2.1.0 onto the system via the toolshed. However it just doesn't work. I always get a Server Error message. I have checked if the dependencies are installed and they are all installed in the toolshed depenencies folders. However, the actual repos only contains the tool_dependency.xml. (eg galaxy/shed_tools/testtoolshed.g2.bx.psu.edu/repos/jjohnson/package_bowtie_2_1_0/38652b57e057/package_bowtie_2_1_0/tool_dependencies.xml)

I thought that there should be a bowtie2.xml file in the repos of package_bowtie_2_1_0 but there isn't...

Also, looking at the shed_tool_config.xml I cannot see any entry for bowtie2.

Is there a way to add bowtie2 manually?

Best wishes,

Alex





___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/




--
Alexander Kurze, DPhil
University of Oxford
Department of Biochemistry
South Parks Road
Oxford, OX1 3QU
United Kingdom

Tel: +44 1865 613 230
Fax:+44 1865 613 341

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: bowtie2 toolshed installation

Dave Bouvier
Alex,

To help determine the cause of this, could you paste the output of the
following commands run from the root of your Galaxy installation?

hg heads
hg id

    --Dave B.

On 01/31/2014 09:05 AM, Alexander Kurze wrote:

> Thanks for your quick answers.
>
> I actually have installed the dependencies first and then I have tried
> to add bowtie2 http://toolshed.g2.bx.psu.edu/view/devteam/bowtie2.
>
> But this is where the problem lies: I get following error message:
>
>
>   "Server Error
>
> An error occurred. See the error logs for more information. (Turn debug
> on to display exception reports here)"
>
>
> Meanwhile, I have downloaded the bowtie2.xml and added it to the
> ./tools/sr_mapping/ folder and added it to the tool_config.xml and it
> now works.
>
> Any clue why I get the error message? Is there something wrong with my
> server or do is it the repository?
>
> Cheers,
>
> Alex
>
>
> On Fri, Jan 31, 2014 at 1:18 PM, [hidden email]
> <mailto:[hidden email]> <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hi Alex,
>
>     there is a difference in
>     http://toolshed.g2.bx.psu.edu/view/devteam/package_bowtie2_2_1_0 and
>     http://toolshed.g2.bx.psu.edu/view/devteam/bowtie_wrappers
>     The package_* is installing the binary for you and can be used by
>     other programs as well. bowtie_wrappers contains the actual wrappers
>     and is depending on package_*. To make it short. You need to install
>     http://toolshed.g2.bx.psu.edu/view/devteam/bowtie_wrappers and both
>     packages will be installed and you should see your wrapper.
>
>     Ciao,
>     Bjoern
>
>
>     2014-01-31 Alexander Kurze <[hidden email]
>     <mailto:[hidden email]>>:
>
>         Hi there,
>
>         I have a local copy of galaxy and I am trying to install bowtie2
>         2.1.0 onto the system via the toolshed. However it just doesn't
>         work. I always get a Server Error message. I have checked if the
>         dependencies are installed and they are all installed in the
>         toolshed depenencies folders. However, the actual repos only
>         contains the tool_dependency.xml. (eg
>         galaxy/shed_tools/testtoolshed.g2.bx.psu.edu/repos/jjohnson/package_bowtie_2_1_0/38652b57e057/package_bowtie_2_1_0/tool_dependencies.xml
>         <http://testtoolshed.g2.bx.psu.edu/repos/jjohnson/package_bowtie_2_1_0/38652b57e057/package_bowtie_2_1_0/tool_dependencies.xml>)
>
>         I thought that there should be a bowtie2.xml file in the repos
>         of package_bowtie_2_1_0 but there isn't...
>
>         Also, looking at the shed_tool_config.xml I cannot see any entry
>         for bowtie2.
>
>         Is there a way to add bowtie2 manually?
>
>         Best wishes,
>
>         Alex
>
>
>
>
>
>         ___________________________________________________________
>         Please keep all replies on the list by using "reply all"
>         in your mail client.  To manage your subscriptions to this
>         and other Galaxy lists, please use the interface at:
>         http://lists.bx.psu.edu/
>
>         To search Galaxy mailing lists use the unified search at:
>         http://galaxyproject.org/search/mailinglists/
>
>
>
>
>
> --
> Alexander Kurze, DPhil
> University of Oxford
> Department of Biochemistry
> South Parks Road
> Oxford, OX1 3QU
> United Kingdom
>
> Tel: +44 1865 613 230
> Fax:+44 1865 613 341
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: bowtie2 toolshed installation

Alexander Kurze-2
Here we go

changeset:   8796:961ae35ba612
branch:      stable
tag:         tip
parent:      8794:1c7174911392
user:        Nate Coraor <[hidden email]>
date:        Fri Feb 08 11:23:04 2013 -0500
summary:     Added tag release_2013.02.08 for changeset 1c7174911392

changeset:   8795:9fd7fe0c5712
parent:      8785:25bd9d387135
parent:      8794:1c7174911392
user:        Nate Coraor <[hidden email]>
date:        Fri Feb 08 11:22:54 2013 -0500
summary:     merge from stable


961ae35ba612+ (stable) tip


Alex


On Fri, Jan 31, 2014 at 2:09 PM, Dave Bouvier <[hidden email]> wrote:
Alex,

To help determine the cause of this, could you paste the output of the following commands run from the root of your Galaxy installation?

hg heads
hg id

   --Dave B.


On 01/31/2014 09:05 AM, Alexander Kurze wrote:
Thanks for your quick answers.

I actually have installed the dependencies first and then I have tried
to add bowtie2 http://toolshed.g2.bx.psu.edu/view/devteam/bowtie2.

But this is where the problem lies: I get following error message:


  "Server Error

An error occurred. See the error logs for more information. (Turn debug
on to display exception reports here)"


Meanwhile, I have downloaded the bowtie2.xml and added it to the
./tools/sr_mapping/ folder and added it to the tool_config.xml and it
now works.

Any clue why I get the error message? Is there something wrong with my
server or do is it the repository?

Cheers,

Alex


On Fri, Jan 31, 2014 at 1:18 PM, [hidden email]
<mailto:[hidden email]> <[hidden email]

<mailto:[hidden email]>> wrote:

    Hi Alex,

    there is a difference in
    http://toolshed.g2.bx.psu.edu/view/devteam/package_bowtie2_2_1_0 and
    http://toolshed.g2.bx.psu.edu/view/devteam/bowtie_wrappers
    The package_* is installing the binary for you and can be used by
    other programs as well. bowtie_wrappers contains the actual wrappers
    and is depending on package_*. To make it short. You need to install
    http://toolshed.g2.bx.psu.edu/view/devteam/bowtie_wrappers and both
    packages will be installed and you should see your wrapper.

    Ciao,
    Bjoern


    2014-01-31 Alexander Kurze <[hidden email]
    <mailto:[hidden email]>>:


        Hi there,

        I have a local copy of galaxy and I am trying to install bowtie2
        2.1.0 onto the system via the toolshed. However it just doesn't
        work. I always get a Server Error message. I have checked if the
        dependencies are installed and they are all installed in the
        toolshed depenencies folders. However, the actual repos only
        contains the tool_dependency.xml. (eg
        galaxy/shed_tools/testtoolshed.g2.bx.psu.edu/repos/jjohnson/package_bowtie_2_1_0/38652b57e057/package_bowtie_2_1_0/tool_dependencies.xml
        <http://testtoolshed.g2.bx.psu.edu/repos/jjohnson/package_bowtie_2_1_0/38652b57e057/package_bowtie_2_1_0/tool_dependencies.xml>)


        I thought that there should be a bowtie2.xml file in the repos
        of package_bowtie_2_1_0 but there isn't...

        Also, looking at the shed_tool_config.xml I cannot see any entry
        for bowtie2.

        Is there a way to add bowtie2 manually?

        Best wishes,

        Alex





        ___________________________________________________________
        Please keep all replies on the list by using "reply all"
        in your mail client.  To manage your subscriptions to this
        and other Galaxy lists, please use the interface at:
        http://lists.bx.psu.edu/

        To search Galaxy mailing lists use the unified search at:
        http://galaxyproject.org/search/mailinglists/





--
Alexander Kurze, DPhil
University of Oxford
Department of Biochemistry
South Parks Road
Oxford, OX1 3QU
United Kingdom

Tel: <a href="tel:%2B44%201865%20613%20230" value="+441865613230" target="_blank">+44 1865 613 230
Fax:<a href="tel:%2B44%201865%20613%20341" value="+441865613341" target="_blank">+44 1865 613 341



--
Alexander Kurze
70 Sunningwell Road
Oxford, OX1 4SX

Tel:   +44 1865-243-609
Mobile:  +44 7962-425-865

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: bowtie2 toolshed installation

Dave Bouvier
Alex,

It is likely that the error you're encountering may have been resolved
in the current stable branch. A description of the steps required to
update your installation can be found on the following page:

https://wiki.galaxyproject.org/Admin/GetGalaxy#Keep_your_code_up_to_date

Be advised that there is at least one database upgrade between the
2013-02-08 release and the current stable branch, so the paragraph
describing database migration does apply.

Additionally, a number of tools were migrated to the tool shed from the
Galaxy distribution since that release. A detailed explanation of this
process and instructions for installing the repositories containing
migrated tools can be found at the following page:

https://wiki.galaxyproject.org/MigratingToolsFromGalaxyDistribution

    --Dave B.

On 01/31/2014 09:14 AM, Alexander Kurze wrote:

> Here we go
>
> changeset:   8796:961ae35ba612
> branch:      stable
> tag:         tip
> parent:      8794:1c7174911392
> user:        Nate Coraor <[hidden email] <mailto:[hidden email]>>
> date:        Fri Feb 08 11:23:04 2013 -0500
> summary:     Added tag release_2013.02.08 for changeset 1c7174911392
>
> changeset:   8795:9fd7fe0c5712
> parent:      8785:25bd9d387135
> parent:      8794:1c7174911392
> user:        Nate Coraor <[hidden email] <mailto:[hidden email]>>
> date:        Fri Feb 08 11:22:54 2013 -0500
> summary:     merge from stable
>
>
> 961ae35ba612+ (stable) tip
>
>
> Alex
>
>
> On Fri, Jan 31, 2014 at 2:09 PM, Dave Bouvier <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Alex,
>
>     To help determine the cause of this, could you paste the output of
>     the following commands run from the root of your Galaxy installation?
>
>     hg heads
>     hg id
>
>         --Dave B.
>
>
>     On 01/31/2014 09:05 AM, Alexander Kurze wrote:
>
>         Thanks for your quick answers.
>
>         I actually have installed the dependencies first and then I have
>         tried
>         to add bowtie2
>         http://toolshed.g2.bx.psu.edu/__view/devteam/bowtie2
>         <http://toolshed.g2.bx.psu.edu/view/devteam/bowtie2>.
>
>         But this is where the problem lies: I get following error message:
>
>
>            "Server Error
>
>         An error occurred. See the error logs for more information.
>         (Turn debug
>         on to display exception reports here)"
>
>
>         Meanwhile, I have downloaded the bowtie2.xml and added it to the
>         ./tools/sr_mapping/ folder and added it to the tool_config.xml
>         and it
>         now works.
>
>         Any clue why I get the error message? Is there something wrong
>         with my
>         server or do is it the repository?
>
>         Cheers,
>
>         Alex
>
>
>         On Fri, Jan 31, 2014 at 1:18 PM, [hidden email]
>         <mailto:[hidden email]>
>         <mailto:[hidden email]
>         <mailto:[hidden email]>>
>         <[hidden email] <mailto:[hidden email]>
>
>         <mailto:bjoern.gruening@gmail.__com
>         <mailto:[hidden email]>>> wrote:
>
>              Hi Alex,
>
>              there is a difference in
>         http://toolshed.g2.bx.psu.edu/__view/devteam/package_bowtie2___2_1_0
>         <http://toolshed.g2.bx.psu.edu/view/devteam/package_bowtie2_2_1_0>
>         and
>         http://toolshed.g2.bx.psu.edu/__view/devteam/bowtie_wrappers
>         <http://toolshed.g2.bx.psu.edu/view/devteam/bowtie_wrappers>
>              The package_* is installing the binary for you and can be
>         used by
>              other programs as well. bowtie_wrappers contains the actual
>         wrappers
>              and is depending on package_*. To make it short. You need
>         to install
>         http://toolshed.g2.bx.psu.edu/__view/devteam/bowtie_wrappers
>         <http://toolshed.g2.bx.psu.edu/view/devteam/bowtie_wrappers> and
>         both
>              packages will be installed and you should see your wrapper.
>
>              Ciao,
>              Bjoern
>
>
>              2014-01-31 Alexander Kurze
>         <[hidden email].__uk
>         <mailto:[hidden email]>
>              <mailto:[hidden email]
>         <mailto:[hidden email]>>>:
>
>
>                  Hi there,
>
>                  I have a local copy of galaxy and I am trying to
>         install bowtie2
>                  2.1.0 onto the system via the toolshed. However it just
>         doesn't
>                  work. I always get a Server Error message. I have
>         checked if the
>                  dependencies are installed and they are all installed
>         in the
>                  toolshed depenencies folders. However, the actual repos
>         only
>                  contains the tool_dependency.xml. (eg
>
>         galaxy/shed_tools/testtoolshed__.g2.bx.psu.edu/repos/jjohnson/__package_bowtie_2_1_0/__38652b57e057/package_bowtie_2___1_0/tool_dependencies.xml
>         <http://testtoolshed.g2.bx.psu.edu/repos/jjohnson/package_bowtie_2_1_0/38652b57e057/package_bowtie_2_1_0/tool_dependencies.xml>
>
>         <http://testtoolshed.g2.bx.__psu.edu/repos/jjohnson/__package_bowtie_2_1_0/__38652b57e057/package_bowtie_2___1_0/tool_dependencies.xml
>         <http://testtoolshed.g2.bx.psu.edu/repos/jjohnson/package_bowtie_2_1_0/38652b57e057/package_bowtie_2_1_0/tool_dependencies.xml>>)
>
>
>                  I thought that there should be a bowtie2.xml file in
>         the repos
>                  of package_bowtie_2_1_0 but there isn't...
>
>                  Also, looking at the shed_tool_config.xml I cannot see
>         any entry
>                  for bowtie2.
>
>                  Is there a way to add bowtie2 manually?
>
>                  Best wishes,
>
>                  Alex
>
>
>
>
>
>
>         _____________________________________________________________
>                  Please keep all replies on the list by using "reply all"
>                  in your mail client.  To manage your subscriptions to this
>                  and other Galaxy lists, please use the interface at:
>         http://lists.bx.psu.edu/
>
>                  To search Galaxy mailing lists use the unified search at:
>         http://galaxyproject.org/__search/mailinglists/
>         <http://galaxyproject.org/search/mailinglists/>
>
>
>
>
>
>         --
>         Alexander Kurze, DPhil
>         University of Oxford
>         Department of Biochemistry
>         South Parks Road
>         Oxford, OX1 3QU
>         United Kingdom
>
>         Tel: +44 1865 613 230 <tel:%2B44%201865%20613%20230>
>         Fax:+44 1865 613 341 <tel:%2B44%201865%20613%20341>
>
>
>
>
> --
> Alexander Kurze
> 70 Sunningwell Road
> Oxford, OX1 4SX
>
> Tel:   +44 1865-243-609
> Mobile:  +44 7962-425-865
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/