bug in galaxy-central security

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

bug in galaxy-central security

Robert Baertsch
James, 
I upgraded to the latest galaxy-central and starting with a blank database. When I add more than 20 users, the security group admin screen doesn't populate. 

mako is pulling the correct data but there is some jquery code for autocomplete or search that seems to be having trouble.

Here is a screen shot.   Let me know if you want admin access to this server and I'll setup a user for you.
-Robert



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: bug in galaxy-central security

Dannon Baker-2
Hey Robert,

Thanks for catching this; I'm working on getting a fix out (this affects multiple areas in the admin panel) but if you need to temporarily fix a single page to get things working you can execute "$('select').select2("destroy")" in your javascript console.

-Dannon


On Tue, Jun 4, 2013 at 3:20 PM, Robert Baertsch <[hidden email]> wrote:
James, 
I upgraded to the latest galaxy-central and starting with a blank database. When I add more than 20 users, the security group admin screen doesn't populate. 

mako is pulling the correct data but there is some jquery code for autocomplete or search that seems to be having trouble.

Here is a screen shot.   Let me know if you want admin access to this server and I'll setup a user for you.
-Robert



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: bug in galaxy-central security

Robert Baertsch
Hi Dannon,
I deleted the declaration to select2 in base.mako (line 42) and that fixed the problem for now. (thanks to Ted for the tip!)
-Robert
On Jun 4, 2013, at 1:30 PM, Dannon Baker wrote:

Hey Robert,

Thanks for catching this; I'm working on getting a fix out (this affects multiple areas in the admin panel) but if you need to temporarily fix a single page to get things working you can execute "$('select').select2("destroy")" in your javascript console.

-Dannon


On Tue, Jun 4, 2013 at 3:20 PM, Robert Baertsch <[hidden email]> wrote:
James, 
I upgraded to the latest galaxy-central and starting with a blank database. When I add more than 20 users, the security group admin screen doesn't populate. 

mako is pulling the correct data but there is some jquery code for autocomplete or search that seems to be having trouble.

Here is a screen shot.   Let me know if you want admin access to this server and I'll setup a user for you.
-Robert

<Screen Shot 2013-06-04 at 12.18.21 PM.png>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: bug in galaxy-central security

Dannon Baker-2
That'll work, but it'll deactivate select2 across the board for all pages in your galaxy instance.  I committed a fix for those specific admin pages yesterday, available in galaxy-central (stable as well as default branch).

-Dannon


On Thu, Jun 6, 2013 at 1:37 PM, Robert Baertsch <[hidden email]> wrote:
Hi Dannon,
I deleted the declaration to select2 in base.mako (line 42) and that fixed the problem for now. (thanks to Ted for the tip!)
-Robert
On Jun 4, 2013, at 1:30 PM, Dannon Baker wrote:

Hey Robert,

Thanks for catching this; I'm working on getting a fix out (this affects multiple areas in the admin panel) but if you need to temporarily fix a single page to get things working you can execute "$('select').select2("destroy")" in your javascript console.

-Dannon


On Tue, Jun 4, 2013 at 3:20 PM, Robert Baertsch <[hidden email]> wrote:
James, 
I upgraded to the latest galaxy-central and starting with a blank database. When I add more than 20 users, the security group admin screen doesn't populate. 

mako is pulling the correct data but there is some jquery code for autocomplete or search that seems to be having trouble.

Here is a screen shot.   Let me know if you want admin access to this server and I'll setup a user for you.
-Robert

<Screen Shot 2013-06-04 at 12.18.21 PM.png>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: bug in galaxy-central security

Robert Baertsch
Ah, I see it now. 
https://bitbucket.org/galaxy/galaxy-central/commits/c4096b030f10eb346b24da98ce16b72d23672f03


On Jun 6, 2013, at 10:42 AM, Dannon Baker wrote:

That'll work, but it'll deactivate select2 across the board for all pages in your galaxy instance.  I committed a fix for those specific admin pages yesterday, available in galaxy-central (stable as well as default branch).

-Dannon


On Thu, Jun 6, 2013 at 1:37 PM, Robert Baertsch <[hidden email]> wrote:
Hi Dannon,
I deleted the declaration to select2 in base.mako (line 42) and that fixed the problem for now. (thanks to Ted for the tip!)
-Robert
On Jun 4, 2013, at 1:30 PM, Dannon Baker wrote:

Hey Robert,

Thanks for catching this; I'm working on getting a fix out (this affects multiple areas in the admin panel) but if you need to temporarily fix a single page to get things working you can execute "$('select').select2("destroy")" in your javascript console.

-Dannon


On Tue, Jun 4, 2013 at 3:20 PM, Robert Baertsch <[hidden email]> wrote:
James, 
I upgraded to the latest galaxy-central and starting with a blank database. When I add more than 20 users, the security group admin screen doesn't populate. 

mako is pulling the correct data but there is some jquery code for autocomplete or search that seems to be having trouble.

Here is a screen shot.   Let me know if you want admin access to this server and I'll setup a user for you.
-Robert

<Screen Shot 2013-06-04 at 12.18.21 PM.png>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/





___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: bug in galaxy-central security

Robert Baertsch
In reply to this post by Dannon Baker-2
Dannon,
Can you also apply the same select2 fix to:

templates/webapps/galaxy/library/common/library_permissions.mako

It has the same problem.
-Robert

On Jun 6, 2013, at 10:42 AM, Dannon Baker wrote:

That'll work, but it'll deactivate select2 across the board for all pages in your galaxy instance.  I committed a fix for those specific admin pages yesterday, available in galaxy-central (stable as well as default branch).

-Dannon


On Thu, Jun 6, 2013 at 1:37 PM, Robert Baertsch <[hidden email]> wrote:
Hi Dannon,
I deleted the declaration to select2 in base.mako (line 42) and that fixed the problem for now. (thanks to Ted for the tip!)
-Robert
On Jun 4, 2013, at 1:30 PM, Dannon Baker wrote:

Hey Robert,

Thanks for catching this; I'm working on getting a fix out (this affects multiple areas in the admin panel) but if you need to temporarily fix a single page to get things working you can execute "$('select').select2("destroy")" in your javascript console.

-Dannon


On Tue, Jun 4, 2013 at 3:20 PM, Robert Baertsch <[hidden email]> wrote:
James, 
I upgraded to the latest galaxy-central and starting with a blank database. When I add more than 20 users, the security group admin screen doesn't populate. 

mako is pulling the correct data but there is some jquery code for autocomplete or search that seems to be having trouble.

Here is a screen shot.   Let me know if you want admin access to this server and I'll setup a user for you.
-Robert

<Screen Shot 2013-06-04 at 12.18.21 PM.png>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/





___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: bug in galaxy-central security

Dannon Baker-2
Thanks, fixed in 9972:7794e02d5ee5.

-Dannon


On Fri, Jun 7, 2013 at 2:26 AM, Robert Baertsch <[hidden email]> wrote:
Dannon,
Can you also apply the same select2 fix to:

templates/webapps/galaxy/library/common/library_permissions.mako

It has the same problem.
-Robert

On Jun 6, 2013, at 10:42 AM, Dannon Baker wrote:

That'll work, but it'll deactivate select2 across the board for all pages in your galaxy instance.  I committed a fix for those specific admin pages yesterday, available in galaxy-central (stable as well as default branch).

-Dannon


On Thu, Jun 6, 2013 at 1:37 PM, Robert Baertsch <[hidden email]> wrote:
Hi Dannon,
I deleted the declaration to select2 in base.mako (line 42) and that fixed the problem for now. (thanks to Ted for the tip!)
-Robert
On Jun 4, 2013, at 1:30 PM, Dannon Baker wrote:

Hey Robert,

Thanks for catching this; I'm working on getting a fix out (this affects multiple areas in the admin panel) but if you need to temporarily fix a single page to get things working you can execute "$('select').select2("destroy")" in your javascript console.

-Dannon


On Tue, Jun 4, 2013 at 3:20 PM, Robert Baertsch <[hidden email]> wrote:
James, 
I upgraded to the latest galaxy-central and starting with a blank database. When I add more than 20 users, the security group admin screen doesn't populate. 

mako is pulling the correct data but there is some jquery code for autocomplete or search that seems to be having trouble.

Here is a screen shot.   Let me know if you want admin access to this server and I'll setup a user for you.
-Robert

<Screen Shot 2013-06-04 at 12.18.21 PM.png>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/






___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/