error with multi dataset tool run

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

error with multi dataset tool run

Robert Baertsch
I submitted 13 fastq files to tophat2 using DRMAA and got this error.  Is it fatal?   BTW: This is a super cool feature.

I’m running the following version of galaxy-dist.

changeset:   14212:91547729ffde
branch:      stable
tag:         tip
user:        Nate Coraor <[hidden email]>
date:        Fri Aug 29 14:00:23 2014 -0400
summary:     Update tag latest_2014.08.11 for changeset ea12550fbc34

-Robert


There were errors setting up 2 submitted job(s):
  • Error executing tool: (OperationalError) database is locked u'UPDATE history_dataset_association SET update_time=?, name=?, blurb=? WHERE history_dataset_association.id = ?' ('2014-08-30 23:14:44.683957', 'Tophat2 on data 7: insertions', 'queued', 137)
  • Error executing tool: (OperationalError) database is locked u'UPDATE dataset SET update_time=?, state=? WHERE dataset.id = ?' ('2014-08-30 23:15:57.204718', 'queued', 446)


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: error with multi dataset tool run

Hans-Rudolf Hotz
Hi Robert

Are you using the built in SQLite database ?

Hans-Rudolf

On 08/31/2014 01:27 AM, Robert Baertsch wrote:

> I submitted 13 fastq files to tophat2 using DRMAA and got this error.
>   Is it fatal?   BTW: This is a super cool feature.
>
> I’m running the following version of galaxy-dist.
>
> changeset:   14212:91547729ffde
> branch:      stable
> tag:         tip
> user:        Nate Coraor <[hidden email] <mailto:[hidden email]>>
> date:        Fri Aug 29 14:00:23 2014 -0400
> summary:     Update tag latest_2014.08.11 for changeset ea12550fbc34
>
> -Robert
>
>
> There were errors setting up 2 submitted job(s):
>
>   * *Error executing tool: (OperationalError) database is locked
>     u'UPDATE history_dataset_association SET update_time=?, name=?,
>     blurb=? WHERE history_dataset_association.id = ?' ('2014-08-30
>     23:14:44.683957', 'Tophat2 on data 7: insertions', 'queued', 137)*
>   * *Error executing tool: (OperationalError) database is locked
>     u'UPDATE dataset SET update_time=?, state=? WHERE dataset.id = ?'
>     ('2014-08-30 23:15:57.204718', 'queued', 446)*
>
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>    http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>    http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: error with multi dataset tool run

Robert Baertsch
In reply to this post by Robert Baertsch

yes,  I was the only user but I guess it is too fragile for this kind of thing.   postgres wasn’t queuing age jobs correctly so I guess I should track down why.


From: Hans-Rudolf Hotz <[hidden email]>
Subject: Re: [galaxy-dev] error with multi dataset tool run
Date: September 1, 2014 at 5:54:10 AM PDT
To: Robert Baertsch <[hidden email]>, <[hidden email]>


Hi Robert

Are you using the built in SQLite database ?

Hans-Rudolf

On 08/31/2014 01:27 AM, Robert Baertsch wrote:
I submitted 13 fastq files to tophat2 using DRMAA and got this error.
 Is it fatal?   BTW: This is a super cool feature.

I’m running the following version of galaxy-dist.

changeset:   14212:91547729ffde
branch:      stable
tag:         tip
user:        Nate Coraor <[hidden email] <[hidden email]>>
date:        Fri Aug 29 14:00:23 2014 -0400
summary:     Update tag latest_2014.08.11 for changeset ea12550fbc34

-Robert


There were errors setting up 2 submitted job(s):

 * *Error executing tool: (OperationalError) database is locked
   u'UPDATE history_dataset_association SET update_time=?, name=?,
   blurb=? WHERE history_dataset_association.id = ?' ('2014-08-30
   23:14:44.683957', 'Tophat2 on data 7: insertions', 'queued', 137)*
 * *Error executing tool: (OperationalError) database is locked
   u'UPDATE dataset SET update_time=?, state=? WHERE dataset.id = ?'
   ('2014-08-30 23:15:57.204718', 'queued', 446)*




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/





From: Sandra Derozier <[hidden email]>
Subject: [galaxy-dev] Error with functional tests on cluster
Date: September 1, 2014 at 6:54:41 AM PDT


Hi all,

I try to set up functional tests on different tools on my Galaxy portal.

When I run functional tests locally everything works fine. But when I run them on the cluster it failed with this message :

/bin/sh: module: line 1: syntax error: unexpected end of file
/bin/sh: error importing function definition for `module'

The execution on the cluster is ok but the dataset state is set to ERROR.

The DIFF between the expected result and the obtained result is null. Indeed, this two files are the same.

As I do not know what the problem is: do you have an idea?

Thanks,
Sandra DEROZIER

Sandra DEROZIER
Unité Mathèmatique, Informatique et Génome (MIG)
Plateforme MIGALE
Bâtiment 233
Domaine de Vilvert
78352 Jouy-en-Josas Cedex




From: Hans-Rudolf Hotz <[hidden email]>
Subject: [galaxy-dev] Solved - Re: testing the visualization plugins
Date: September 1, 2014 at 8:13:30 AM PDT


Hi all

First of all, a big Thanks to Carl who helped me fixing this problem.

So as a summary for all, the problem was caused by a datatype (an extension to tabular), I manually added to "datatypes_conf.xml"

Removing the datatype fixed the problem. I couldn't identify a syntax problem, neither in "datatypes_conf.xml" nor in "~/lib/galaxy/datatypes/registry.py" and "~/lib/galaxy/datatypes/tabular.py". However, renaming it (in all three files) fixed it as well.

Regards, Hans-Rudolf



_______________________________________________
galaxy-dev mailing list
[hidden email]
http://lists.bx.psu.edu/listinfo/galaxy-dev

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/