installing htseq-count from tool-shed

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

installing htseq-count from tool-shed

karenchait

Hi,

I am trying to install the tool htseq-count from the tool-shed. I had a problem in the first installation so I uninstalled the tool and all its dependencies (numpy, samtools 0.1.19 and pysam) from the ‘manage installed tool shed repositories) and installed it again but then I get installation status ‘Installed, missing tool dependencies’ for htseq-count.

When running this tool I get the error

Fatal error: The HTSeq python package is not properly installed, contact Galaxy administrators

The path set in universe_wsgi.ini:

tool_dependency_dir = /home/galaxy/galaxy-dist/tool_deps

 

in the installation log htseq/0.6.1/lparsons/htseq_count/d5edaf8dc974/INSTALLATION.log I get the error:

Setup script for HTSeq: Failed to import 'numpy'.

Please install numpy and then try again to install HTSeq.

 

I reinstalled numpy but that did not help.

How should I continue?

Thanks,

Karen

 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: installing htseq-count from tool-shed

Ross-2
Hi, Karen.
The toolshed has changed a lot recently so if you are not running the latest Galaxy release, try updating? If that doesn't help maybe check with the tool author?
Another htseq based wrapper htseq_bams_to_count_matrix which passes tests can be installed via the admin menu from the test toolshed via the admin menu or viewed at https://testtoolshed.g2.bx.psu.edu/view/fubar/htseq_bams_to_count_matrix.


On Tue, Jun 10, 2014 at 6:04 PM, Karen Chait <[hidden email]> wrote:

Hi,

I am trying to install the tool htseq-count from the tool-shed. I had a problem in the first installation so I uninstalled the tool and all its dependencies (numpy, samtools 0.1.19 and pysam) from the ‘manage installed tool shed repositories) and installed it again but then I get installation status ‘Installed, missing tool dependencies’ for htseq-count.

When running this tool I get the error

Fatal error: The HTSeq python package is not properly installed, contact Galaxy administrators

The path set in universe_wsgi.ini:

tool_dependency_dir = /home/galaxy/galaxy-dist/tool_deps

 

in the installation log htseq/0.6.1/lparsons/htseq_count/d5edaf8dc974/INSTALLATION.log I get the error:

Setup script for HTSeq: Failed to import 'numpy'.

Please install numpy and then try again to install HTSeq.

 

I reinstalled numpy but that did not help.

How should I continue?

Thanks,

Karen

 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: installing htseq-count from tool-shed

Lance Parsons
In reply to this post by karenchait
Hi Karen,

Sorry your having trouble with installing the tool. It seems that the somehow, the numpy dependency didn't install properly or isn't being found during the HTSeq install. Is there any other info in the log to indicate an issue with installing Numpy? Also, what OS are you running Galaxy on?

Lance

On June 10, 2014 4:04:13 AM EDT, Karen Chait <[hidden email]> wrote:

Hi,

I am trying to install the tool htseq-count from the tool-shed. I had a problem in the first installation so I uninstalled the tool and all its dependencies (numpy, samtools 0.1.19 and pysam) from the ‘manage installed tool shed repositories) and installed it again but then I get installation status ‘Installed, missing tool dependencies’ for htseq-count.

When running this tool I get the error

Fatal error: The HTSeq python package is! not properly installed, contact Galaxy administrators

The path set in universe_wsgi.ini:

tool_dependency_dir = /home/galaxy/galaxy-dist/tool_deps

 

in the installation log htseq/0.6.1/lparsons/htseq_count/d5edaf8dc974/INSTALLATION.log I get the error:

Setup script for HTSeq: Failed to import 'numpy'.

Please install numpy and then try again to install HTSeq.

 

I reinstalled numpy but that did not help.

How should I continue?

Thanks,

Karen

 



Please keep all replies on the list by using "reply all"
in your mail client. To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/

--
Lance Parsons - Scientific Programmer
134 Carl C. Icahn Laboratory
Lewis-Sigler Institute for Integrative Genomics
Princeton University
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/