migratting to Galaxy new realease error

classic Classic list List threaded Threaded
5 messages Options
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

migratting to Galaxy new realease error

Mohamed Kassam
Dear all,

I have migrate my old version of Galaxy to the new release V17.01, And I am facing this error when I am running run.sh, any clue ?

Installing collected packages: python-ldap
  Found existing installation: python-ldap 2.4.17
    DEPRECATION: Uninstalling a distutils installed project (python-ldap) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will only partially uninstall the project.
    Can't uninstall 'python-ldap'. No files were found to uninstall.
  Can't roll back python-ldap; was not uninstalled
Exception:
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/commands/install.py", line 342, in run
    prefix=options.prefix_path,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_set.py", line 784, in install
    **kwargs
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 851, in install
    self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 1064, in move_wheel_files
    isolated=self.isolated,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 345, in move_wheel_files
    clobber(source, lib_dir, True)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 329, in clobber
    os.utime(destfile, (st.st_atime, st.st_mtime))
OSError: [Errno 1] Operation not permitted: '/home/galaxy/galaxy-dist/.venv/lib64/python2.7/site-packages/dsml.pyo'


Thanks,

Mohamed

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: migratting to Galaxy new realease error

Mohamed Kassam
Hello 
i tried to install via root and maybe it works, 

However now the bash run.sh it is working, however my ldap is not working I have password incorrect and I get this error in the terminal :

galaxy.auth.providers.ldap_ad ERROR 2017-02-24 10:52:24,672 LDAP authenticate: search exception
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/lib/galaxy/auth/providers/ldap_ad.py", line 118, in authenticate
    ldap.set_option(*opt)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 135, in set_option
    return _ldap_function_call(None,_ldap.set_option,option,invalue)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 66, in _ldap_function_call
    result = func(*args,**kwargs)
ValueError: option error


Any idea ?

Thanks,

Mohamed

2017-02-24 9:11 GMT+01:00 Mohamed Kassam <[hidden email]>:
Dear all,

I have migrate my old version of Galaxy to the new release V17.01, And I am facing this error when I am running run.sh, any clue ?

Installing collected packages: python-ldap
  Found existing installation: python-ldap 2.4.17
    DEPRECATION: Uninstalling a distutils installed project (python-ldap) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will only partially uninstall the project.
    Can't uninstall 'python-ldap'. No files were found to uninstall.
  Can't roll back python-ldap; was not uninstalled
Exception:
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/commands/install.py", line 342, in run
    prefix=options.prefix_path,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_set.py", line 784, in install
    **kwargs
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 851, in install
    self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 1064, in move_wheel_files
    isolated=self.isolated,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 345, in move_wheel_files
    clobber(source, lib_dir, True)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 329, in clobber
    os.utime(destfile, (st.st_atime, st.st_mtime))
OSError: [Errno 1] Operation not permitted: '/home/galaxy/galaxy-dist/.venv/lib64/python2.7/site-packages/dsml.pyo'


Thanks,

Mohamed


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: migratting to Galaxy new realease error

Gildas Le Corguillé
Hi Mohamed,

Have you try to remove (and backup if you want) the whole .venn folder?
Galaxy will create a new one with all its needs.

Best

Gildas

-----------------------------------------------------------------
Gildas Le Corguillé - Bioinformatician/Bioanalyste

Plateform ABiMS (Analyses and Bioinformatics for Marine Science)
http://abims.sb-roscoff.fr

Member of the Workflow4Metabolomics project
http://workflow4metabolomics.org

Station Biologique de Roscoff - UPMC/CNRS - FR2424
Place Georges Teissier 29680 Roscoff FRANCE
tel: +33 2 98 29 23 81
------------------------------------------------------------------



Le 24 févr. 2017 à 09:42, Mohamed Kassam <[hidden email]> a écrit :

Hello 
i tried to install via root and maybe it works, 

However now the bash run.sh it is working, however my ldap is not working I have password incorrect and I get this error in the terminal :

galaxy.auth.providers.ldap_ad ERROR 2017-02-24 10:52:24,672 LDAP authenticate: search exception
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/lib/galaxy/auth/providers/ldap_ad.py", line 118, in authenticate
    ldap.set_option(*opt)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 135, in set_option
    return _ldap_function_call(None,_ldap.set_option,option,invalue)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 66, in _ldap_function_call
    result = func(*args,**kwargs)
ValueError: option error


Any idea ?

Thanks,

Mohamed

2017-02-24 9:11 GMT+01:00 Mohamed Kassam <[hidden email]>:
Dear all,

I have migrate my old version of Galaxy to the new release V17.01, And I am facing this error when I am running run.sh, any clue ?

Installing collected packages: python-ldap
  Found existing installation: python-ldap 2.4.17
    DEPRECATION: Uninstalling a distutils installed project (python-ldap) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will only partially uninstall the project.
    Can't uninstall 'python-ldap'. No files were found to uninstall.
  Can't roll back python-ldap; was not uninstalled
Exception:
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/commands/install.py", line 342, in run
    prefix=options.prefix_path,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_set.py", line 784, in install
    **kwargs
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 851, in install
    self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 1064, in move_wheel_files
    isolated=self.isolated,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 345, in move_wheel_files
    clobber(source, lib_dir, True)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 329, in clobber
    os.utime(destfile, (st.st_atime, st.st_mtime))
OSError: [Errno 1] Operation not permitted: '/home/galaxy/galaxy-dist/.venv/lib64/python2.7/site-packages/dsml.pyo'


Thanks,

Mohamed

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: migratting to Galaxy new realease error

Mohamed Kassam
Dear Gildas,

Thanks for your message.

So I 've tried and it recretaed a new .venv. I've checked the ldap python and it was succeffully installed : Installing collected packages: psycopg2, Pygments, WebError, python-ldap
Successfully installed Pygments-2.0.2 WebError-0.10.3 psycopg2-2.6.1 python-ldap-2.4.27
Activating virtualenv at .venv


But the probelm is still there, and I think it is because there is this new folder auth in galaxy-dist/lib/galaxy/auth/.  
And maybe it is looking from that 
 File "/home/galaxy/galaxy-dist/lib/galaxy/auth/providers/ldap_ad.py", line 118, in authenticate
    ldap.set_option(*opt)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 135, in set_option
    return _ldap_function_call(None,_ldap.set_option,option,invalue)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 66, in _ldap_function_call
    result = func(*args,**kwargs)
ValueError: option error


Any one has this error ?

Mohamed


2017-02-24 9:47 GMT+01:00 Gildas Le Corguillé <[hidden email]>:
Hi Mohamed,

Have you try to remove (and backup if you want) the whole .venn folder?
Galaxy will create a new one with all its needs.

Best

Gildas

-----------------------------------------------------------------
Gildas Le Corguillé - Bioinformatician/Bioanalyste

Plateform ABiMS (Analyses and Bioinformatics for Marine Science)
http://abims.sb-roscoff.fr

Member of the Workflow4Metabolomics project
http://workflow4metabolomics.org

Station Biologique de Roscoff - UPMC/CNRS - FR2424
Place Georges Teissier 29680 Roscoff FRANCE
tel: <a href="tel:02%2098%2029%2023%2081" value="+33298292381" target="_blank">+33 2 98 29 23 81
------------------------------------------------------------------



Le 24 févr. 2017 à 09:42, Mohamed Kassam <[hidden email]> a écrit :

Hello 
i tried to install via root and maybe it works, 

However now the bash run.sh it is working, however my ldap is not working I have password incorrect and I get this error in the terminal :

galaxy.auth.providers.ldap_ad ERROR 2017-02-24 10:52:24,672 LDAP authenticate: search exception
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/lib/galaxy/auth/providers/ldap_ad.py", line 118, in authenticate
    ldap.set_option(*opt)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 135, in set_option
    return _ldap_function_call(None,_ldap.set_option,option,invalue)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 66, in _ldap_function_call
    result = func(*args,**kwargs)
ValueError: option error


Any idea ?

Thanks,

Mohamed

2017-02-24 9:11 GMT+01:00 Mohamed Kassam <[hidden email]>:
Dear all,

I have migrate my old version of Galaxy to the new release V17.01, And I am facing this error when I am running run.sh, any clue ?

Installing collected packages: python-ldap
  Found existing installation: python-ldap 2.4.17
    DEPRECATION: Uninstalling a distutils installed project (python-ldap) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will only partially uninstall the project.
    Can't uninstall 'python-ldap'. No files were found to uninstall.
  Can't roll back python-ldap; was not uninstalled
Exception:
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/commands/install.py", line 342, in run
    prefix=options.prefix_path,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_set.py", line 784, in install
    **kwargs
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 851, in install
    self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 1064, in move_wheel_files
    isolated=self.isolated,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 345, in move_wheel_files
    clobber(source, lib_dir, True)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 329, in clobber
    os.utime(destfile, (st.st_atime, st.st_mtime))
OSError: [Errno 1] Operation not permitted: '/home/galaxy/galaxy-dist/.venv/lib64/python2.7/site-packages/dsml.pyo'


Thanks,

Mohamed

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: migratting to Galaxy new realease error

Nicola Soranzo-2
Hi Mohamed,
the lib/galaxy/auth/ folder is not new at all, there seems to be a problem in your config/auth_conf.xml , what do you have inside

<ldap-options> </ldap-options>

?

Cheers,
Nicola

On 24/02/17 08:56, Mohamed Kassam wrote:
Dear Gildas,

Thanks for your message.

So I 've tried and it recretaed a new .venv. I've checked the ldap python and it was succeffully installed : Installing collected packages: psycopg2, Pygments, WebError, python-ldap
Successfully installed Pygments-2.0.2 WebError-0.10.3 psycopg2-2.6.1 python-ldap-2.4.27
Activating virtualenv at .venv


But the probelm is still there, and I think it is because there is this new folder auth in galaxy-dist/lib/galaxy/auth/.  
And maybe it is looking from that 
 File "/home/galaxy/galaxy-dist/lib/galaxy/auth/providers/ldap_ad.py", line 118, in authenticate
    ldap.set_option(*opt)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 135, in set_option
    return _ldap_function_call(None,_ldap.set_option,option,invalue)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 66, in _ldap_function_call
    result = func(*args,**kwargs)
ValueError: option error


Any one has this error ?

Mohamed


2017-02-24 9:47 GMT+01:00 Gildas Le Corguillé <[hidden email]>:
Hi Mohamed,

Have you try to remove (and backup if you want) the whole .venn folder?
Galaxy will create a new one with all its needs.

Best

Gildas

-----------------------------------------------------------------
Gildas Le Corguillé - Bioinformatician/Bioanalyste

Plateform ABiMS (Analyses and Bioinformatics for Marine Science)
http://abims.sb-roscoff.fr

Member of the Workflow4Metabolomics project
http://workflow4metabolomics.org

Station Biologique de Roscoff - UPMC/CNRS - FR2424
Place Georges Teissier 29680 Roscoff FRANCE
tel: <a moz-do-not-send="true" href="tel:02%2098%2029%2023%2081" value="+33298292381" target="_blank">+33 2 98 29 23 81
------------------------------------------------------------------



Le 24 févr. 2017 à 09:42, Mohamed Kassam <[hidden email]> a écrit :

Hello 
i tried to install via root and maybe it works, 

However now the bash run.sh it is working, however my ldap is not working I have password incorrect and I get this error in the terminal :

galaxy.auth.providers.ldap_ad ERROR 2017-02-24 10:52:24,672 LDAP authenticate: search exception
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/lib/galaxy/auth/providers/ldap_ad.py", line 118, in authenticate
    ldap.set_option(*opt)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 135, in set_option
    return _ldap_function_call(None,_ldap.set_option,option,invalue)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/ldap/functions.py", line 66, in _ldap_function_call
    result = func(*args,**kwargs)
ValueError: option error


Any idea ?

Thanks,

Mohamed

2017-02-24 9:11 GMT+01:00 Mohamed Kassam <[hidden email]>:
Dear all,

I have migrate my old version of Galaxy to the new release V17.01, And I am facing this error when I am running run.sh, any clue ?

Installing collected packages: python-ldap
  Found existing installation: python-ldap 2.4.17
    DEPRECATION: Uninstalling a distutils installed project (python-ldap) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will only partially uninstall the project.
    Can't uninstall 'python-ldap'. No files were found to uninstall.
  Can't roll back python-ldap; was not uninstalled
Exception:
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/commands/install.py", line 342, in run
    prefix=options.prefix_path,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_set.py", line 784, in install
    **kwargs
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 851, in install
    self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/req/req_install.py", line 1064, in move_wheel_files
    isolated=self.isolated,
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 345, in move_wheel_files
    clobber(source, lib_dir, True)
  File "/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/wheel.py", line 329, in clobber
    os.utime(destfile, (st.st_atime, st.st_mtime))
OSError: [Errno 1] Operation not permitted: '/home/galaxy/galaxy-dist/.venv/lib64/python2.7/site-packages/dsml.pyo'


Thanks,

Mohamed

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Loading...