nginx x-accel

classic Classic list List threaded Threaded
2 messages Options
| Threaded
Open this post in threaded view
|

nginx x-accel

Briand, Sheldon (NRC/CNRC)

Hi,

 

I have galaxy 16.10.  Whenever I try to download a file now nothing happens.  I have followed the configuration guide for nginx to allow it to handle file downloads.  However the nginx logs show that the file path has /etc/nginx/htmlTrue in front of the correct path.  Obviously I have a misconfiguration somewhere but I am not sure what the problem is.

 

Could someone point me in the right direction?

 

Thanks,

-Sheldon

 

Sheldon Briand

Computer Systems and Applications Analyst

National Research Council/Government of Canada

[hidden email] Tel: (902) 426-1677

 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: nginx x-accel

Briand, Sheldon (NRC/CNRC)

Hi,

 

My problem was due to an old configuration in my galaxy.ini file.

 

I had the following setting in my .ini but the correct setting earlier in the .ini file.

 

nginx_x_accel_redirect_base = true

 

I also had:

location /_x_accel_redirect/ {

            internal;

            root /;

        }

 

Instead of:

location /_x_accel_redirect/ {

            internal;

            alias /;

        }

 

In my nginx.conf file.

 

The alias directive needs to be there or the value in nginx_x_accel_redirect_base gets placed in front of the download directory.

 

Hopefully this helps someone else.

 

Thanks,

-Sheldon

 

From: Briand, Sheldon (NRC/CNRC)
Sent: Wednesday, February 15, 2017 2:01 PM
To: '[hidden email]' <[hidden email]>
Subject: nginx x-accel

 

Hi,

 

I have galaxy 16.10.  Whenever I try to download a file now nothing happens.  I have followed the configuration guide for nginx to allow it to handle file downloads.  However the nginx logs show that the file path has /etc/nginx/htmlTrue in front of the correct path.  Obviously I have a misconfiguration somewhere but I am not sure what the problem is.

 

Could someone point me in the right direction?

 

Thanks,

-Sheldon

 

Sheldon Briand

Computer Systems and Applications Analyst

National Research Council/Government of Canada

[hidden email] Tel: (902) 426-1677

 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/