package_r_xx problem: X11 is not available

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

package_r_xx problem: X11 is not available

Geert Vandeweyer-4
Hi all,

I installed to package_r_2.11 and r_3x from the devteam to use as tool
dependency. All installation goes fine, but when I run my tool I get the
following error:

Error in png(file = "../Plots/outname.png", bg = "white", width = 480,  :
   X11 is not available

The tool uses the installed R :
/galaxy/galaxy_tool_binaries/R/2.11.0/devteam/package_r_2_11_0/8d0a55bf7aaf/lib/R/bin/R

If I force the tool to use the system installed version of R, it works
fine. Are there packages available in the toolsheds that allow the 'png'
function to work? I already tried the R-packages from boris, but they
gave compilation errors... I also tried to install the R-png package
from cran as a galaxy dependency, but that didn't help either.


Thanks for the help,

Geert

--

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: package_r_xx problem: X11 is not available

Björn Grüning-3
Hi Geert,

I tried to update the R package to include the libpng dependency, if you
like to test it ...

http://testtoolshed.g2.bx.psu.edu/view/iuc/package_r_3_0_2

Do you know if cairo is really needed? If I can I would omit to have a
dependency on cairo :)

Cheers,
Bjoern

> Hi all,
>
> I installed to package_r_2.11 and r_3x from the devteam to use as tool
> dependency. All installation goes fine, but when I run my tool I get
> the following error:
>
> Error in png(file = "../Plots/outname.png", bg = "white", width = 480,  :
>   X11 is not available
>
> The tool uses the installed R :
> /galaxy/galaxy_tool_binaries/R/2.11.0/devteam/package_r_2_11_0/8d0a55bf7aaf/lib/R/bin/R
>
> If I force the tool to use the system installed version of R, it works
> fine. Are there packages available in the toolsheds that allow the
> 'png' function to work? I already tried the R-packages from boris, but
> they gave compilation errors... I also tried to install the R-png
> package from cran as a galaxy dependency, but that didn't help either.
>
>
> Thanks for the help,
>
> Geert
>

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: package_r_xx problem: X11 is not available

Geert Vandeweyer-4
hi,

The dependencies installed fine, but R itself gave this error:

configure: error: unrecognized option: `-I/galaxy/galaxy_tool_binaries/libpng/1.6.7/devteam/package_libpng_1_6_7/a0b0e0281cc4/include' Try `./configure --help' for more information


Any idea what might be wrong?

Best,

Geert


On 02/19/2014 12:55 PM, Björn Grüning wrote:
Hi Geert,

I tried to update the R package to include the libpng dependency, if you like to test it ...

http://testtoolshed.g2.bx.psu.edu/view/iuc/package_r_3_0_2

Do you know if cairo is really needed? If I can I would omit to have a dependency on cairo :)

Cheers,
Bjoern

Hi all,

I installed to package_r_2.11 and r_3x from the devteam to use as tool dependency. All installation goes fine, but when I run my tool I get the following error:

Error in png(file = "../Plots/outname.png", bg = "white", width = 480,  :
  X11 is not available

The tool uses the installed R : /galaxy/galaxy_tool_binaries/R/2.11.0/devteam/package_r_2_11_0/8d0a55bf7aaf/lib/R/bin/R

If I force the tool to use the system installed version of R, it works fine. Are there packages available in the toolsheds that allow the 'png' function to work? I already tried the R-packages from boris, but they gave compilation errors... I also tried to install the R-png package from cran as a galaxy dependency, but that didn't help either.


Thanks for the help,

Geert




-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: package_r_xx problem: X11 is not available

Björn Grüning-3

Hi Geert,

can you retest please, I had a typo. Unfortunately, I can't test it by myself since my internet connection is to bad here in Slovenia to download that R-tarball.

Sorry,
Bjoern

hi,

The dependencies installed fine, but R itself gave this error:

configure: error: unrecognized option: `-I/galaxy/galaxy_tool_binaries/libpng/1.6.7/devteam/package_libpng_1_6_7/a0b0e0281cc4/include' Try `./configure --help' for more information


Any idea what might be wrong?

Best,

Geert


On 02/19/2014 12:55 PM, Björn Grüning wrote:
Hi Geert,

I tried to update the R package to include the libpng dependency, if you like to test it ...

http://testtoolshed.g2.bx.psu.edu/view/iuc/package_r_3_0_2

Do you know if cairo is really needed? If I can I would omit to have a dependency on cairo :)

Cheers,
Bjoern

Hi all,

I installed to package_r_2.11 and r_3x from the devteam to use as tool dependency. All installation goes fine, but when I run my tool I get the following error:

Error in png(file = "../Plots/outname.png", bg = "white", width = 480,  :
  X11 is not available

The tool uses the installed R : /galaxy/galaxy_tool_binaries/R/2.11.0/devteam/package_r_2_11_0/8d0a55bf7aaf/lib/R/bin/R

If I force the tool to use the system installed version of R, it works fine. Are there packages available in the toolsheds that allow the 'png' function to work? I already tried the R-packages from boris, but they gave compilation errors... I also tried to install the R-png package from cran as a galaxy dependency, but that didn't help either.


Thanks for the help,

Geert




-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: package_r_xx problem: X11 is not available

Geert Vandeweyer-4
Hi,

Compilation/installing works now. Using this R from the commandline no longer complains about missing X. With regards to cairo, I don't think I explicitly need it, but as I understood it, it was used in case there was no X11 server on the system?

would you add it to the main toolshed? Then I can put is as a dependency on my tools that create plots from R (coverage_report), which has now the system version hardcoded.

Best,

Geert

On 02/20/2014 01:45 AM, Björn Grüning wrote:

Hi Geert,

can you retest please, I had a typo. Unfortunately, I can't test it by myself since my internet connection is to bad here in Slovenia to download that R-tarball.

Sorry,
Bjoern

hi,

The dependencies installed fine, but R itself gave this error:

configure: error: unrecognized option: `-I/galaxy/galaxy_tool_binaries/libpng/1.6.7/devteam/package_libpng_1_6_7/a0b0e0281cc4/include' Try `./configure --help' for more information


Any idea what might be wrong?

Best,

Geert


On 02/19/2014 12:55 PM, Björn Grüning wrote:
Hi Geert,

I tried to update the R package to include the libpng dependency, if you like to test it ...

http://testtoolshed.g2.bx.psu.edu/view/iuc/package_r_3_0_2

Do you know if cairo is really needed? If I can I would omit to have a dependency on cairo :)

Cheers,
Bjoern

Hi all,

I installed to package_r_2.11 and r_3x from the devteam to use as tool dependency. All installation goes fine, but when I run my tool I get the following error:

Error in png(file = "../Plots/outname.png", bg = "white", width = 480,  :
  X11 is not available

The tool uses the installed R : /galaxy/galaxy_tool_binaries/R/2.11.0/devteam/package_r_2_11_0/8d0a55bf7aaf/lib/R/bin/R

If I force the tool to use the system installed version of R, it works fine. Are there packages available in the toolsheds that allow the 'png' function to work? I already tried the R-packages from boris, but they gave compilation errors... I also tried to install the R-png package from cran as a galaxy dependency, but that didn't help either.


Thanks for the help,

Geert




-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer



-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: package_r_xx problem: X11 is not available

Björn Grüning-3
Hello,

Hi,

Compilation/installing works now. Using this R from the commandline no longer complains about missing X. With regards to cairo, I don't think I explicitly need it, but as I understood it, it was used in case there was no X11 server on the system?

Not sure, I will add it if anyone complains :)

would you add it to the main toolshed? Then I can put is as a dependency on my tools that create plots from R (coverage_report), which has now the system version hardcoded.

Done!
Thanks for testing!
Bjoern

Best,

Geert

On 02/20/2014 01:45 AM, Björn Grüning wrote:

Hi Geert,

can you retest please, I had a typo. Unfortunately, I can't test it by myself since my internet connection is to bad here in Slovenia to download that R-tarball.

Sorry,
Bjoern

hi,

The dependencies installed fine, but R itself gave this error:

configure: error: unrecognized option: `-I/galaxy/galaxy_tool_binaries/libpng/1.6.7/devteam/package_libpng_1_6_7/a0b0e0281cc4/include' Try `./configure --help' for more information


Any idea what might be wrong?

Best,

Geert


On 02/19/2014 12:55 PM, Björn Grüning wrote:
Hi Geert,

I tried to update the R package to include the libpng dependency, if you like to test it ...

http://testtoolshed.g2.bx.psu.edu/view/iuc/package_r_3_0_2

Do you know if cairo is really needed? If I can I would omit to have a dependency on cairo :)

Cheers,
Bjoern

Hi all,

I installed to package_r_2.11 and r_3x from the devteam to use as tool dependency. All installation goes fine, but when I run my tool I get the following error:

Error in png(file = "../Plots/outname.png", bg = "white", width = 480,  :
  X11 is not available

The tool uses the installed R : /galaxy/galaxy_tool_binaries/R/2.11.0/devteam/package_r_2_11_0/8d0a55bf7aaf/lib/R/bin/R

If I force the tool to use the system installed version of R, it works fine. Are there packages available in the toolsheds that allow the 'png' function to work? I already tried the R-packages from boris, but they gave compilation errors... I also tried to install the R-png package from cran as a galaxy dependency, but that didn't help either.


Thanks for the help,

Geert




-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer



-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: libpng (devteam) install fails

Geert Vandeweyer-4
Hi Bjoern & devteam members,

I tried to install R_3_0_2 iuc version  from the main toolshed, but got an error from the package_libpng from the devteam. I checked between the working tool_dependency from the testtoolshed and the failing one from the main.

working:
              <action type="download_by_url">http://downloads.sourceforge.net/project/libpng/libpng16/older-releases/1.6.7/libpng-1.6.7.tar.gz</action>

failing :
              <action type="download_by_url">http://downloads.sourceforge.net/project/libpng/libpng16/1.6.7/libpng-1.6.7.tar.gz</action>

The package_libpng from the devteam is downloading a different version on test and main.

Best,

Geert




On 02/20/2014 12:56 PM, Björn Grüning wrote:
Hello,

Hi,

Compilation/installing works now. Using this R from the commandline no longer complains about missing X. With regards to cairo, I don't think I explicitly need it, but as I understood it, it was used in case there was no X11 server on the system?

Not sure, I will add it if anyone complains :)

would you add it to the main toolshed? Then I can put is as a dependency on my tools that create plots from R (coverage_report), which has now the system version hardcoded.

Done!
Thanks for testing!
Bjoern

Best,

Geert

On 02/20/2014 01:45 AM, Björn Grüning wrote:

Hi Geert,

can you retest please, I had a typo. Unfortunately, I can't test it by myself since my internet connection is to bad here in Slovenia to download that R-tarball.

Sorry,
Bjoern

hi,

The dependencies installed fine, but R itself gave this error:

configure: error: unrecognized option: `-I/galaxy/galaxy_tool_binaries/libpng/1.6.7/devteam/package_libpng_1_6_7/a0b0e0281cc4/include' Try `./configure --help' for more information


Any idea what might be wrong?

Best,

Geert


On 02/19/2014 12:55 PM, Björn Grüning wrote:
Hi Geert,

I tried to update the R package to include the libpng dependency, if you like to test it ...

http://testtoolshed.g2.bx.psu.edu/view/iuc/package_r_3_0_2

Do you know if cairo is really needed? If I can I would omit to have a dependency on cairo :)

Cheers,
Bjoern

Hi all,

I installed to package_r_2.11 and r_3x from the devteam to use as tool dependency. All installation goes fine, but when I run my tool I get the following error:

Error in png(file = "../Plots/outname.png", bg = "white", width = 480,  :
  X11 is not available

The tool uses the installed R : /galaxy/galaxy_tool_binaries/R/2.11.0/devteam/package_r_2_11_0/8d0a55bf7aaf/lib/R/bin/R

If I force the tool to use the system installed version of R, it works fine. Are there packages available in the toolsheds that allow the 'png' function to work? I already tried the R-packages from boris, but they gave compilation errors... I also tried to install the R-png package from cran as a galaxy dependency, but that didn't help either.


Thanks for the help,

Geert




-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer



-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer



-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Reply | Threaded
Open this post in threaded view
|

Re: libpng (devteam) install fails

Greg Von Kuster
Hi Geert,

Thanks for letting us know - I've added the folllowing Trello card for this and we'll get it fixed asap.


Greg Von Kuster


On Feb 20, 2014, at 5:10 PM, Geert Vandeweyer <[hidden email]> wrote:

Hi Bjoern & devteam members,

I tried to install R_3_0_2 iuc version  from the main toolshed, but got an error from the package_libpng from the devteam. I checked between the working tool_dependency from the testtoolshed and the failing one from the main.

working:
              <action type="download_by_url">http://downloads.sourceforge.net/project/libpng/libpng16/older-releases/1.6.7/libpng-1.6.7.tar.gz</action>

failing :
              <action type="download_by_url">http://downloads.sourceforge.net/project/libpng/libpng16/1.6.7/libpng-1.6.7.tar.gz</action>

The package_libpng from the devteam is downloading a different version on test and main.

Best,

Geert




On 02/20/2014 12:56 PM, Björn Grüning wrote:
Hello,

Hi,

Compilation/installing works now. Using this R from the commandline no longer complains about missing X. With regards to cairo, I don't think I explicitly need it, but as I understood it, it was used in case there was no X11 server on the system?

Not sure, I will add it if anyone complains :)

would you add it to the main toolshed? Then I can put is as a dependency on my tools that create plots from R (coverage_report), which has now the system version hardcoded.

Done!
Thanks for testing!
Bjoern

Best,

Geert

On 02/20/2014 01:45 AM, Björn Grüning wrote:

Hi Geert,

can you retest please, I had a typo. Unfortunately, I can't test it by myself since my internet connection is to bad here in Slovenia to download that R-tarball.

Sorry,
Bjoern

hi,

The dependencies installed fine, but R itself gave this error:

configure: error: unrecognized option: `-I/galaxy/galaxy_tool_binaries/libpng/1.6.7/devteam/package_libpng_1_6_7/a0b0e0281cc4/include' Try `./configure --help' for more information


Any idea what might be wrong?

Best,

Geert


On 02/19/2014 12:55 PM, Björn Grüning wrote:
Hi Geert,

I tried to update the R package to include the libpng dependency, if you like to test it ...

http://testtoolshed.g2.bx.psu.edu/view/iuc/package_r_3_0_2

Do you know if cairo is really needed? If I can I would omit to have a dependency on cairo :)

Cheers,
Bjoern

Hi all,

I installed to package_r_2.11 and r_3x from the devteam to use as tool dependency. All installation goes fine, but when I run my tool I get the following error:

Error in png(file = "../Plots/outname.png", bg = "white", width = 480,  :
  X11 is not available

The tool uses the installed R : /galaxy/galaxy_tool_binaries/R/2.11.0/devteam/package_r_2_11_0/8d0a55bf7aaf/lib/R/bin/R

If I force the tool to use the system installed version of R, it works fine. Are there packages available in the toolsheds that allow the 'png' function to work? I already tried the R-packages from boris, but they gave compilation errors... I also tried to install the R-png package from cran as a galaxy dependency, but that didn't help either.


Thanks for the help,

Geert




-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer



-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer



-- 

Geert Vandeweyer, Ph.D.
Department of Medical Genetics
University of Antwerp
Prins Boudewijnlaan 43
2650 Edegem
Belgium
Tel: +32 (0)3 275 97 56
E-mail: [hidden email]
http://ua.ac.be/cognitivegenetics
http://www.linkedin.com/in/geertvandeweyer
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/