planemo/toolshed error, assistance request

classic Classic list List threaded Threaded
2 messages Options
| Threaded
Open this post in threaded view
|

planemo/toolshed error, assistance request

Dennis, H. E. Cicada Brokaw

Hello,


I am having a problem using planemo to upload a suite of tools into the testtoolshed. The tools at this point are all in the toolshed from using the shed_create and shed_update commands in the suite directory. However, along the way there were some errors in uploading some of the tools that I had to fix. Those are all fixed and all the tools show as up to date, except for the suite, which is returning the following error message, about which I have no idea what to do (and I have tried a lot of different things):


The repository_dependencies.xml file contains an invalid <repository> tag. Invalid latest installable changeset_revision 000000000000 retrieved for repository ctat_metagenomics owned by trinity_ctat.


Does anyone have an idea of what to do to fix this?
Thanks,

Cicada Dennis


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/
| Threaded
Open this post in threaded view
|

Re: planemo/toolshed error, assistance request

Dave Bouvier
Cicada,

It appears that the ctat_metagenomics repository does exist, so that's
not causing the problem. To simplify debugging this error, could you
send me your repository_dependencies.xml file or a link to a gist?

-
Dave Bouvier
http://galaxyproject.org
http://usegalaxy.org

On 04/13/2018 06:27 AM, Dennis, H. E. Cicada Brokaw wrote:

> Hello,
>
>
> I am having a problem using planemo to upload a suite of tools into the
> testtoolshed. The tools at this point are all in the toolshed from using
> the shed_create and shed_update commands in the suite directory.
> However, along the way there were some errors in uploading some of the
> tools that I had to fix. Those are all fixed and all the tools show as
> up to date, except for the suite, which is returning the following error
> message, about which I have no idea what to do (and I have tried a lot
> of different things):
>
>
> The repository_dependencies.xml file contains an invalid <repository>
> tag. Invalid latest installable changeset_revision 000000000000
> retrieved for repository ctat_metagenomics owned by trinity_ctat.
>
>
> Does anyone have an idea of what to do to fix this?
> Thanks,
>
> Cicada Dennis
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>    https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>    http://galaxyproject.org/search/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/