Quantcast

tmp file under database/tmp get regenerated after restarting Galaxy

classic Classic list List threaded Threaded
2 messages Options
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

tmp file under database/tmp get regenerated after restarting Galaxy

Mark Xiao
Dear Galaxy Developers,

I am using Galaxy version 15.10 on my server, load-balancing is enabled. I found a problem when running the jobs. When there are running jobs and if I restart the Galaxy process at this time, the job will fail at the end of the job with the error message such as:

IOError: [Errno 2] No such file or directory: '/galaxy/database/tmp/tmpleXN4b'


That tmp file doesn't exist, I guess it is because when Galaxy process get restarted, the tmp file get regenerated, so the job cannot find the correct tmp file, then it was failed. Do you think this is a known issue, and is there a fix for this?

Thank you in advance!
MarkĀ 

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: tmp file under database/tmp get regenerated after restarting Galaxy

Mark Xiao
Hi,

Just want to follow up this request. We hope to have some tips about how to investigate this problem. Because of this issue, we cannot restart Galaxy when there are running jobs.

Thanks,
Mark

2016-11-15 16:52 GMT-06:00 Mark Xiao <[hidden email]>:
Dear Galaxy Developers,

I am using Galaxy version 15.10 on my server, load-balancing is enabled. I found a problem when running the jobs. When there are running jobs and if I restart the Galaxy process at this time, the job will fail at the end of the job with the error message such as:

IOError: [Errno 2] No such file or directory: '/galaxy/database/tmp/tmpleXN4b'


That tmp file doesn't exist, I guess it is because when Galaxy process get restarted, the tmp file get regenerated, so the job cannot find the correct tmp file, then it was failed. Do you think this is a known issue, and is there a fix for this?

Thank you in advance!
MarkĀ 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
Loading...