tool_shed question on multiple tool versions

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

tool_shed question on multiple tool versions

Rui Wang
Hi Guys,

Sorry for the duplicate posting...nobody saw my original one seems and I'm still wondering what the proper way is. I searched around the wiki but didn't find much.

Originally, I installed macs dependency for galaxy myself. The version is 1.4.2. It worked well. 

Now, after galaxy upgrading removed it, and I installed it back from tool_shed, things broke. In the galaxy tool panel, it looks the same like before(as expected), but when I click on macs, it will show an option of MACS 'version 1.0.0' and 'version 1.0.1'. Be default it is 1.0.1, which is defined in migrated_tools_conf.xml:

<section id="peak_calling" name="NGS: Peak Calling" version="">
      <tool_shed>toolshed.g2.bx.psu.edu</tool_shed>
        <repository_name>macs</repository_name>
        <repository_owner>devteam</repository_owner>
        <installed_changeset_revision>ae2ec275332a</installed_changeset_revision>
        <version>1.0.1</version>
    </tool>
</section>

if we dive in this file toolshed.g2.bx.psu.edu/repos/devteam/macs/ae2ec275332a/macs/macs_wrapper.xml, we could see that in this dir /home/bioinfoadmin/app/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/macs/ae2ec275332a/macs, there is a tool_dependency xml file that has following content:

<?xml version="1.0"?>
<tool_dependency>
  <package name="macs" version="1.3.7.1">
      <repository changeset_revision="a7ea583a35d2" name="package_macs_1_3_7_1" owner="devteam" prior_installation_required="False" toolshed="http://toolshed.g2.bx.psu.edu" />
    </package>
    <package name="R" version="2.15.0">
      <repository changeset_revision="8ab0d08a3da1" name="package_r_2_15_0" owner="devteam" prior_installation_required="False" toolshed="http://toolshed.g2.bx.psu.edu" />
    </package>
</tool_dependency>

These versions are both older than what we installed before(1.4.2 and 3.0.2). could we manually modify that to use our own? wouldn't that be a bad practice?

while in the same dir, macs_wrapper.xml has:

  <requirements>
    <requirement type="package" version="1.3.7.1">macs</requirement>
    <requirement type="package" version="2.15.0">R</requirement>
  </requirements>

Seems that this is the tool_shed version of macs(which is identical to the one on main galaxy server, I think?). However this one does not work with our input data. Additionally, when I click to switch from 1.0.1 to 1.0.0 of macs, it immediately reports error. 

So, what if I want to keep using the one I installed myself? I know that tool_shed is a cleaner way to manage tools, but in our situation the upgrade and elimination actually broke the thing that worked before. I want to ask the proper way to handle this kind of situation. could I simply drop the entry from migrated_tools_conf.xml about macs, and restore the old tools_conf.xml entry? in that way we could continue using the 1.4.2 we have. However next time when we do the upgrade, things will break again I guess? 

I think that I shouldn't be the only person that has this concern? how to handle multiple version/dependency version for a tool? is there an option to not use the tool_shed but keep own version?

Thanks,
Rui

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/