trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

classic Classic list List threaded Threaded
12 messages Options
| Threaded
Open this post in threaded view
|

trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Shu-Yi Su
Hi all,

We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
./static/scripts/viz/trackster.js (commits date: 2014-02-28)
./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
./static/scripts/utils/utils.js (commits date: 2014-03-19)
./static/scripts/utils/config.js (commits date: 2014-03-15)

But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
I looked into all possible files I can think about that might cause the problems but still don't have any clues. 
I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
The log where the trackster is not working:
1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda 

The log where the trackster is working (from the old installation):
1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..

It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.

Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)

Any ideas or suggestions are appreciated.

Thank you very much.

Best,
Shu-Yi



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Jeremy Goecks-4
Providing some additional information will help diagnose the problem:

*are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
*which Web browser are you using?
*can you please open the JavaScript console in your browser and provide any errors that you see?

Thanks,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:

Hi all,

We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
./static/scripts/viz/trackster.js (commits date: 2014-02-28)
./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
./static/scripts/utils/utils.js (commits date: 2014-03-19)
./static/scripts/utils/config.js (commits date: 2014-03-15)

But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
I looked into all possible files I can think about that might cause the problems but still don't have any clues. 
I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
The log where the trackster is not working:
1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda 

The log where the trackster is working (from the old installation):
1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..

It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.

Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)

Any ideas or suggestions are appreciated.

Thank you very much.

Best,
Shu-Yi

<PastedGraphic-1.tiff>

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Shu-Yi Su
Hi Jeremy,

Thank you very much for the reply.

Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
I have tried safari and firefox. Both are not working.
Here is the error massage from console:
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
[Error] Error: Script error for: libs/backbone/backbone-relational
defaultOnError (require.js, line 1)
onError (require.js, line 1)
onScriptError (require.js, line 1)
[Error] Error: Script error for: utils/galaxy.utils
defaultOnError (require.js, line 1)
onError (require.js, line 1)
onScriptError (require.js, line 1);;;

We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.

Thank you.

Best,
Shu-Yi


On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:

Providing some additional information will help diagnose the problem:

*are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
*which Web browser are you using?
*can you please open the JavaScript console in your browser and provide any errors that you see?

Thanks,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:

Hi all,

We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
./static/scripts/viz/trackster.js (commits date: 2014-02-28)
./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
./static/scripts/utils/utils.js (commits date: 2014-03-19)
./static/scripts/utils/config.js (commits date: 2014-03-15)

But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
I looked into all possible files I can think about that might cause the problems but still don't have any clues. 
I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
The log where the trackster is not working:
1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda 

The log where the trackster is working (from the old installation):
1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..

It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.

Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)

Any ideas or suggestions are appreciated.

Thank you very much.

Best,
Shu-Yi

<PastedGraphic-1.tiff>

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Charles Girardot
Hi Jeremy,

After checking, the two js scripts are absent from the release:

backbone-relational.js ( static/scripts/packed/libs/backbone/ )
galaxy.utils.js ( static/scripts/packed/utils/ )

bw

C

On 25 Mar 2014, at 16:16, Shu-Yi Su wrote:

> Hi Jeremy,
>
> Thank you very much for the reply.
>
> Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
> I have tried safari and firefox. Both are not working.
> Here is the error massage from console:
> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
> [Error] Error: Script error for: libs/backbone/backbone-relational
> http://requirejs.org/docs/errors.html#scripterror
> defaultOnError (require.js, line 1)
> onError (require.js, line 1)
> onScriptError (require.js, line 1)
> [Error] Error: Script error for: utils/galaxy.utils
> http://requirejs.org/docs/errors.html#scripterror
> defaultOnError (require.js, line 1)
> onError (require.js, line 1)
> onScriptError (require.js, line 1);;;
>
> We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.
>
> Thank you.
>
> Best,
> Shu-Yi
>
>
> On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:
>
>> Providing some additional information will help diagnose the problem:
>>
>> *are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
>> *which Web browser are you using?
>> *can you please open the JavaScript console in your browser and provide any errors that you see?
>>
>> Thanks,
>> J.
>>
>> --
>> Jeremy Goecks
>> Assistant Professor of Computational Biology
>> George Washington University
>>
>>
>>
>> On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:
>>
>>> Hi all,
>>>
>>> We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
>>> ./static/scripts/viz/trackster.js (commits date: 2014-02-28)
>>> ./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
>>> ./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
>>> ./static/scripts/utils/utils.js (commits date: 2014-03-19)
>>> ./static/scripts/utils/config.js (commits date: 2014-03-15)
>>>
>>> But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
>>> I looked into all possible files I can think about that might cause the problems but still don't have any clues.
>>> I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
>>> The log where the trackster is not working:
>>> 1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda
>>>
>>> The log where the trackster is working (from the old installation):
>>> 1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
>>> 2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
>>> 3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..
>>>
>>> It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.
>>>
>>> Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)
>>>
>>> Any ideas or suggestions are appreciated.
>>>
>>> Thank you very much.
>>>
>>> Best,
>>> Shu-Yi
>>>
>>> <PastedGraphic-1.tiff>
>>>
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>>  http://lists.bx.psu.edu/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>>  http://galaxyproject.org/search/mailinglists/
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>  http://lists.bx.psu.edu/
>>
>> To search Galaxy mailing lists use the unified search at:
>>  http://galaxyproject.org/search/mailinglists/
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>  http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Jeremy Goecks-4
This sounds like a cache issue. Both of these scripts have been removed from the distribution, so they should be absent from the distribution. Can you try clearing your cache and see if that fixes the issue?

Thanks,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 26, 2014, at 4:39 AM, Charles Girardot <[hidden email]> wrote:

> Hi Jeremy,
>
> After checking, the two js scripts are absent from the release:
>
> backbone-relational.js ( static/scripts/packed/libs/backbone/ )
> galaxy.utils.js ( static/scripts/packed/utils/ )
>
> bw
>
> C
>
> On 25 Mar 2014, at 16:16, Shu-Yi Su wrote:
>
>> Hi Jeremy,
>>
>> Thank you very much for the reply.
>>
>> Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
>> I have tried safari and firefox. Both are not working.
>> Here is the error massage from console:
>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
>> [Error] Error: Script error for: libs/backbone/backbone-relational
>> http://requirejs.org/docs/errors.html#scripterror
>> defaultOnError (require.js, line 1)
>> onError (require.js, line 1)
>> onScriptError (require.js, line 1)
>> [Error] Error: Script error for: utils/galaxy.utils
>> http://requirejs.org/docs/errors.html#scripterror
>> defaultOnError (require.js, line 1)
>> onError (require.js, line 1)
>> onScriptError (require.js, line 1);;;
>>
>> We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.
>>
>> Thank you.
>>
>> Best,
>> Shu-Yi
>>
>>
>> On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:
>>
>>> Providing some additional information will help diagnose the problem:
>>>
>>> *are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
>>> *which Web browser are you using?
>>> *can you please open the JavaScript console in your browser and provide any errors that you see?
>>>
>>> Thanks,
>>> J.
>>>
>>> --
>>> Jeremy Goecks
>>> Assistant Professor of Computational Biology
>>> George Washington University
>>>
>>>
>>>
>>> On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:
>>>
>>>> Hi all,
>>>>
>>>> We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
>>>> ./static/scripts/viz/trackster.js (commits date: 2014-02-28)
>>>> ./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
>>>> ./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
>>>> ./static/scripts/utils/utils.js (commits date: 2014-03-19)
>>>> ./static/scripts/utils/config.js (commits date: 2014-03-15)
>>>>
>>>> But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
>>>> I looked into all possible files I can think about that might cause the problems but still don't have any clues.
>>>> I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
>>>> The log where the trackster is not working:
>>>> 1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda
>>>>
>>>> The log where the trackster is working (from the old installation):
>>>> 1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
>>>> 2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
>>>> 3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..
>>>>
>>>> It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.
>>>>
>>>> Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)
>>>>
>>>> Any ideas or suggestions are appreciated.
>>>>
>>>> Thank you very much.
>>>>
>>>> Best,
>>>> Shu-Yi
>>>>
>>>> <PastedGraphic-1.tiff>
>>>>
>>>> ___________________________________________________________
>>>> Please keep all replies on the list by using "reply all"
>>>> in your mail client.  To manage your subscriptions to this
>>>> and other Galaxy lists, please use the interface at:
>>>> http://lists.bx.psu.edu/
>>>>
>>>> To search Galaxy mailing lists use the unified search at:
>>>> http://galaxyproject.org/search/mailinglists/
>>>
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>> http://lists.bx.psu.edu/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>> http://galaxyproject.org/search/mailinglists/
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>> http://lists.bx.psu.edu/
>>
>> To search Galaxy mailing lists use the unified search at:
>> http://galaxyproject.org/search/mailinglists/
>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Shu-Yi Su
Hi Jeremy,

I cleaned the catche on both safari and firefox, but it doesn't work. It still shows the same error messages.

Thank you very much for the help!!

Best,
Shu-Yi

On Mar 26, 2014, at 2:00 PM, Jeremy Goecks wrote:

> This sounds like a cache issue. Both of these scripts have been removed from the distribution, so they should be absent from the distribution. Can you try clearing your cache and see if that fixes the issue?
>
> Thanks,
> J.
>
> --
> Jeremy Goecks
> Assistant Professor of Computational Biology
> George Washington University
>
>
>
> On Mar 26, 2014, at 4:39 AM, Charles Girardot <[hidden email]> wrote:
>
>> Hi Jeremy,
>>
>> After checking, the two js scripts are absent from the release:
>>
>> backbone-relational.js ( static/scripts/packed/libs/backbone/ )
>> galaxy.utils.js ( static/scripts/packed/utils/ )
>>
>> bw
>>
>> C
>>
>> On 25 Mar 2014, at 16:16, Shu-Yi Su wrote:
>>
>>> Hi Jeremy,
>>>
>>> Thank you very much for the reply.
>>>
>>> Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
>>> I have tried safari and firefox. Both are not working.
>>> Here is the error massage from console:
>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
>>> [Error] Error: Script error for: libs/backbone/backbone-relational
>>> http://requirejs.org/docs/errors.html#scripterror
>>> defaultOnError (require.js, line 1)
>>> onError (require.js, line 1)
>>> onScriptError (require.js, line 1)
>>> [Error] Error: Script error for: utils/galaxy.utils
>>> http://requirejs.org/docs/errors.html#scripterror
>>> defaultOnError (require.js, line 1)
>>> onError (require.js, line 1)
>>> onScriptError (require.js, line 1);;;
>>>
>>> We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.
>>>
>>> Thank you.
>>>
>>> Best,
>>> Shu-Yi
>>>
>>>
>>> On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:
>>>
>>>> Providing some additional information will help diagnose the problem:
>>>>
>>>> *are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
>>>> *which Web browser are you using?
>>>> *can you please open the JavaScript console in your browser and provide any errors that you see?
>>>>
>>>> Thanks,
>>>> J.
>>>>
>>>> --
>>>> Jeremy Goecks
>>>> Assistant Professor of Computational Biology
>>>> George Washington University
>>>>
>>>>
>>>>
>>>> On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:
>>>>
>>>>> Hi all,
>>>>>
>>>>> We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
>>>>> ./static/scripts/viz/trackster.js (commits date: 2014-02-28)
>>>>> ./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
>>>>> ./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
>>>>> ./static/scripts/utils/utils.js (commits date: 2014-03-19)
>>>>> ./static/scripts/utils/config.js (commits date: 2014-03-15)
>>>>>
>>>>> But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
>>>>> I looked into all possible files I can think about that might cause the problems but still don't have any clues.
>>>>> I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
>>>>> The log where the trackster is not working:
>>>>> 1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda
>>>>>
>>>>> The log where the trackster is working (from the old installation):
>>>>> 1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
>>>>> 2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
>>>>> 3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..
>>>>>
>>>>> It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.
>>>>>
>>>>> Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)
>>>>>
>>>>> Any ideas or suggestions are appreciated.
>>>>>
>>>>> Thank you very much.
>>>>>
>>>>> Best,
>>>>> Shu-Yi
>>>>>
>>>>> <PastedGraphic-1.tiff>
>>>>>
>>>>> ___________________________________________________________
>>>>> Please keep all replies on the list by using "reply all"
>>>>> in your mail client.  To manage your subscriptions to this
>>>>> and other Galaxy lists, please use the interface at:
>>>>> http://lists.bx.psu.edu/
>>>>>
>>>>> To search Galaxy mailing lists use the unified search at:
>>>>> http://galaxyproject.org/search/mailinglists/
>>>>
>>>> ___________________________________________________________
>>>> Please keep all replies on the list by using "reply all"
>>>> in your mail client.  To manage your subscriptions to this
>>>> and other Galaxy lists, please use the interface at:
>>>> http://lists.bx.psu.edu/
>>>>
>>>> To search Galaxy mailing lists use the unified search at:
>>>> http://galaxyproject.org/search/mailinglists/
>>>
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>> http://lists.bx.psu.edu/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>> http://galaxyproject.org/search/mailinglists/
>>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>  http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Jeremy Goecks-4
The next step then is to revert all the changes that you pulled from -central and report back the errors you’re seeing. Manually pulling selected change sets can be problematic if you don’t get all the dependencies.

Best,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 26, 2014, at 11:04 AM, Shu-Yi Su <[hidden email]> wrote:

> Hi Jeremy,
>
> I cleaned the catche on both safari and firefox, but it doesn't work. It still shows the same error messages.
>
> Thank you very much for the help!!
>
> Best,
> Shu-Yi
>
> On Mar 26, 2014, at 2:00 PM, Jeremy Goecks wrote:
>
>> This sounds like a cache issue. Both of these scripts have been removed from the distribution, so they should be absent from the distribution. Can you try clearing your cache and see if that fixes the issue?
>>
>> Thanks,
>> J.
>>
>> --
>> Jeremy Goecks
>> Assistant Professor of Computational Biology
>> George Washington University
>>
>>
>>
>> On Mar 26, 2014, at 4:39 AM, Charles Girardot <[hidden email]> wrote:
>>
>>> Hi Jeremy,
>>>
>>> After checking, the two js scripts are absent from the release:
>>>
>>> backbone-relational.js ( static/scripts/packed/libs/backbone/ )
>>> galaxy.utils.js ( static/scripts/packed/utils/ )
>>>
>>> bw
>>>
>>> C
>>>
>>> On 25 Mar 2014, at 16:16, Shu-Yi Su wrote:
>>>
>>>> Hi Jeremy,
>>>>
>>>> Thank you very much for the reply.
>>>>
>>>> Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
>>>> I have tried safari and firefox. Both are not working.
>>>> Here is the error massage from console:
>>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
>>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
>>>> [Error] Error: Script error for: libs/backbone/backbone-relational
>>>> http://requirejs.org/docs/errors.html#scripterror
>>>> defaultOnError (require.js, line 1)
>>>> onError (require.js, line 1)
>>>> onScriptError (require.js, line 1)
>>>> [Error] Error: Script error for: utils/galaxy.utils
>>>> http://requirejs.org/docs/errors.html#scripterror
>>>> defaultOnError (require.js, line 1)
>>>> onError (require.js, line 1)
>>>> onScriptError (require.js, line 1);;;
>>>>
>>>> We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.
>>>>
>>>> Thank you.
>>>>
>>>> Best,
>>>> Shu-Yi
>>>>
>>>>
>>>> On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:
>>>>
>>>>> Providing some additional information will help diagnose the problem:
>>>>>
>>>>> *are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
>>>>> *which Web browser are you using?
>>>>> *can you please open the JavaScript console in your browser and provide any errors that you see?
>>>>>
>>>>> Thanks,
>>>>> J.
>>>>>
>>>>> --
>>>>> Jeremy Goecks
>>>>> Assistant Professor of Computational Biology
>>>>> George Washington University
>>>>>
>>>>>
>>>>>
>>>>> On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:
>>>>>
>>>>>> Hi all,
>>>>>>
>>>>>> We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
>>>>>> ./static/scripts/viz/trackster.js (commits date: 2014-02-28)
>>>>>> ./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
>>>>>> ./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
>>>>>> ./static/scripts/utils/utils.js (commits date: 2014-03-19)
>>>>>> ./static/scripts/utils/config.js (commits date: 2014-03-15)
>>>>>>
>>>>>> But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
>>>>>> I looked into all possible files I can think about that might cause the problems but still don't have any clues.
>>>>>> I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
>>>>>> The log where the trackster is not working:
>>>>>> 1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda
>>>>>>
>>>>>> The log where the trackster is working (from the old installation):
>>>>>> 1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
>>>>>> 2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
>>>>>> 3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..
>>>>>>
>>>>>> It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.
>>>>>>
>>>>>> Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)
>>>>>>
>>>>>> Any ideas or suggestions are appreciated.
>>>>>>
>>>>>> Thank you very much.
>>>>>>
>>>>>> Best,
>>>>>> Shu-Yi
>>>>>>
>>>>>> <PastedGraphic-1.tiff>
>>>>>>
>>>>>> ___________________________________________________________
>>>>>> Please keep all replies on the list by using "reply all"
>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>> and other Galaxy lists, please use the interface at:
>>>>>> http://lists.bx.psu.edu/
>>>>>>
>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>> http://galaxyproject.org/search/mailinglists/
>>>>>
>>>>> ___________________________________________________________
>>>>> Please keep all replies on the list by using "reply all"
>>>>> in your mail client.  To manage your subscriptions to this
>>>>> and other Galaxy lists, please use the interface at:
>>>>> http://lists.bx.psu.edu/
>>>>>
>>>>> To search Galaxy mailing lists use the unified search at:
>>>>> http://galaxyproject.org/search/mailinglists/
>>>>
>>>> ___________________________________________________________
>>>> Please keep all replies on the list by using "reply all"
>>>> in your mail client.  To manage your subscriptions to this
>>>> and other Galaxy lists, please use the interface at:
>>>> http://lists.bx.psu.edu/
>>>>
>>>> To search Galaxy mailing lists use the unified search at:
>>>> http://galaxyproject.org/search/mailinglists/
>>>
>>
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>> http://lists.bx.psu.edu/
>>
>> To search Galaxy mailing lists use the unified search at:
>> http://galaxyproject.org/search/mailinglists/
>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Shu-Yi Su
Hi Jeremy,

I reverted the files that I have changed, and also cleaned the cache once again.  The error messages are the same:

Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:1:1910Error: Script error for: libs/backbone/backbone-relational
http://requirejs.org/docs/errors.html#scripterror
http://gbcs-dev/galaxy-dev/static/scripts/utils/galaxy.utils.jsFailed to load resource: the server responded with a status of 404 (Not Found)
require.js:1:1910Error: Script error for: utils/galaxy.utils
http://requirejs.org/docs/errors.html#scripterror

Thanks a lot…..

Best,
Shu-Yi

On Mar 27, 2014, at 12:00 AM, Jeremy Goecks wrote:

> The next step then is to revert all the changes that you pulled from -central and report back the errors you’re seeing. Manually pulling selected change sets can be problematic if you don’t get all the dependencies.
>
> Best,
> J.
>
> --
> Jeremy Goecks
> Assistant Professor of Computational Biology
> George Washington University
>
>
>
> On Mar 26, 2014, at 11:04 AM, Shu-Yi Su <[hidden email]> wrote:
>
>> Hi Jeremy,
>>
>> I cleaned the catche on both safari and firefox, but it doesn't work. It still shows the same error messages.
>>
>> Thank you very much for the help!!
>>
>> Best,
>> Shu-Yi
>>
>> On Mar 26, 2014, at 2:00 PM, Jeremy Goecks wrote:
>>
>>> This sounds like a cache issue. Both of these scripts have been removed from the distribution, so they should be absent from the distribution. Can you try clearing your cache and see if that fixes the issue?
>>>
>>> Thanks,
>>> J.
>>>
>>> --
>>> Jeremy Goecks
>>> Assistant Professor of Computational Biology
>>> George Washington University
>>>
>>>
>>>
>>> On Mar 26, 2014, at 4:39 AM, Charles Girardot <[hidden email]> wrote:
>>>
>>>> Hi Jeremy,
>>>>
>>>> After checking, the two js scripts are absent from the release:
>>>>
>>>> backbone-relational.js ( static/scripts/packed/libs/backbone/ )
>>>> galaxy.utils.js ( static/scripts/packed/utils/ )
>>>>
>>>> bw
>>>>
>>>> C
>>>>
>>>> On 25 Mar 2014, at 16:16, Shu-Yi Su wrote:
>>>>
>>>>> Hi Jeremy,
>>>>>
>>>>> Thank you very much for the reply.
>>>>>
>>>>> Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
>>>>> I have tried safari and firefox. Both are not working.
>>>>> Here is the error massage from console:
>>>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
>>>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
>>>>> [Error] Error: Script error for: libs/backbone/backbone-relational
>>>>> http://requirejs.org/docs/errors.html#scripterror
>>>>> defaultOnError (require.js, line 1)
>>>>> onError (require.js, line 1)
>>>>> onScriptError (require.js, line 1)
>>>>> [Error] Error: Script error for: utils/galaxy.utils
>>>>> http://requirejs.org/docs/errors.html#scripterror
>>>>> defaultOnError (require.js, line 1)
>>>>> onError (require.js, line 1)
>>>>> onScriptError (require.js, line 1);;;
>>>>>
>>>>> We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.
>>>>>
>>>>> Thank you.
>>>>>
>>>>> Best,
>>>>> Shu-Yi
>>>>>
>>>>>
>>>>> On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:
>>>>>
>>>>>> Providing some additional information will help diagnose the problem:
>>>>>>
>>>>>> *are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
>>>>>> *which Web browser are you using?
>>>>>> *can you please open the JavaScript console in your browser and provide any errors that you see?
>>>>>>
>>>>>> Thanks,
>>>>>> J.
>>>>>>
>>>>>> --
>>>>>> Jeremy Goecks
>>>>>> Assistant Professor of Computational Biology
>>>>>> George Washington University
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:
>>>>>>
>>>>>>> Hi all,
>>>>>>>
>>>>>>> We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
>>>>>>> ./static/scripts/viz/trackster.js (commits date: 2014-02-28)
>>>>>>> ./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
>>>>>>> ./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
>>>>>>> ./static/scripts/utils/utils.js (commits date: 2014-03-19)
>>>>>>> ./static/scripts/utils/config.js (commits date: 2014-03-15)
>>>>>>>
>>>>>>> But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
>>>>>>> I looked into all possible files I can think about that might cause the problems but still don't have any clues.
>>>>>>> I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
>>>>>>> The log where the trackster is not working:
>>>>>>> 1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda
>>>>>>>
>>>>>>> The log where the trackster is working (from the old installation):
>>>>>>> 1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
>>>>>>> 2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
>>>>>>> 3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..
>>>>>>>
>>>>>>> It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.
>>>>>>>
>>>>>>> Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)
>>>>>>>
>>>>>>> Any ideas or suggestions are appreciated.
>>>>>>>
>>>>>>> Thank you very much.
>>>>>>>
>>>>>>> Best,
>>>>>>> Shu-Yi
>>>>>>>
>>>>>>> <PastedGraphic-1.tiff>
>>>>>>>
>>>>>>> ___________________________________________________________
>>>>>>> Please keep all replies on the list by using "reply all"
>>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>>> and other Galaxy lists, please use the interface at:
>>>>>>> http://lists.bx.psu.edu/
>>>>>>>
>>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>>> http://galaxyproject.org/search/mailinglists/
>>>>>>
>>>>>> ___________________________________________________________
>>>>>> Please keep all replies on the list by using "reply all"
>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>> and other Galaxy lists, please use the interface at:
>>>>>> http://lists.bx.psu.edu/
>>>>>>
>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>> http://galaxyproject.org/search/mailinglists/
>>>>>
>>>>> ___________________________________________________________
>>>>> Please keep all replies on the list by using "reply all"
>>>>> in your mail client.  To manage your subscriptions to this
>>>>> and other Galaxy lists, please use the interface at:
>>>>> http://lists.bx.psu.edu/
>>>>>
>>>>> To search Galaxy mailing lists use the unified search at:
>>>>> http://galaxyproject.org/search/mailinglists/
>>>>
>>>
>>>
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>> http://lists.bx.psu.edu/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>> http://galaxyproject.org/search/mailinglists/
>>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>  http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Jeremy Goecks-4
I just downloaded a fresh copy of galaxy-dist and everything worked fine with Trackster. This suggests that your Galaxy installation is somehow corrupted. You’ll need to rollback any changes to your repository and/or start from a fresh copy.

Let us know if you need help doing this.

Best,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 27, 2014, at 4:28 AM, Shu-Yi Su <[hidden email]> wrote:

> Hi Jeremy,
>
> I reverted the files that I have changed, and also cleaned the cache once again.  The error messages are the same:
>
> Failed to load resource: the server responded with a status of 404 (Not Found)
> require.js:1:1910Error: Script error for: libs/backbone/backbone-relational
> http://requirejs.org/docs/errors.html#scripterror
> http://gbcs-dev/galaxy-dev/static/scripts/utils/galaxy.utils.jsFailed to load resource: the server responded with a status of 404 (Not Found)
> require.js:1:1910Error: Script error for: utils/galaxy.utils
> http://requirejs.org/docs/errors.html#scripterror
>
> Thanks a lot…..
>
> Best,
> Shu-Yi
>
> On Mar 27, 2014, at 12:00 AM, Jeremy Goecks wrote:
>
>> The next step then is to revert all the changes that you pulled from -central and report back the errors you’re seeing. Manually pulling selected change sets can be problematic if you don’t get all the dependencies.
>>
>> Best,
>> J.
>>
>> --
>> Jeremy Goecks
>> Assistant Professor of Computational Biology
>> George Washington University
>>
>>
>>
>> On Mar 26, 2014, at 11:04 AM, Shu-Yi Su <[hidden email]> wrote:
>>
>>> Hi Jeremy,
>>>
>>> I cleaned the catche on both safari and firefox, but it doesn't work. It still shows the same error messages.
>>>
>>> Thank you very much for the help!!
>>>
>>> Best,
>>> Shu-Yi
>>>
>>> On Mar 26, 2014, at 2:00 PM, Jeremy Goecks wrote:
>>>
>>>> This sounds like a cache issue. Both of these scripts have been removed from the distribution, so they should be absent from the distribution. Can you try clearing your cache and see if that fixes the issue?
>>>>
>>>> Thanks,
>>>> J.
>>>>
>>>> --
>>>> Jeremy Goecks
>>>> Assistant Professor of Computational Biology
>>>> George Washington University
>>>>
>>>>
>>>>
>>>> On Mar 26, 2014, at 4:39 AM, Charles Girardot <[hidden email]> wrote:
>>>>
>>>>> Hi Jeremy,
>>>>>
>>>>> After checking, the two js scripts are absent from the release:
>>>>>
>>>>> backbone-relational.js ( static/scripts/packed/libs/backbone/ )
>>>>> galaxy.utils.js ( static/scripts/packed/utils/ )
>>>>>
>>>>> bw
>>>>>
>>>>> C
>>>>>
>>>>> On 25 Mar 2014, at 16:16, Shu-Yi Su wrote:
>>>>>
>>>>>> Hi Jeremy,
>>>>>>
>>>>>> Thank you very much for the reply.
>>>>>>
>>>>>> Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
>>>>>> I have tried safari and firefox. Both are not working.
>>>>>> Here is the error massage from console:
>>>>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
>>>>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
>>>>>> [Error] Error: Script error for: libs/backbone/backbone-relational
>>>>>> http://requirejs.org/docs/errors.html#scripterror
>>>>>> defaultOnError (require.js, line 1)
>>>>>> onError (require.js, line 1)
>>>>>> onScriptError (require.js, line 1)
>>>>>> [Error] Error: Script error for: utils/galaxy.utils
>>>>>> http://requirejs.org/docs/errors.html#scripterror
>>>>>> defaultOnError (require.js, line 1)
>>>>>> onError (require.js, line 1)
>>>>>> onScriptError (require.js, line 1);;;
>>>>>>
>>>>>> We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.
>>>>>>
>>>>>> Thank you.
>>>>>>
>>>>>> Best,
>>>>>> Shu-Yi
>>>>>>
>>>>>>
>>>>>> On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:
>>>>>>
>>>>>>> Providing some additional information will help diagnose the problem:
>>>>>>>
>>>>>>> *are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
>>>>>>> *which Web browser are you using?
>>>>>>> *can you please open the JavaScript console in your browser and provide any errors that you see?
>>>>>>>
>>>>>>> Thanks,
>>>>>>> J.
>>>>>>>
>>>>>>> --
>>>>>>> Jeremy Goecks
>>>>>>> Assistant Professor of Computational Biology
>>>>>>> George Washington University
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:
>>>>>>>
>>>>>>>> Hi all,
>>>>>>>>
>>>>>>>> We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
>>>>>>>> ./static/scripts/viz/trackster.js (commits date: 2014-02-28)
>>>>>>>> ./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
>>>>>>>> ./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
>>>>>>>> ./static/scripts/utils/utils.js (commits date: 2014-03-19)
>>>>>>>> ./static/scripts/utils/config.js (commits date: 2014-03-15)
>>>>>>>>
>>>>>>>> But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
>>>>>>>> I looked into all possible files I can think about that might cause the problems but still don't have any clues.
>>>>>>>> I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
>>>>>>>> The log where the trackster is not working:
>>>>>>>> 1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda
>>>>>>>>
>>>>>>>> The log where the trackster is working (from the old installation):
>>>>>>>> 1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
>>>>>>>> 2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
>>>>>>>> 3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..
>>>>>>>>
>>>>>>>> It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.
>>>>>>>>
>>>>>>>> Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)
>>>>>>>>
>>>>>>>> Any ideas or suggestions are appreciated.
>>>>>>>>
>>>>>>>> Thank you very much.
>>>>>>>>
>>>>>>>> Best,
>>>>>>>> Shu-Yi
>>>>>>>>
>>>>>>>> <PastedGraphic-1.tiff>
>>>>>>>>
>>>>>>>> ___________________________________________________________
>>>>>>>> Please keep all replies on the list by using "reply all"
>>>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>>>> and other Galaxy lists, please use the interface at:
>>>>>>>> http://lists.bx.psu.edu/
>>>>>>>>
>>>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>>>> http://galaxyproject.org/search/mailinglists/
>>>>>>>
>>>>>>> ___________________________________________________________
>>>>>>> Please keep all replies on the list by using "reply all"
>>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>>> and other Galaxy lists, please use the interface at:
>>>>>>> http://lists.bx.psu.edu/
>>>>>>>
>>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>>> http://galaxyproject.org/search/mailinglists/
>>>>>>
>>>>>> ___________________________________________________________
>>>>>> Please keep all replies on the list by using "reply all"
>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>> and other Galaxy lists, please use the interface at:
>>>>>> http://lists.bx.psu.edu/
>>>>>>
>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>> http://galaxyproject.org/search/mailinglists/
>>>>>
>>>>
>>>>
>>>> ___________________________________________________________
>>>> Please keep all replies on the list by using "reply all"
>>>> in your mail client.  To manage your subscriptions to this
>>>> and other Galaxy lists, please use the interface at:
>>>> http://lists.bx.psu.edu/
>>>>
>>>> To search Galaxy mailing lists use the unified search at:
>>>> http://galaxyproject.org/search/mailinglists/
>>>
>>
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>> http://lists.bx.psu.edu/
>>
>> To search Galaxy mailing lists use the unified search at:
>> http://galaxyproject.org/search/mailinglists/
>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Shu-Yi Su-2
Hi Jeremy,

Which version you download, the most latest one or vrelease_2014.02.10--2--29ce93a13ac7?

Thank you very much.
Best,
Shu-Yi

On Mar 28, 2014, at 10:47 PM, Jeremy Goecks wrote:

> I just downloaded a fresh copy of galaxy-dist and everything worked fine with Trackster. This suggests that your Galaxy installation is somehow corrupted. You’ll need to rollback any changes to your repository and/or start from a fresh copy.
>
> Let us know if you need help doing this.
>
> Best,
> J.
>
> --
> Jeremy Goecks
> Assistant Professor of Computational Biology
> George Washington University
>
>
>
> On Mar 27, 2014, at 4:28 AM, Shu-Yi Su <[hidden email]> wrote:
>
>> Hi Jeremy,
>>
>> I reverted the files that I have changed, and also cleaned the cache once again.  The error messages are the same:
>>
>> Failed to load resource: the server responded with a status of 404 (Not Found)
>> require.js:1:1910Error: Script error for: libs/backbone/backbone-relational
>> http://requirejs.org/docs/errors.html#scripterror
>> http://gbcs-dev/galaxy-dev/static/scripts/utils/galaxy.utils.jsFailed to load resource: the server responded with a status of 404 (Not Found)
>> require.js:1:1910Error: Script error for: utils/galaxy.utils
>> http://requirejs.org/docs/errors.html#scripterror
>>
>> Thanks a lot…..
>>
>> Best,
>> Shu-Yi
>>
>> On Mar 27, 2014, at 12:00 AM, Jeremy Goecks wrote:
>>
>>> The next step then is to revert all the changes that you pulled from -central and report back the errors you’re seeing. Manually pulling selected change sets can be problematic if you don’t get all the dependencies.
>>>
>>> Best,
>>> J.
>>>
>>> --
>>> Jeremy Goecks
>>> Assistant Professor of Computational Biology
>>> George Washington University
>>>
>>>
>>>
>>> On Mar 26, 2014, at 11:04 AM, Shu-Yi Su <[hidden email]> wrote:
>>>
>>>> Hi Jeremy,
>>>>
>>>> I cleaned the catche on both safari and firefox, but it doesn't work. It still shows the same error messages.
>>>>
>>>> Thank you very much for the help!!
>>>>
>>>> Best,
>>>> Shu-Yi
>>>>
>>>> On Mar 26, 2014, at 2:00 PM, Jeremy Goecks wrote:
>>>>
>>>>> This sounds like a cache issue. Both of these scripts have been removed from the distribution, so they should be absent from the distribution. Can you try clearing your cache and see if that fixes the issue?
>>>>>
>>>>> Thanks,
>>>>> J.
>>>>>
>>>>> --
>>>>> Jeremy Goecks
>>>>> Assistant Professor of Computational Biology
>>>>> George Washington University
>>>>>
>>>>>
>>>>>
>>>>> On Mar 26, 2014, at 4:39 AM, Charles Girardot <[hidden email]> wrote:
>>>>>
>>>>>> Hi Jeremy,
>>>>>>
>>>>>> After checking, the two js scripts are absent from the release:
>>>>>>
>>>>>> backbone-relational.js ( static/scripts/packed/libs/backbone/ )
>>>>>> galaxy.utils.js ( static/scripts/packed/utils/ )
>>>>>>
>>>>>> bw
>>>>>>
>>>>>> C
>>>>>>
>>>>>> On 25 Mar 2014, at 16:16, Shu-Yi Su wrote:
>>>>>>
>>>>>>> Hi Jeremy,
>>>>>>>
>>>>>>> Thank you very much for the reply.
>>>>>>>
>>>>>>> Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
>>>>>>> I have tried safari and firefox. Both are not working.
>>>>>>> Here is the error massage from console:
>>>>>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
>>>>>>> [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
>>>>>>> [Error] Error: Script error for: libs/backbone/backbone-relational
>>>>>>> http://requirejs.org/docs/errors.html#scripterror
>>>>>>> defaultOnError (require.js, line 1)
>>>>>>> onError (require.js, line 1)
>>>>>>> onScriptError (require.js, line 1)
>>>>>>> [Error] Error: Script error for: utils/galaxy.utils
>>>>>>> http://requirejs.org/docs/errors.html#scripterror
>>>>>>> defaultOnError (require.js, line 1)
>>>>>>> onError (require.js, line 1)
>>>>>>> onScriptError (require.js, line 1);;;
>>>>>>>
>>>>>>> We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.
>>>>>>>
>>>>>>> Thank you.
>>>>>>>
>>>>>>> Best,
>>>>>>> Shu-Yi
>>>>>>>
>>>>>>>
>>>>>>> On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:
>>>>>>>
>>>>>>>> Providing some additional information will help diagnose the problem:
>>>>>>>>
>>>>>>>> *are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
>>>>>>>> *which Web browser are you using?
>>>>>>>> *can you please open the JavaScript console in your browser and provide any errors that you see?
>>>>>>>>
>>>>>>>> Thanks,
>>>>>>>> J.
>>>>>>>>
>>>>>>>> --
>>>>>>>> Jeremy Goecks
>>>>>>>> Assistant Professor of Computational Biology
>>>>>>>> George Washington University
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:
>>>>>>>>
>>>>>>>>> Hi all,
>>>>>>>>>
>>>>>>>>> We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
>>>>>>>>> ./static/scripts/viz/trackster.js (commits date: 2014-02-28)
>>>>>>>>> ./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
>>>>>>>>> ./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
>>>>>>>>> ./static/scripts/utils/utils.js (commits date: 2014-03-19)
>>>>>>>>> ./static/scripts/utils/config.js (commits date: 2014-03-15)
>>>>>>>>>
>>>>>>>>> But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
>>>>>>>>> I looked into all possible files I can think about that might cause the problems but still don't have any clues.
>>>>>>>>> I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
>>>>>>>>> The log where the trackster is not working:
>>>>>>>>> 1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda
>>>>>>>>>
>>>>>>>>> The log where the trackster is working (from the old installation):
>>>>>>>>> 1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
>>>>>>>>> 2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
>>>>>>>>> 3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..
>>>>>>>>>
>>>>>>>>> It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.
>>>>>>>>>
>>>>>>>>> Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)
>>>>>>>>>
>>>>>>>>> Any ideas or suggestions are appreciated.
>>>>>>>>>
>>>>>>>>> Thank you very much.
>>>>>>>>>
>>>>>>>>> Best,
>>>>>>>>> Shu-Yi
>>>>>>>>>
>>>>>>>>> <PastedGraphic-1.tiff>
>>>>>>>>>
>>>>>>>>> ___________________________________________________________
>>>>>>>>> Please keep all replies on the list by using "reply all"
>>>>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>>>>> and other Galaxy lists, please use the interface at:
>>>>>>>>> http://lists.bx.psu.edu/
>>>>>>>>>
>>>>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>>>>> http://galaxyproject.org/search/mailinglists/
>>>>>>>>
>>>>>>>> ___________________________________________________________
>>>>>>>> Please keep all replies on the list by using "reply all"
>>>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>>>> and other Galaxy lists, please use the interface at:
>>>>>>>> http://lists.bx.psu.edu/
>>>>>>>>
>>>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>>>> http://galaxyproject.org/search/mailinglists/
>>>>>>>
>>>>>>> ___________________________________________________________
>>>>>>> Please keep all replies on the list by using "reply all"
>>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>>> and other Galaxy lists, please use the interface at:
>>>>>>> http://lists.bx.psu.edu/
>>>>>>>
>>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>>> http://galaxyproject.org/search/mailinglists/
>>>>>>
>>>>>
>>>>>
>>>>> ___________________________________________________________
>>>>> Please keep all replies on the list by using "reply all"
>>>>> in your mail client.  To manage your subscriptions to this
>>>>> and other Galaxy lists, please use the interface at:
>>>>> http://lists.bx.psu.edu/
>>>>>
>>>>> To search Galaxy mailing lists use the unified search at:
>>>>> http://galaxyproject.org/search/mailinglists/
>>>>
>>>
>>>
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>> http://lists.bx.psu.edu/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>> http://galaxyproject.org/search/mailinglists/
>>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>  http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>  http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Jeremy Goecks-4
I cloned directly from galaxy-dist:


 which gives you the latest release, and it is 2014.02.10--2–29ce93a13ac7

Best,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 29, 2014, at 3:02 AM, Shu-Yi Su <[hidden email]> wrote:

Hi Jeremy,

Which version you download, the most latest one or vrelease_2014.02.10--2--29ce93a13ac7?

Thank you very much.
Best,
Shu-Yi

On Mar 28, 2014, at 10:47 PM, Jeremy Goecks wrote:

I just downloaded a fresh copy of galaxy-dist and everything worked fine with Trackster. This suggests that your Galaxy installation is somehow corrupted. You’ll need to rollback any changes to your repository and/or start from a fresh copy.

Let us know if you need help doing this.

Best,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 27, 2014, at 4:28 AM, Shu-Yi Su <[hidden email]> wrote:

Hi Jeremy,

I reverted the files that I have changed, and also cleaned the cache once again.  The error messages are the same:

Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:1:1910Error: Script error for: libs/backbone/backbone-relational
http://requirejs.org/docs/errors.html#scripterror
http://gbcs-dev/galaxy-dev/static/scripts/utils/galaxy.utils.jsFailed to load resource: the server responded with a status of 404 (Not Found)
require.js:1:1910Error: Script error for: utils/galaxy.utils
http://requirejs.org/docs/errors.html#scripterror

Thanks a lot…..

Best,
Shu-Yi

On Mar 27, 2014, at 12:00 AM, Jeremy Goecks wrote:

The next step then is to revert all the changes that you pulled from -central and report back the errors you’re seeing. Manually pulling selected change sets can be problematic if you don’t get all the dependencies.

Best,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 26, 2014, at 11:04 AM, Shu-Yi Su <[hidden email]> wrote:

Hi Jeremy,

I cleaned the catche on both safari and firefox, but it doesn't work. It still shows the same error messages.

Thank you very much for the help!!

Best,
Shu-Yi

On Mar 26, 2014, at 2:00 PM, Jeremy Goecks wrote:

This sounds like a cache issue. Both of these scripts have been removed from the distribution, so they should be absent from the distribution. Can you try clearing your cache and see if that fixes the issue?

Thanks,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 26, 2014, at 4:39 AM, Charles Girardot <[hidden email]> wrote:

Hi Jeremy,

After checking, the two js scripts are absent from the release:

backbone-relational.js ( static/scripts/packed/libs/backbone/ )
galaxy.utils.js ( static/scripts/packed/utils/ )

bw

C

On 25 Mar 2014, at 16:16, Shu-Yi Su wrote:

Hi Jeremy,

Thank you very much for the reply.

Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
I have tried safari and firefox. Both are not working.
Here is the error massage from console:
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
[Error] Error: Script error for: libs/backbone/backbone-relational
http://requirejs.org/docs/errors.html#scripterror
defaultOnError (require.js, line 1)
onError (require.js, line 1)
onScriptError (require.js, line 1)
[Error] Error: Script error for: utils/galaxy.utils
http://requirejs.org/docs/errors.html#scripterror
defaultOnError (require.js, line 1)
onError (require.js, line 1)
onScriptError (require.js, line 1);;;

We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.

Thank you.

Best,
Shu-Yi


On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:

Providing some additional information will help diagnose the problem:

*are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
*which Web browser are you using?
*can you please open the JavaScript console in your browser and provide any errors that you see?

Thanks,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:

Hi all,

We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
./static/scripts/viz/trackster.js (commits date: 2014-02-28)
./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
./static/scripts/utils/utils.js (commits date: 2014-03-19)
./static/scripts/utils/config.js (commits date: 2014-03-15)

But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
I looked into all possible files I can think about that might cause the problems but still don't have any clues.
I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
The log where the trackster is not working:
1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda

The log where the trackster is working (from the old installation):
1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..

It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.

Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)

Any ideas or suggestions are appreciated.

Thank you very much.

Best,
Shu-Yi

<PastedGraphic-1.tiff>

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
| Threaded
Open this post in threaded view
|

Re: trackster is not working on the vrelease_2014.02.10--2--29ce93a13ac7

Shu-Yi Su-2
Hi Jeremy,

We found that the vis packed files were somehow not updated when we did the Galaxy updates. So, we manually update these files and now the trackster is working fine.

Thank you very much for the help!!

Best,
Shu-Yi

 On Mar 29, 2014, at 7:51 PM, Jeremy Goecks wrote:

I cloned directly from galaxy-dist:


 which gives you the latest release, and it is 2014.02.10--2–29ce93a13ac7

Best,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 29, 2014, at 3:02 AM, Shu-Yi Su <[hidden email]> wrote:

Hi Jeremy,

Which version you download, the most latest one or vrelease_2014.02.10--2--29ce93a13ac7?

Thank you very much.
Best,
Shu-Yi

On Mar 28, 2014, at 10:47 PM, Jeremy Goecks wrote:

I just downloaded a fresh copy of galaxy-dist and everything worked fine with Trackster. This suggests that your Galaxy installation is somehow corrupted. You’ll need to rollback any changes to your repository and/or start from a fresh copy.

Let us know if you need help doing this.

Best,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 27, 2014, at 4:28 AM, Shu-Yi Su <[hidden email]> wrote:

Hi Jeremy,

I reverted the files that I have changed, and also cleaned the cache once again.  The error messages are the same:

Failed to load resource: the server responded with a status of 404 (Not Found)
require.js:1:1910Error: Script error for: libs/backbone/backbone-relational
http://requirejs.org/docs/errors.html#scripterror
http://gbcs-dev/galaxy-dev/static/scripts/utils/galaxy.utils.jsFailed to load resource: the server responded with a status of 404 (Not Found)
require.js:1:1910Error: Script error for: utils/galaxy.utils
http://requirejs.org/docs/errors.html#scripterror

Thanks a lot…..

Best,
Shu-Yi

On Mar 27, 2014, at 12:00 AM, Jeremy Goecks wrote:

The next step then is to revert all the changes that you pulled from -central and report back the errors you’re seeing. Manually pulling selected change sets can be problematic if you don’t get all the dependencies.

Best,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 26, 2014, at 11:04 AM, Shu-Yi Su <[hidden email]> wrote:

Hi Jeremy,

I cleaned the catche on both safari and firefox, but it doesn't work. It still shows the same error messages.

Thank you very much for the help!!

Best,
Shu-Yi

On Mar 26, 2014, at 2:00 PM, Jeremy Goecks wrote:

This sounds like a cache issue. Both of these scripts have been removed from the distribution, so they should be absent from the distribution. Can you try clearing your cache and see if that fixes the issue?

Thanks,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 26, 2014, at 4:39 AM, Charles Girardot <[hidden email]> wrote:

Hi Jeremy,

After checking, the two js scripts are absent from the release:

backbone-relational.js ( static/scripts/packed/libs/backbone/ )
galaxy.utils.js ( static/scripts/packed/utils/ )

bw

C

On 25 Mar 2014, at 16:16, Shu-Yi Su wrote:

Hi Jeremy,

Thank you very much for the reply.

Yes, we are running on galaxy-dist, and manually pulled to update our installation. The release version is vrelease_2014.02.10--2--29ce93a13ac7.
I have tried safari and firefox. Both are not working.
Here is the error massage from console:
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (backbone-relational.js, line 0)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (galaxy.utils.js, line 0)
[Error] Error: Script error for: libs/backbone/backbone-relational
http://requirejs.org/docs/errors.html#scripterror
defaultOnError (require.js, line 1)
onError (require.js, line 1)
onScriptError (require.js, line 1)
[Error] Error: Script error for: utils/galaxy.utils
http://requirejs.org/docs/errors.html#scripterror
defaultOnError (require.js, line 1)
onError (require.js, line 1)
onScriptError (require.js, line 1);;;

We are also wondering if there is anything we didn't set up probably for our universe_wsgi.ini file.

Thank you.

Best,
Shu-Yi


On Mar 25, 2014, at 4:05 PM, Jeremy Goecks wrote:

Providing some additional information will help diagnose the problem:

*are you running galaxy-dist? If so, have you manually pulled and applied commits from galaxy-central? If so, which ones?
*which Web browser are you using?
*can you please open the JavaScript console in your browser and provide any errors that you see?

Thanks,
J.

--
Jeremy Goecks
Assistant Professor of Computational Biology
George Washington University



On Mar 24, 2014, at 11:38 AM, Shu-Yi Su <[hidden email]> wrote:

Hi all,

We have recently updated our local Galaxy installation to  vrelease_2014.02.10--2--29ce93a13ac7 (database version is 118). I found that the Trackster is not working. I have checked the latest commits related to Trackster bugs. So i have updated theses files:
./static/scripts/viz/trackster.js (commits date: 2014-02-28)
./static/scripts/viz/trackster_ui.js (commits date: 2014-02-28)
./static/scripts/viz/trackster/tracks.js (commits date: 2014-03-16)
./static/scripts/utils/utils.js (commits date: 2014-03-19)
./static/scripts/utils/config.js (commits date: 2014-03-15)

But, it is still not working. I have tried different format…bam, bed, sam….all are not working.
I looked into all possible files I can think about that might cause the problems but still don't have any clues.
I also looked into the log, and there is no error, but i noticed that there is difference from the log where the trackster was working in previous installation.
The log where the trackster is not working:
1. "GET /galaxy-dev/visualization/trackster?dataset_id=f04ecb1d3d259245&hda_ldda=hda

The log where the trackster is working (from the old installation):
1. "GET /galaxy/visualization/trackster?dataset_id=5d38b380cba2f4a6&hda_ldda=hda……
2. "GET /galaxy/api/datasets/5d38b380cba2f4a6?hda_ldda=hda&data_type=converted_datasets_state….
3. "GET /galaxy/api/datasets/5d38b380cba2f4a6?data_type=data&chrom=chr2L…..

It looks like that the trackster in new version of Galaxy does not execute the second and the third steps.

Here is the screen shot when i clicked "View in new visualization" (there is nothing shown up---blank)

Any ideas or suggestions are appreciated.

Thank you very much.

Best,
Shu-Yi

<PastedGraphic-1.tiff>

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
http://galaxyproject.org/search/mailinglists/




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/