uWSGI threading issue

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

uWSGI threading issue

Durdevic, Marija

Dear developers,

Since last Galaxy upgrade some issue with uwsgi and threading arise.
I used Galaxy documentation as a guideline to configure galaxy.yml:

  buffer-size: 16384
  processes: 4
  threads: 8
  offload-threads: 2
  static-map: /static/style=static/style/blue
  static-map: /static=static
  master: true
  virtualenv: .venv
  pythonpath: lib
  module: galaxy.webapps.galaxy.buildapp:uwsgi_app()
  thunder-lock: true
  die-on-term: true
  hook-master-start: unix_signal:2 gracefully_kill_them_all
  hook-master-start: unix_signal:15 gracefully_kill_them_all
  py-call-osafterfork: true
  enable-threads: true  
  mule: lib/galaxy/main.py
  mule: lib/galaxy/main.py
  mule: lib/galaxy/main.py
  farm: job-handlers:1,2,3

When I run Galaxy, I got error message - error: can't start new thread

Also if I run some job which require a lot of threads, I always get error message - RuntimeError: can't start new thread
I tried to increase number of processes in /etc/security/limits.conf for galaxy user but it didn’t help.

What can be solution? Do you have any idea what could be wrong?

Thanks a lot for your support.



Marija Đurđević

PhD, Diagnostic & Research Center for Molecular BioMedicine

Institute of Pathology

Bioinformatician, Core Facility Computational Bioanalytics

Center for Medical Research

Medical University of Graz
Stiftingtalstraße 24, A-8010 Graz

Phone: +43 316/385-73024
Fax:+43 316/385-73009

Email: [hidden email]
Email: [hidden email]

Web: https://zmf.medunigraz.at


Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at: